Solved

Dell XPS - Slow connecting to wireless network

Posted on 2016-09-09
20
43 Views
Last Modified: 2016-11-22
Hi All,
I need your assistance with my laptop. Every time I restart my laptop it takes about 5 to 7 minutes to connect to my wireless network, not only it takes a long time to connect, while is connecting if I double click on any program such firefox, word or excel it also takes a long time to open these, the whole system slows to a crawl while is connecting to the wireless network.

Once the laptop connects to the wireless network then everything is okay, no issues like nothing happened.

I have reinstalled windows, updated drivers including Intel Centrino, windows is up to date. All other devices connect to my wireless network quick and easy without any issues.

Any ideas how can I fix this? Is really frustrating.

Wireless Router: BiPAC 7800N - Dual WAN ADSL2+ Firewall Router
Laptop details below.:

OS Name      Microsoft Windows 7 Professional      
Version      6.1.7601 Service Pack 1 Build 7601
System Manufacturer      Dell Inc.      
System Model      Dell System XPS L702X      
System Type      x64-based PC      
Processor      Intel(R) Core(TM) i7-2670QM CPU @ 2.20GHz, 2201 Mhz, 4 Core(s), 8 Logical Processor(s)      

BIOS Version/Date      Dell Inc. A14, 11/11/2011      
SMBIOS Version      2.6      
Windows Directory      C:\Windows      
System Directory      C:\Windows\system32      
Boot Device      \Device\HarddiskVolume1      

Installed Physical Memory (RAM)      8.00 GB      
Total Physical Memory      7.90 GB      
Available Physical Memory      5.52 GB      
Total Virtual Memory      15.8 GB      
Available Virtual Memory      12.9 GB      
Page File Space      7.90 GB      
Page File      C:\pagefile.sys      

Name      [00000012] Intel(R) Centrino(R) Advanced-N 6230      
Adapter Type      Ethernet 802.3      
Product Type      Intel(R) Centrino(R) Advanced-N 6230      
Installed      Yes
0
Comment
Question by:jose11au
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 8
  • 4
  • 3
  • +3
20 Comments
 
LVL 94

Assisted Solution

by:John Hurst
John Hurst earned 125 total points (awarded by participants)
ID: 41792087
Delete the Wireless Profile and make a new fresh profile.

From an admin command prompt.

netsh wlan delete profile name="name of profile"

Then use the Wi-Fi icon to make a new profile.
0
 
LVL 27

Expert Comment

by:Dr. Klahn
ID: 41792097
If you're not using any of the Microsoft Networking features (i.e., you only use the network for internet access, not things like sharing files or printing to another computer on the network), try disabling:

  • Client for Microsoft Networks
  • QOS Packet Scheduler
  • File and Printer Sharing for Microsoft Networks
  • Link Layer Topology Discovery Mapper I/O Driver
  • Link Layer Topology Responder

in the WiFi connection profile and see if that improves the situation.

See this page for a more detailed commentary.
0
 
LVL 94

Expert Comment

by:John Hurst
ID: 41792099
Disabling the suggested things will not speed up Wi-Fi (not on any machine I know) but will have a detrimental effect on operations. In my opinion, do not disable these things.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 27

Expert Comment

by:Dr. Klahn
ID: 41792103
Here we must agree to disagree.  It is within the pale that one of them may bear on the problem; if so, it is worth checking that possibility.
0
 
LVL 94

Expert Comment

by:John Hurst
ID: 41792104
As I noted, even disabled, Wi-Fi won't speed up. Been there and done that.

Then I get clients "Someone messed with my computer at the hotel and now I cannot connect to anything"

I am just stating my own viewpoint of the trouble that follows disabling long standing Microsoft Protocols .
0
 

Author Comment

by:jose11au
ID: 41792106
Hi,

Thank you for your help. I tried both suggestions but issue remains.

Anymore ideas?

Thanks.
0
 
LVL 17

Assisted Solution

by:pjam
pjam earned 125 total points (awarded by participants)
ID: 41792107
Change roaming aggressiveness of network adapter in network settings.
0
 
LVL 94

Expert Comment

by:John Hurst
ID: 41792108
Try two things:

1. Uninstall the wireless card (Device Manager) , shut down, start up and install it again.

2. Run System File Checker. Open cmd.exe with Run as Administrator and run SFC /SCANNOW. Allow to complete and restart again
0
 

Author Comment

by:jose11au
ID: 41792149
Hi - I tried the suggestions below but the issue remains. Any other suggestions please?

- Change roaming aggressiveness
- Uninstall the wireless card (Device Manager)  and Run System File Checker.

Many Thanks.
0
 
LVL 94

Expert Comment

by:John Hurst
ID: 41792150
Have you tried a different network. We assumed it was an issue with your computer because you say all other devices connect properly.

But at this point, see if your computer connects properly with a different network.
0
 

Author Comment

by:jose11au
ID: 41792154
Hi - I just connected to my neighbours wireless connection, same thing, it took about six minutes to connect but my other devices connected within seconds.

I am at a lost with this issue.
0
 
LVL 94

Expert Comment

by:John Hurst
ID: 41792157
So your computer is in trouble. With all you have done, you now should consider a Windows 7 Repair Install. You should back up first and you need the Windows 7 DVD. Here is a Seven Forums tutorial to assist.

http://www.sevenforums.com/tutorials/3413-repair-install.html

As a point of reference, I have all the protocols enabled on my Wi-Fi card and aggressive roaming is set at medium. My Wi-Fi connects quickly before I log on to my computer (Windows 10 Pro and Intel card (N6205) similar to yours.
0
 
LVL 6

Accepted Solution

by:
K_Wilke earned 125 total points (awarded by participants)
ID: 41792585
Disable IPv6 on the wireless card (just un-checkmark it in TCP/IP properties of the wireless card).
Sometimes IPv6 loves to be the master of everything.
0
 
LVL 94

Expert Comment

by:John Hurst
ID: 41792587
In a properly running machine, IPv6 does not cause any issues. So long as IPv4 is also installed, you can safely leave IPv6 installed also.
0
 
LVL 6

Expert Comment

by:K_Wilke
ID: 41792636
I politely disagree....Windows implements RFC 3484 and uses a prefix table to determine which address to use when multiple addresses are available for a name.

By default, it favors IPv6  addresses over IPv4 addresses therefore IPv6 takes precedence over IPv4.

https://tools.ietf.org/html/rfc3484

Therefore if you don't want IPv6 broadcasting on your network and you are not using IPv6 then it should be disabled.
0
 

Author Comment

by:jose11au
ID: 41793036
Hi All,

I tried repairing Windows 7, disabled IPv6 on the wireless card and change aggressive roaming to medium but no change, the issue remains.

Not really sure whats going on with the laptop, I guess a clean install may be necessary.

Thanks.
0
 
LVL 94

Assisted Solution

by:John Hurst
John Hurst earned 125 total points (awarded by participants)
ID: 41793039
Since a Repair Install did not fix the issue, then, yes, now you must back up the system (documents and data), format and reinstall Windows. That will be the best for long term stability.

Be sure to install Windows 7 SP1 or download SP1 and install it first
0
 
LVL 6

Expert Comment

by:K_Wilke
ID: 41793395
Did you update the driver for the wireless card?
0
 
LVL 27

Assisted Solution

by:masnrock
masnrock earned 125 total points (awarded by participants)
ID: 41796163
Have you tried resetting Winsock and the TCP/IP stack? If so, you're down to one of two possibilities:
1) Windows is screwed up and needs a reinstall as John has pointed out.
2) Your wireless card might have issues.

If possible, I'd recommend seeing if you can borrow a USB wireless card and see if the same issue occurs.
0
 
LVL 27

Expert Comment

by:Dr. Klahn
ID: 41825210
System requested stale question close
0

Featured Post

Don't miss ATEN at NAB Show April 24-27!

Visit ATEN at NAB Show to learn how our "Seamlessly Entertaining" solutions deliver fast, precise video streaming without delays for the broadcasting and media environment. ATEN will showcase its 16x16 Modular Matrix Switch (VM1600) and KVM Over IP Solution (KE6900 series).

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Server 2012 R2 Hyper 12 42
ATI Radeon HD 5450 video card problem? 12 71
Restart "sometimes" fails 11 41
How to add a second 1TB SSD to a pc 16 27
Need WiFi? Often, there are perfectly good networks that don't have WiFi capability - and there's a need to add it.  - Perhaps you have an Ethernet port into a network but no WiFi nearby. - Perhaps you have a powerline extender and no WiFi at the…
Arrow Electronics was searching for a KVM  (Keyboard/Video/Mouse) switch that could display on one single monitor the current status of all units being tested on the rack.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question