Solved

Avast install stuck on virtual machine

Posted on 2016-09-11
3
163 Views
Last Modified: 2016-09-19
Hello
I am using VMware and have Windows 10 running as a virtual machine. It is a copy of my main system, not a fresh install.
I have no anti virus on my VM so I tried to install AVAST free edition.
Issue is = the install process is stuck at the first step; I see the pop up window attached; it is there all the time and won't go to the next step, even after 1h waiting...
Is there any specific issue with AV installation on a virtual machine? I tried to install another software (VLC player) and It went well...
Thanks
avast-2016-installation-loading.jpg
0
Comment
Question by:gallandjc
3 Comments
 
LVL 7

Assisted Solution

by:Ned Ramsay
Ned Ramsay earned 250 total points
ID: 41793683
Avast can be pretty funny when installing.
If you are using Win10 I recommend using the built in Windows Defender as Microsoft have really made some big improvements.

I have also seen cheaper Antivirus try and remove "Vmware Tools" and other required VM software, so that may be part of it.
0
 
LVL 62

Accepted Solution

by:
btan earned 250 total points
ID: 41794173
Avast free AV has minimal req which I am supecting it may be detecting the below including internet connection - https://www.avast.com/faq.php?article=AVKB44#idt_100
- Windows 10 except Mobile and IoT Core Edition (32 or 64-bit);
- 256 MB RAM or above; 2 GB free space on the hard disk
- Internet connection (to download, activate and maintain updates of the program and antivirus database)
- Using Microsoft Windows operating systems without the latest Service Pack may not be supported.

There are other mentioned to disable defender
- http://windowsreport.com/windows-10-prevents-antivirus-install/
So far other has stated the below as compatible AV tested
Here’s the list of all ‘approved for Windows 10’ security programs created by AV-Comparatives:

Avast Free Antivirus 10.3.2223
AVG Internet Security 2015.0.6110
Avira Antivirus Pro 15.0.11.579
Bitdefender Internet Security 18.23.0.1604
BullGuard Internet Security 15.1.307
Emsisoft Anti-Malware 10.0.0.5561
ESET Smart Security 8.0.319.0
Fortinet FortiClient 5.2.3.0633
F-Secure Internet Security 15.3
Kaspersky Internet Security 16.0.0.614
Panda Free Antivirus 15.01.00.0006
Quick Heal Total Security 16.00 (9.0.0.46)
Sophos Enpoint Security and Control 10.3.12.312
Tencent PC Manager 10.11.25856.501
ThreatTrack VIPRE Internet Security 8.2.1.16
Trend Micro Internet Security 10.0.1150
http://windowsreport.com/windows-10-compatible-antivirus/

If all did not seems to progress, then suggest uninstall (use Avast uninstall tool) and do last try. If still stuck then suggest try other AV (see above-mentioned list) to see if this is common to other AVs.
0
 

Expert Comment

by:Khalid Mahmoud R. Abbas
ID: 41804690
Ok, sounds nice. Then I found several problem reports from users about this NG thing. For example, avast deleting users VirtualBox hard drives (in certain situation), NG process/service using max CPU for long period of times (sounded to me that those weren't normal "NG building up" CPU cycles), and finally what prompted me to write this topic: solution for system protection to 50% of hard drive with avast?.

For me too the System Protection was/is set to 50% when NG is enabled. That's about 220GB of space of my hard drive. Of course it's _max_ value, if available, which I don't have by the way.

I started watching the amount used for System Protection, aka System Restore. Now for few weeks (I've not rebooted, I use sleep mode) the "current usage" has been going from 0GB to about 16-20GB. The way the value behaves is that when it goes to about 16-20GB, next it is back to 0GB and starts growing until the 16-20GB and it goes to zero again. This cycle repeats itself over and over. FYI, I've had more space available when the value has gone to zero, not ~220GB but plenty more than ~20GB.

The negative thing about this? Well, every time when System Protection goes to 0GB, ALL your restore points are GONE. ALL.

I've seen the "current usage" going from 0 to the about 16-20GB and back to zero in 1-2 days. So, this renders the Windows System Protection totally useless.

I don't understand who in Avast thought that this is a good thing.

Incidentally just before I upgraded to the 2015 version and NG, I happened to check the system protection restore points (I was checking it for another thing) and there were many older restore points available. Few days using 2015 and NG, after I stumbled to the "system protection to 50%" topic I checked the settings and at the same time noticed that ALL of my restore points were gone.

Additionally it definitely was affecting normal use of Windows by slowing things down more even with a fairly powerful pc.

It's "uninstall NG time" I'm afraid. Back to using only File system shield.. that's all you need.
0

Featured Post

Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If we need to check who deleted a Virtual Machine from our vCenter. Looking this task in logs can be painful and spend lot of time, so the best way to check this is in the vCenter DB. Just connect to vCenter DB(default DB should be VCDB and using…
This article outlines why you need to choose a backup solution that protects your entire environment – including your VMware ESXi and Microsoft Hyper-V virtualization hosts – not just your virtual machines.
Teach the user how to install log collectors and how to configure ESXi 5.5 for remote logging Open console session and mount vCenter Server installer: Install vSphere Core Dump Collector: Install vSphere Syslog Collector: Open vSphere Client: Config…
This video shows you how to use a vSphere client to connect to your ESX host as the root user. Demonstrates the basic connection of bypassing certification set up. Demonstrates how to access the traditional view to begin managing your virtual mac…

778 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question