Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange 2010 External Out of Office not working - "550 5.5.0. Sender Domain is empty"

Posted on 2016-09-12
9
Medium Priority
?
208 Views
Last Modified: 2016-10-14
Hello Experts,

Our client's external OoO is not working or more likely being rejected. When I did Exchange message tracking on the automated reply, it fails with an error message: "550 5.5.0. Sender Domain is empty". The customer is using a Smart host pointing to our Fortimail appliance for a spam filtering, but I can't find the message being logged on our end anywhere (Fortimail). I've also disabled any Content filtering on customer's Exchange(for testing only) to no avail.

I know a workaround would be to use DNS (MX) records to route the mail out instead, but they'd get smashed with SPAM obviously..
Was somebody else experiencing this please?

Thanks a lot
Vlas
0
Comment
Question by:Vlastimil Sopuch
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 3
9 Comments
 
LVL 14

Expert Comment

by:Andy M
ID: 41794095
I'm assuming it all works fine internally.

As you are not seeing the Out Of Office on the logs on your fortinet then the problem would lie either with the client's Exchange or the smart host system. I've known some smarthosts utilsie anti-spam features that prevent out of office responses being sent previously.

On the client's exchange do the smtp logs show the out of office being sent to the smart host successfully or not?

You could temporarily setup a new send connector that just goes directly out (no smart host, just use DNS/MX). Sent that as the primary send connector, run some tests and then set it back again. If Out of Office works fine on that then I'd be looking at the smart host as being the issue in which case you'd need to contact them about it.
0
 
LVL 4

Author Comment

by:Vlastimil Sopuch
ID: 41795569
Yes, you're correct. The internal OoO works fine.

Hmmm, just did a test with the smart host off, using the DNS MX records and it fails with exactly the same error: "550 5.5.0. Sender Domain is empty" ..when I do Exchange message tracking for automatic reply.
- I haven't restarted the Exchange Transport service" before the test. Might need to re-test after hours again.
0
 
LVL 14

Assisted Solution

by:Andy M
Andy M earned 2000 total points
ID: 41795968
Came across this article which may be of use - same issue with Exchange 2007 and Fortinet systems (plus does mention same thing on Exchange 2010).

https://forum.fortinet.com/tm.aspx?m=81879

Yeah, if you make any changes to send/receive connectors it is always worth restarting the Exchange transport service as well to ensure the changes are correctly applied.
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 4

Author Comment

by:Vlastimil Sopuch
ID: 41797137
I came across similar article, but can you tell which policy to edit? FortiMail_PolicyThanks a lot!
0
 
LVL 14

Expert Comment

by:Andy M
ID: 41797771
I would guess it would be 16 and 17. Unfortunately I don't have a great deal of experience specifically with fortinet applications so not much use in actually changing the settings but those two seems to be rules applying to external systems.
0
 
LVL 4

Author Comment

by:Vlastimil Sopuch
ID: 41799131
I'm attaching all 4 policies currently created for review. If someone with more networking background could suggest what needs to be changed please. Or should a new policy be created? Thanks Fortimail_Policy.png
0
 
LVL 4

Accepted Solution

by:
Vlastimil Sopuch earned 0 total points
ID: 41836335
The fix was in Fortimail appliance / Policy / Policies - creating a new policy for the customer and unchecking the "Reject empty domains" under "Unauthenticated Session Settings".
0
 
LVL 4

Author Comment

by:Vlastimil Sopuch
ID: 41836337
Thank you Andy M for your help with this! Appreciated.
0
 
LVL 4

Author Closing Comment

by:Vlastimil Sopuch
ID: 41843328
The issue was resolved by further testing myself at the end.
0

Featured Post

Introducing the WatchGuard 420 Access Point

WatchGuard's newest access point includes an 802.11ac Wave 2 chipset, providing the fastest speeds for VoIP, video and music streaming, and large data file transfers. Additionally, enjoy the benefits of strong security as the 3rd radio delivers dedicated WIPS protection!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
The core idea of this article is to make you acquainted with the best way in which you can export Exchange mailbox to PST format.
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question