• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 182
  • Last Modified:

User not showing up in GAL

We have a hybrid environment, exchange 2010 on premise and all mailboxes in the cloud (365). We recently had a user change her name.

We cannot see your in the GLA nor the all users list, however if we put her part of her email address in a new email and do contrl-k it finds it.

This user is not seen on all peoples outlooks (2016)

Any suggestions?
  • 2
1 Solution
Vasil Michev (MVP)Commented:
How was the mailbox provisioned, directly in the cloud or migrated from on-prem? If the first, it will only be visible in the O365 GAL, not the on-prem one.

Also, maybe she's simply hidden from the GAL?
WycombeAbbeyAuthor Commented:
She was provisioned on prem, was all working and showing up. We changed her name, on prem and it does not show up. we have done this before and will worked  just this lady it does not seem to play ball.

She not hidden, though i did hide and unhide her in-case that would kick start anything. I also forced the address books to update via the prem EAC.
Vasil Michev (MVP)Commented:
I'd say check the object status and properties in the Metaverse, see if the new name is properly reflected there. Here's an example article to guide you: https://azure.microsoft.com/en-us/documentation/articles/active-directory-aadconnectsync-service-manager-ui-connectors/#follow-an-object-and-its-data-through-the-system
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now