http redirect does not work after renewal of certificate for Exchange 2010 web server.

We have recently renew the SSL certificate for our Exchange 2010 web server.  

The only issue right now is that when people do a http://mail.mydomain.com, it does not auto redirect to https://mail.mydomain.com.

Before renewal of the cert, http://mail.mydomain.com worked.  

Please advise where I should look at.

Thanks.
nav2567Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam BrownSr Solutions ArchitectCommented:
Check the HTTP redirect settings in IIS for the OWA virtual site. That's where the redirect is configured. If you run updates on Exchange or reset the virtual site you have to reconfigure the redirect because Exchange completely recreates the IIS Virtual site.
0
RantCanSr. Systems AdministratorCommented:
Look in IIS and make sure you have attached your renewed certificate to the Virtual Directories properly.

https://technet.microsoft.com/en-us/library/bb123583(v=exchg.141).aspx

Failing that, make sure your redirect in IIS did not reset when you assigned services to SSL in the EMS console:
https://support.microsoft.com/en-us/kb/975341
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nav2567Author Commented:
I have already checked the HTTP Redirect setting of the default web site on the HUB/CAS server and "Redirect requests to this destination" is checked and the field is "https://mail.mydomain.com/owa".  The "Only redirect requests to content in this directory not sub directories" is checked and status code is Found (302).
0
MAS (MVE)EE Solution GuideCommented:
Hi,
Please reset IIS and try.
iisreset /noforce

Open in new window

0
MAS (MVE)EE Solution GuideCommented:
I believe this can be closed as we have explained how to check and reconfigure the certificate.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.