Windows 7 Laptop cannot see any shares on Windows Server 2012 R2 but can see 2008 R2

I recently added another domain controller to a network and transferred the masters to make it the primary domain controller (replaced a 2008 R2 DC with 2012 R2 DC) - all seems fine with AD and 8 other computers, but 1 computer will not browse the new 2012 server anymore, it works fine to the old 2008 server and all the other machines see both just fine.  I tried messing with SMB and disabling SMB2 on laptop but still nothing.  DNS is running on new server and DNS1 of laptop is pointing to new server as well
dlaffertyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Windows 7 Pro works just fine with Server 2012 R2. For the one computer that has issues, run TCP/IP Reset and DNS Flush

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

Then in Advanced Network Sharing, make sure Network Discovery and File / Print are both ON and make sure Homegroup is ON.

After doing the above, disjoin the computer from the domain, restart and re-add it to the domain.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
FOXActive Directory/Exchange EngineerCommented:
on the windows 7 machine...try
Control Panel>Network and Sharing> (left side)Changed advanced Sharing settings> turn on Network discovery
JohnBusiness Consultant (Owner)Commented:
@dlafferty - The question has been marked as abandoned. Did you try our suggestions? Either or both will likely work.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.