Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Configure a Local PHP Interpreter for Phpstorm

Posted on 2016-09-13
2
Medium Priority
?
977 Views
Last Modified: 2016-09-13
Hi Experts,

1- I use Phpstorm 2016.2.1 + Xampp 3.2.2 installed on my laptop (Windows 10) and when I tried to run the any php page in browser I got this error:
Access forbidden!
You don't have permission to access the requested object. It is either read-protected or not readable by the server.
If you think this is a server error, please contact the webmaster.
Error 403
localhost
Apache/2.4.23 (Win32) OpenSSL/1.0.2h PHP/5.6.24


2- Phpstorm asking me to Configure a Local PHP Interpreter.

I'm totally new to PHP, so please answer me in details.

Please help.

Thanks a lot.
Harreni
0
Comment
Question by:Harreni
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 30

Accepted Solution

by:
Olaf Doschke earned 2000 total points
ID: 41795720
Most probably you stored your php file(s) somewhere restricted for both Apache and phpStorm access. Additional to that you didn't configure, what php.exe phpStorm may use.

Most probably you did install Xampp into program files, that's an unfortunate installation location, as that means limited access (read/execute, not write) to the xampp webroot, where you could store your php files for testing. Rather uninstall and then reinnstall Xampp into C:\Xampp.

To configure what phpStorm uses for php execution, from the start screen choose configure, Language&Frameworks, then click the browse [...] button for the Interpreter and choose C:\Xampp\php\php.exe - obviously after you installed Xampp there.

Bye, Olaf.
1
 

Author Closing Comment

by:Harreni
ID: 41795742
Thanks a lot Olaf, you solve my problem
0

Featured Post

Plesk WordPress Toolkit

Plesk's WordPress Toolkit allows server administrators, resellers and customers to manage their WordPress instances, enabling a variety of development workflows for WordPress admins of all skill levels, from beginners to pros.

See why 2/3 of Plesk servers use it.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
These days socially coordinated efforts have turned into a critical requirement for enterprises.
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.
The viewer will learn how to synchronize PHP projects with a remote server in NetBeans IDE 8.0 for Windows.
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question