Emails Fired from Outlook are not Delivered to Recipient


We are using 3rd party Windows Hosting server from and using their SMTP and pop credentials for Emails as well. Lets assume our domain is

Our company email accounts are configured on outlook and we are using pop and smtp to connect to their server and both of these addresses are and obviously uses 110 port for pop and 25/8025 for smtp.
Till now for 6 years, this was running fine but suddenly day before yesterday, emails from outlook were sent successfully and were transferred to sent folder but it was not received by the recipient. I investigated further and sent an email from to and both of these emails are configured in my outlook itself. After sending the email, I went to webmail of to see whether email was there and there is some problem in receiving but actually email was not there itself.
So email was sent from outlook but vanished in between or went to different folder in the email server rather than inbox folder of

There are several other tests which I did:

a)when I sent an email from webmail of to then email was delivered which made me think that webmail might be using different smtp port than 25/8025. But as per hosting provider they said it is same- 25. Also same emails are configured on my
blackberry mobile and if I send from there then also it gets received by the recipient. So the issue is only sending emails from outlook which infact shows its sent though its not received by recipient (infact is not showing in server inbox on webmail as well).

b) When I sent an email from or any other domain which is not hosted with dailyrazor then email gets delivered to the recipient which cleared that problem is with smtp of this computer

c) I though we are in india so my ISP (Airtel) is blocked but not sure then email should not have gone into sent folder. Also I ran telnet command with port 25 and 8025 , it returned successful. But still on safer side, I tried another ISP (Vodafone) and it failed for that as well which means ISP is not blocking. Correct me if I am wrong.

Please help me if there is some sudden problem with Outlook or if the hosting provider has to do something. They are actually not competent to find the cause and saying everything is working.
Does all Indian ip addresses are blocked for this domain by Hosting Provider’s ISP? Is that a possibility? But in that case telnet should not have returned successful. Correct me.

Please help!
Who is Participating?
TUS11Connect With a Mentor Author Commented:
had a problem with the hosting provider as their spam filter was working incorrectly. @Foxluv helped personally by logging into our network and helped thoroughly hence accepting his above comment. though actual solution was to remove spam filter from all email ids from plesk panel as all internal emails were treated as spam and rule was to delete those emails.
It depends on the mail server and webmail application, but usually webmail does not send using port 25 in the traditional sense.

if your mail provider supports it, I would suggest trying with port 587 (Mail Submission) instead of 25.

if your mobile device can send using port 25, but emails from Outlook fail to send (even though they go into the sent items folder) I would point the finger at Outlook.

Is this happening for all users ?

Have you tried with a different email client on a PC ?
FOXActive Directory/Exchange EngineerCommented:
Something was definitely changed.  I would try on the outgoing server port 587 (encryption set to none) give that a go.
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

TUS11Author Commented:

@Foxluv - how are you? Help me. this has taken my 2 nights. I have no option now other than to purchase another smtp provider as these hosting guys are not helping at all and saying everything is fine at their end. We didnt change anything in our outlook clients and have been running the same for last 6 years. I will try 587 in outlook.

@ArneLovius - as per them their webmail uses port 25 but i dont think so.
i am not sure what port my mobile devices uses( not sure what blackberry india)?
Yes all of a sudden 4pm on Friday , nobody was receiving emails. I came to know 2 hours later when i was skeptical that i receive atleast 1 email every 10 mins.

No have not tried different email client as of now as dont think all outlooks can be problematic. We have a .net application which fires email and that is also using same credentials so if we treat it as a client then emails have stopped firing in that code as well which makes me further skeptical that it is port 25 issue.

What both of you think - if telnet is working then indian ip addresses getting banned is not a possibility as hosts are in the USA.
FOXActive Directory/Exchange EngineerCommented:
TUS11Author Commented:
Did 8025 as well and still went in sent folder of outlook but no email on server inbox on webmail.

also tried ssl and same thing,
FOXConnect With a Mentor Active Directory/Exchange EngineerCommented:
You tried port 587 outgoing with no encryption already?
TUS11Author Commented:
as i had to personally contact hosting provider though foxluv nearly reached to the problem
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.