Solved

Win10 port 80 in use

Posted on 2016-09-13
8
60 Views
Last Modified: 2016-09-14
Running Tridium web server on a win10 machine.
Getting port 80 in use error message

Any ideas on how to locate and disabled service that is using port 80?
0
Comment
Question by:BCS-AZ
  • 3
  • 3
  • 2
8 Comments
 
LVL 28

Expert Comment

by:Bill Bach
ID: 41796134
From an Administrative command prompt, type "NETSTAT -a -b" and you should see a list of the EXE with each port open.
0
 
LVL 26

Expert Comment

by:Dr. Klahn
ID: 41796979
Microsoft TCP View (free) displays what is using TCP, what ports are being used, and where those ports are connected to.

TCP View in use
0
 

Author Comment

by:BCS-AZ
ID: 41797141
Thanks, Tried both and neither yielded a definitive answer. Could not replicate results from one with the other.

PID4 came up but it's source could not be determined

Best to direct output of netstat to make searching results easier
 NETSTAT -AB >> c:\ports.txt

Wireshark with port 80 filter might yield cleaner results
But I opted to take the easy way out and assign the web server to use 8080

Appears port 80 is allusive target in Win10
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 26

Expert Comment

by:Dr. Klahn
ID: 41797146
If the system has something on it that is only intermittently opening port 80 with no ascertainable source, I'd look for malware or a virus.  Unless there is a web server running, nothing should be using port 80 for any purpose.
0
 
LVL 28

Expert Comment

by:Bill Bach
ID: 41797151
I would agree with that. Further, pid 4 is usually the file system process, used to serve files to remote users. I would definitely run a malware scan using something like Vipre Rescue.
0
 

Author Comment

by:BCS-AZ
ID: 41797171
It's not malware or virus
This is not an example of one. It's a very large sample.
This is issue has been seen on many win10 machines by many people. A lot a people are looking for a solution.
Moving to port 80xx is the standard work around.

My examples are win7 Pro upgraded to 10 pro and a few OEM Win10

We've had port 80 working in win7 that won't work after upgrade to 10
0
 
LVL 26

Accepted Solution

by:
Dr. Klahn earned 500 total points
ID: 41797176
See if this helps:

http://stackoverflow.com/questions/30758894/apache-server-xampp-doesnt-run-on-windows-10-port-80/31229606#31229606

Windows 10 runs IIS (Internet Information Services, Microsoft's web server software) automatically during Startup on Port 80. In order to use Apache Server on that port, IIS must be stopped. .... In order to disable it or modify how the service runs, you need to know where to find "Services" in your system.


I found the easiest way there was to click on the search button next to the start menu button in the Windows 10 taskbar and type "Administrative Tools". You can either hit return or click on the "Administrative Tools" link that Windows finds for you.

A control panel window will open with a list of tools. The one you want is "Services." Double-click it.

Another window will open called "Services." Locate the one named "World Wide Web Publishing Service." Some other users in this thread have listed what it is called in other languages, if your list is not in English.

If you only want to turn off the IIS server for this Windows session, but want it to run automatically again the next time you start up Windows, right-click "World Wide Web Publishing Service" and choose "Stop." The server will stop, and Port 80 will be freed up for Apache (or whatever else you want to use it for).

If you want to prevent the IIS server from running automatically when you start up Windows in the future, right-click "World Wide Web Publishing Serivce" and select "Properties." In the window that appears, locate the "Startup type" dropdown, and set it "Manual." Click "Apply" or "OK" to save your changes. You should be all set.
0
 

Author Comment

by:BCS-AZ
ID: 41797649
It was WWW Publishing services W3SVC

I had turned it off earlier but didn’t disable it on startup and it restarted after pc was rebooted n+1 times

Two steps required to disable it
1.      Stop the services
2.      Disable it from startup by changing to manual or disable

Win10 port 80 - disable W3SVC WWW publishing service
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With Windows evolving further, the built-in protective mechanisms get better and better. Still, Microsoft is not very good at introducing those to the technical community. This article is about a new bitlocker functionality that could revolutionize …
Today, still in the boom of Apple, PC's and products, nearly 50% of the computer users use Windows as graphical operating systems. If you are among those users who love windows, but are grappling to keep the system's hard drive optimized, then you s…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Hi friends,  in this video  I'll show you how new windows 10 user can learn the using of windows 10. Thank you.

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question