Solved

Exchange 2013 ECP SSL error

Posted on 2016-09-13
5
56 Views
Last Modified: 2016-10-31
Hi all,

I've run into a bit of trouble with an Exchange 2013 installation. The server had issues with OWA which I thought where connected with certificates that might not be correctly configured. To fix this I used ECP to register a new, self-signed certificate from scratch. I somehow connected this to IIS (for ECP and OWA) and set it up to need SSL. Now I've run into the problem that whenever I try and open ECP I get an 403.4 error because the http-url forwards or is looking for the https version.

I didnt setup or install the environment so what I basically am looking for is a direction to reset certificates in Exchange back to defaults, so I can use ECP to try and fix everything again. Any suggestions are welcome :D.

Greetings
Martijn
0
Comment
Question by:Martijn Snel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
5 Comments
 
LVL 16

Expert Comment

by:Todd Nelson
ID: 41797273
Do you get an error when you open EMS?  Is there a certificate bound to the Default Web Site in IIS?
0
 

Author Comment

by:Martijn Snel
ID: 41797539
Hi. Yes.. i get the same type of error (either its a 403.4 > when I go to ECP or a blanc page when I go to OWA or any other subpage). There is a binding in IIS to a certificate on the default website (Exchange Back End), I'm thinking that something went wrong (or I screwed up) and the wrong type of setting for SSL. I'm basically look for a way to bypass SSL / settings, or reset them completly so I can at least access ECP.
0
 
LVL 63

Expert Comment

by:Simon Butler (Sembee)
ID: 41798849
Use EMS and the command enable-exchangecertificate.
That will allow you to assign the correct certificate to the IIS role.

You can do everything through EMS, so lack of accept to ECP shouldn't be a problem to get the server fixed.
0
 

Accepted Solution

by:
Martijn Snel earned 0 total points
ID: 41810703
Hi, Finally seems that I have fixed the issue; I have reset all certifcates (made a new self-signed certificate) and to get IIS working correctly again used the EMS with Remove-OwaVirtualDirectory and Remove-ECPVirtualDirectory commands to repair everything.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
how to add IIS SMTP to handle application/Scanner relays into office 365.
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question