SBS2011 server password problem

Please can someone help we though we had a security breach on our SBS2011 server so after doing various tests and scans we then changed the Administrator password.

This password was too complex so we tried to change it again, but this time the server kept coming back that we had not met the lenfth and complexity requirements
(which all we tried were over 8 characters long and contained an uppercase letter, a number and a #)

We then turned off password length and complexity and we are still getting the same message!!
Any help please
samcoryAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Waqar AhmedCommented:
Hi Samcory could you snip the error ? have you consider honeypot ?
0
Lorenzo ContiCommented:
Check the password age requirements, if the min age is set to 1 day you can't change it twice the same day.
0
samcoryAuthor Commented:
No I dont think thats the problem
When I go into the group policy security this is what it says
Enforce pw history - not defined
max pw age            - not defined
min pw age             - not defined
min pw length       -  8
pw must meet complexity requirements - disabled
store pw using reversible encryption -        disabled
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

harryhelpCommented:
Have you rebooted/run a gpupdate /force since making this change?
0
samcoryAuthor Commented:
no, should I?
0
harryhelpCommented:
Try a gpupdate /force first, a reboot shouldn't be necessary but good to rule it out!
0
samcoryAuthor Commented:
did that, still cant change password.
Will reboot tonight.
0
harryhelpCommented:
Just to confirm, what Group Policy are you changing? Have you checked the SBS password policy as well as the Default Domain policy?
0
harryhelpCommented:
If you enter this in a cmd prompt:
gpresult /h gpresult.html

Then type in:
gpresult.html

This may give you an indicaton
0
samcoryAuthor Commented:
change done in:
Group policy management editor -domain policy
policies
windows settings
security settings
account policy
password policy
0
harryhelpCommented:
Have you checked all the other GPOs, like the SBS password policy mentioned before?
0
samcoryAuthor Commented:
all entries in
Windows SBS CSE Policy - windows settings- security -account policy  - password         are not defined
WINDows SBS user policy  as above -not defined
same for Default domain controller policy
0
harryhelpCommented:
Ok great, as long as you've checked Computer Configuration you should be good.

Try the reboot and let us know.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
samcoryAuthor Commented:
Thanks Harryhelp the reboot worked

sam
0
harryhelpCommented:
Glad to hear it!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.