Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 182
  • Last Modified:

Change local server setting in php

Hi Experts,

I used  use Phpstorm 2016.2.1 + Xampp 3.2.2 installed on my laptop (Windows 10); and when I tried to run a PHP page in browser it show me the link like this: localhost/C:/Users/IT/Desktop/......../MyPHPPage

I already:
1- Move my application to be under : C:\XMAPP\htdocs\
2- Change my PHP server setting to be Localhost:8080 (Because It's conflicted with other app port)

Usually, I want to get something like this localhost:8080/MyPHPFolder/MyPHPPage, So please tell me what to do in details.


Thanks a lot.
Harreni
0
Harreni
Asked:
Harreni
  • 3
  • 3
1 Solution
 
Julian HansenCommented:
localhost:8080 should take you to the DocumentRoot as defined in the Apache httpd.conf file

If you want to have localhost:8080/yourfolder/yourfile.php where yourfolder is not under the document root you need to setup an Alias to the folder - also in the httpd.conf file.

I am not sure how you managed to get localhost:/c:.... - is it is till doing that?
0
 
HarreniAuthor Commented:
Thanks Julian.
I copied the whole folder from the internet site using FileZilla to C:\ drive and then I moved again it to C:\XMAPP\htdocs\ and for that it mayb keep showing me localhost/C:/Users/IT/Desktop/......../MyPHPPage in the URL.
Now, It fixed by coping the folder from the internet to C:\XMAPP\htdocs\ directly.

Another question:
Why Phpstorm showing localhost:63342/ instead of localhost/ although XMAPP is using port 80? Is there a way to fix that to localhost?

Thanks a lot.
0
 
Julian HansenCommented:
I don't know much about PHPStorm but like many development environments what they do is launch a http service that is then used to monitor / debug the session. I suspect PHPStorm is doing the same thing - when you connect to localhost63342 it is a PHPStorm HTTP service and not apache.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
HarreniAuthor Commented:
Thanks a lot Julian.

Anyone can tell me how to make Phpstom run localhost/ instead of localhost:63342/ ?
0
 
Julian HansenCommented:
From this article
Built-in webserver port can be always configured in Settings/Preferences | Build, Execution, Deployment | Debugger. The default port is 63342. Built-in webserver can also accept external connections when explicitly configured to do so (disabled by default due to security reasons).
0
 
HarreniAuthor Commented:
I configure the interpreter as per the article and its works with  localhost:63342/ without need to change it to  localhost
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now