Solved

Uninstalling Exchange 2010

Posted on 2016-09-14
11
60 Views
Last Modified: 2016-10-17
Hello

I am trying to uninstall Exchange 2010 as I have migrated all mailboxes to Office 365. When using program and features to uninstall exchange the Mailbox Role Prerequisites fail. Error Below

Error:
Uninstall cannot continue. Database 'Public Folder Database': The public folder database "Public Folder Database" contains folder replicas. Before deleting the public folder database, remove the folders or move the replicas to another public folder database. For detailed instructions about how to remove a public folder database, see http://go.microsoft.com/fwlink/?linkid=81409&clcid=0x409.

I would like to delete the replicas completely, not move to another server. I have done this before with exchange 2007 and used a couple of powershell commands to do so and it worked perfectly but for some reason exchange 2010 is being stubborn. Any Suggestions

Thanks
0
Comment
Question by:cairnsfuture
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 3
11 Comments
 
LVL 4

Expert Comment

by:El Fierro
ID: 41799113
run this command it removes everything left within your Public Folder database...you should be able to remove the public folder db.

Get-PublicFolderStatistics –Server SERVERNAME | Remove-PublicFolder
0
 
LVL 4

Expert Comment

by:El Fierro
ID: 41799116
if that one command doesnt work then you can use this guide ..
http://exchangeserverpro.com/exchange-2010-remove-public-folder-database/
good luck
0
 

Author Comment

by:cairnsfuture
ID: 41799194
Thanks ElFierro

When I run that command i get the below error. I looked at the guided you posted. Issue is Im trying to delete the replicas not move them to another server.

    + CategoryInfo          : NotSpecified: (0:Int32) [Remove-PublicFolder], MapiPartialCompletionException
    + FullyQualifiedErrorId : FE9F09C5,Microsoft.Exchange.Management.MapiTasks.RemovePublicFolder

Cannot delete the object '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK\EX:/o=xyz/ou=Exchange Administrative Group (FYDIB
OHF23SPDLT)'. Please make sure that you specified the correct identity and that you have the correct permissions to del
ete it.
    + CategoryInfo          : NotSpecified: (1:Int32) [Remove-PublicFolder], MapiPartialCompletionException
    + FullyQualifiedErrorId : 96F0ECBA,Microsoft.Exchange.Management.MapiTasks.RemovePublicFolder
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 

Author Comment

by:cairnsfuture
ID: 41799195
I have also used the below commands, still get errors about the replicas.

Get-PublicFolder -Server servername "\" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server servername -Recurse -ErrorAction:SilentlyContinue -Confirm:$False
Get-PublicFolder -Server servername "Non_Ipm_Subtree" -Recurse -ResultSize:Unlimited | Remove-PublicFolder -Server servername -Recurse -ErrorAction:SilentlyContinue -Confirm:$False
Get-PublicFolderDatabase -Server servername | Remove-PublicFolderDatabase -RemoveLastAllowed

Thanks
0
 
LVL 4

Expert Comment

by:El Fierro
ID: 41799889
Well you can always force remove it using adsiedit

    connect to your DC.
    Open ADSIEDIT.MSC console and connect to configuration.
    Go to the following path.

–> CN=Configuration –> CN=Services –> CN=Microsoft Exchange –> CN=YOUR ORGANIZATION –> CN=Administrative Groups –> CN=First Administrative Group –> CN=Servers –> CN=SERVER NAME +—> CN=InformationStore

Delete public folder Database.
Restart Exchange Information Store.
Refresh EMC and you should see that the database has been removed
0
 
LVL 16

Expert Comment

by:Todd Nelson
ID: 41800206
cairnsfuture,

I've had a lot of success with the commands to provided from this link ... https://technet.microsoft.com/en-us/library/bb201664(v=exchg.141).aspx

Make certain there are no typos.

Alternately, I've needed to delete them via ADSI Edit as ElFierro stated.
0
 

Author Comment

by:cairnsfuture
ID: 41804255
Hello Todd

Those commands worked fine. However when trying to remove exchange 2010 it still say that there are replicas and they need to be removed. I used the commands below to tryand delete all the folders but get an error on the 2 command

Get-PublicFolder -Identity \ -GetChildren | Remove-PublicFolder -Recurse
Get-PublicFolder -Identity \Non_Ipm_Subtree -GetChildren | Remove-PublicFolder -Recurse

Modification of the '\NON_IPM_SUBTREE\EFORMS REGISTRY' folder isn't allowed
Modification of the '\NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK' folder isn't allowed
Modification of the '\NON_IPM_SUBTREE\SCHEDULE+ FREE BUSY' folder isn't allowed

Any ideas?

Thanks
0
 
LVL 4

Expert Comment

by:El Fierro
ID: 41804418
Have tried to force remove yet via ADSIEDIT.MSC as i mentioned before?
0
 
LVL 16

Accepted Solution

by:
Todd Nelson earned 500 total points (awarded by participants)
ID: 41804810
It seems that you might not have the correct permissions set for the account you are using to remove Exchange or the permissions of the system PFs were modified.  Could be a red herring though.

Via the Exchange Toolbox, are you able to traverse the PF hierarchy and remove the server that you want to uninstall from the replicas manually?

Also, did you update the mailbox databases so they aren't associated with a PF DB and remove the PF replication of the OAB?
0
 

Author Comment

by:cairnsfuture
ID: 41818953
Thanks to all who commented. It is now removed. Had to fix permissions on the account and now all removed.

Thanks
0
 
LVL 16

Expert Comment

by:Todd Nelson
ID: 41846300
Issues resolved by fixing permissions.
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question