?
Solved

EIGRP Confg

Posted on 2016-09-15
18
Medium Priority
?
42 Views
Last Modified: 2016-10-08
How to configure point to point link with 2 router in single location (single switch) which is connected to single router, detail find below
R1 192.168.1.1
(E1 Link 10.10.10.2)
R2 192.168.1.2
(Eth Link 20.20.20.2)

3 router installed 2nd location
R1 192.168.20.1
(E1 Link 10.10.10.1)
(Eth Link 20.20.20.1)
0
Comment
Question by:Rajat Kumar Sahgal
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 10
  • 8
18 Comments
 
LVL 31

Expert Comment

by:Predrag
ID: 41799710
I am not sure that I understand what you need. Can you, please, provide topology?
0
 

Author Comment

by:Rajat Kumar Sahgal
ID: 41800987
Hello Sir,
Please find the attachment for topology detail.
Topology.jpg
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41801048
Router 1 (uper left)
router eigrp 1
 passive-interface FastEthernet0/1  <-- do not send hellos to private network
 network 90.90.90.2 0.0.0.0  <---- 0.0.0.0 means advertise networks only on that specific address
 network 192.168.90.1 0.0.0.0
 no auto-summary

Router2 (upper right)
router eigrp 1
 passive-interface FastEthernet0/1<-- do not send hellos to private network
 network 80.80.80.2 0.0.0.0
 network 192.168.90.6 0.0.0.0
 no auto-summary

Router3 (router down)
router eigrp 1
 passive-interface FastEthernet0/1 <-- do not send hello to private network
 network 80.80.80.1 0.0.0.0
 network 90.90.90.1 0.0.0.0
 network 192.168.207.1 0.0.0.0
 no auto-summary

However, on drawing you have in network down ip addresses from 192.168.90.X/X assigned to hosts I guess those should not be down :). Also address on router is 192.168.0.201 and hosts are 192.168.207.x/x I guess it is typo (check you design and adjust IP addresses).
If those are not typo I guess you created router on the stick and then passive interfaces for EIGRP should be all subinterfaces to local network and rest of the networks should be added to EIGRP so those too can be advertised.
I assumed everywhere fa0/1 was used as interface to local network (you should adapt it to your design).
It is easy to check what interface should be passive (the one with private IP address on it (that should be configured with network statement)):
sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        90.90.90.2      YES manual up                    up
FastEthernet0/1        192.168.90.1    YES manual up                    up
0
Manage your data center from practically anywhere

The KN8164V features HD resolution of 1920 x 1200, FIPS 140-2 with level 1 security standards and virtual media transmissions at twice the speed. Built for reliability, the KN series provides local console and remote over IP access, ensuring 24/7 availability to all servers.

 

Author Comment

by:Rajat Kumar Sahgal
ID: 41801140
Sir,
I did it, after that m not able to reach my network, please suggest...

Router 1 (uper left)

interface FastEthernet0/0
 ip address 192.168.90.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 90.90.90.2 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 90.90.90.0 0.0.0.3
 network 192.168.90.0
 no auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end


Router2 (upper right)

interface FastEthernet0/0
 ip address 192.168.90.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 80.80.80.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 80.80.80.0 0.0.0.3
 network 192.168.90.0
 no auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end



Router3 (router down)

interface FastEthernet0/0
 ip address 192.168.90.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 80.80.80.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 80.80.80.0 0.0.0.3
 network 192.168.90.0
 no auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end
R-192.168.90.1.txt
R-192.168.90.6.txt
R-192.168.207.1.txt
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41801156
Router3 (router down)

interface FastEthernet0/0
 ip address 192.168.90.6 255.255.255.0
 duplex auto
 speed auto

router eigrp 1
 passive-interface FastEthernet0/1
 network 80.80.80.0 0.0.0.3
 network 192.168.90.0

Wrong network and passive interface (you have wrong passive interface on router 1 and 2). According to configurations passive interfaces everywhere should be fa0/0.
On router 3 network should be 192.168.271.0

But you can remove passive interface command for practice, it is security mechanism. passive interface should match with interface to hosts, not to EIGRP neighbors. If interface is passive hello messages will not be sent from that interface and routers can't establish neighbor relationships on those interfaces.
0
 

Author Comment

by:Rajat Kumar Sahgal
ID: 41801181
Dear Sir,
Sorry for the inconvenience, previously giving configuration was wrong, kindly consider following configuration.


Router1 (upper left)

interface FastEthernet0/0
 ip address 192.168.90.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 90.90.90.2 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 90.90.90.0 0.0.0.3
 network 192.168.90.0
 no auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end



Router2 (upper right)

interface FastEthernet0/0
 ip address 192.168.90.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 80.80.80.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 80.80.80.0 0.0.0.3
 network 192.168.90.0
 no auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end


Router3 (router down)

interface FastEthernet0/0
 ip address 192.168.207.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 80.80.80.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 90.90.90.1 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 80.80.80.0 0.0.0.3
 network 90.90.90.0 0.0.0.3
 network 192.168.207.0
 no auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end
R-192.168.90.1.txt
R-192.168.90.6.txt
R-192.168.207.1.txt
0
 
LVL 31

Accepted Solution

by:
Predrag earned 2000 total points (awarded by participants)
ID: 41801206
Correct passive interfaces (or remove passive interface completely) on router 2 and 3 should be Fa0/0

Router 3
 interface FastEthernet0/1
   ip address 80.80.80.1 255.255.255.0
is passive interface

Router 2
 interface FastEthernet0/1
  ip address 80.80.80.2 255.255.255.0
is passive interface

Interfaces Fa0/1 on those routers should not be passive.
1
 

Author Comment

by:Rajat Kumar Sahgal
ID: 41801249
In between Router 3 & Router 2 communication is done, but Router 3 & Router 1 still not able to communicate (serial interface down showing), whats need to be change, please suggest.

Router 1

#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
 
FastEthernet0/0        192.168.90.1    YES manual up                    up
 
FastEthernet0/1        unassigned      YES manual administratively down down
 
Serial0/0/0            90.90.90.2      YES manual up                    down

Vlan1                  unassigned      YES manual administratively down down


#sh running-config
interface FastEthernet0/0
 ip address 192.168.90.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 90.90.90.2 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 90.90.90.0 0.0.0.3
 network 192.168.90.0
 no auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end



Router 3

#sh ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
 
FastEthernet0/0        192.168.207.1   YES manual up                    up
 
FastEthernet0/1        80.80.80.1      YES manual up                    up
 
Serial0/0/0            90.90.90.1      YES manual up                    down
 
Vlan1                  unassigned      YES manual administratively down down


#sh running-config
Building configuration...

Current configuration : 558 bytes
!
version 12.4
no service password-encryption
!
hostname Router
!
!
!
!
!
ip ssh version 1
!
!
interface FastEthernet0/0
 ip address 192.168.207.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 80.80.80.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 90.90.90.1 255.255.255.0
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 80.80.80.0 0.0.0.3
 network 90.90.90.0 0.0.0.3
 network 192.168.207.0
 no auto-summary
!
ip classless
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
end
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41801253
Serial0/0/0            90.90.90.2      YES manual up                    down
Your serial interface protocol is down. Problem is not related to EIGRP, but for serial interface.


You can try cable serial DCE cable instead of serial DTE that you are using.
Since for serial links one side must be DCE, if both sides are DTE protocol will be down.
But I am not sure what is solution for Packet tracer.
0
 

Author Comment

by:Rajat Kumar Sahgal
ID: 41801326
Both link working, but why all traffic going through Router2 only

Router 1


Router#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
 
FastEthernet0/0        192.168.90.1    YES manual up                    up
 
FastEthernet0/1        unassigned      YES unset  administratively down down
 
Serial0/0/0            90.90.90.2      YES manual up                    up
 
Vlan1                  unassigned      YES unset  administratively down down

Router#traceroute 192.168.207.100
Type escape sequence to abort.
Tracing the route to 192.168.207.100

  1   192.168.90.6    1 msec    0 msec    0 msec    
  2   80.80.80.1      0 msec    1 msec    0 msec    
  3   192.168.207.100 11 msec   0 msec    0 msec    


Router#sh running-config
Building configuration...

Current configuration : 778 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
ip ssh version 1
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.90.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 90.90.90.2 255.255.255.0
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 passive-interface FastEthernet0/1
 network 90.90.90.0 0.0.0.3
 network 192.168.90.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end



Router 2

Router#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
 
FastEthernet0/0        192.168.90.6    YES manual up                    up
 
FastEthernet0/1        80.80.80.2      YES manual up                    up
 
Vlan1                  unassigned      YES unset  administratively down down

Router#traceroute 192.168.207.100
Type escape sequence to abort.
Tracing the route to 192.168.207.100

  1   80.80.80.1      0 msec    0 msec    0 msec    
  2   192.168.207.100 0 msec    1 msec    0 msec    

Router#sh running-config
Building configuration...

Current configuration : 677 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
ip ssh version 1
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.90.6 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 80.80.80.2 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
router eigrp 1
 network 80.80.80.0 0.0.0.3
 network 192.168.90.0
 no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41801335
That's how EIGRP works.
:)
Serial link is way much slower than Fast Ethernet link.
By default you can load balance traffic only through 4 equal cost paths.
If routes are not equal cost routes, by default only best route will be placed in routing table.
0
 

Author Comment

by:Rajat Kumar Sahgal
ID: 41801363
Ok got it sir, but there is a problem actually we have 2 different ISP link in my network which is connected to a single router with different location. in my network there is 100 + computer out of which 50 in connected with 1 ISP router & rest of connected with 2 ISP router. What happens now is if my 1st ISP goes down my all 50 user stuck in same case we run batch file for using 2nd ISP & all 100 user will be connect with 2nd router.

In that scenario if my 1st ISP or 2nd ISP goes down, i am not able to find out which one is down because it will connect computers automatically for running ISP router.

I would like automatically fail over should stop.
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41801370
EIGRP knows that both neighbors exists and what networks are advertised by each of them. Router will have to rediscover the best path, no problem there. EIGRP can be configured to use unequal load balancing if you want to do so (but it can create new challenges).

router eigrp 1
 variance x

However for failover scenario, have in mind that if one of the links is down you can run into problem with NAT.
0
 

Author Comment

by:Rajat Kumar Sahgal
ID: 41801378
Ok got it sir,
Thank You so much.
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41801379
You can shut Fa 0/1 interface on R2 or R3 and see that is traffic rerouted.

You are welcome.
0
 

Author Comment

by:Rajat Kumar Sahgal
ID: 41801595
Sir,
There is a issue is my serial link goes down in same time eth link getting RTO 5-6 time because of which user disconnect which is connected with eth link. what is the way to serial traffic in & out via serial link only & eth traffic in out via eth link only ?
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41801619
Not sure what are you trying to describe.
Real world or lab situation?
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41805026
I tried it in packet tracer and the same happened what you described. That is some packet tracer bug. That's should not happen in real world, I expect other problems in the real world.
0

Featured Post

Looking for the Wi-Fi vendor that's right for you?

We know how difficult it can be to evaluate Wi-Fi vendors, so we created this helpful Wi-Fi Buyer's Guide to help you find the Wi-Fi vendor that's right for your business! Download the guide and get started on our checklist today!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question