Outlook 2016 Security Alert certificate error - Security Cert for this site has been revoked.

lbideaux
lbideaux used Ask the Experts™
on
I am running Windows 10 Home, with Outlook 2016 using Exchange online plan.  When I test Email AutoConfiguration, I see the following in the log:  Autodiscover to https://autodiscover.domain.com/autodiscover/auotdiscover.xml Failed (0x80070057)
Local autodiscover for domain.com Failed (0x8004010F)
I can see the certificate has expired, but confused why it would look for an Equifax Cert when I'm using Exchange online plan?
Is it possible to stop Outlook or Windows to stop looking for this certificate?

Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
IvanSystem Engineer
Commented:
Hi,

autodiscover is going to look for domain.com first, and then will go to autodiscover.domain.dom.
That is by design.

Are you using Equifax Cert  on your domain.com site?

Regards,
Ivan.
AkhaterSolutions Architect
Commented:
have you created the correct autodiscover record in your DNS with autodiscover.domain.com CNAME for utodiscover.outlook.com ?

note that if you have domain.com also in your LAN you will need to create this record on both your internal and external DNS servers


also, the way autodiscover works it will start by querying https://domain.com/autodiscover and (if this fails) will faill back to autodiscover.domain.com/autodiscover (which is what you want)

you have no real way of solving your problem other than

1) fix your certificate on https://domain.com 
2) make https://domain.com not reachable

Author

Commented:
Ivan,
I used the following website and it shows the expired cert for the domain.  https://www.sslshopper.com/ssl-checker.html
I didn't setup the domain, but might be able to get access to their hosting.
There are only a handful of PC's so if I could find a fix for the PC/Outlook I could apply to the few PC's.

Thanks.
AkhaterSolutions Architect

Commented:
Add in the hostsfile of the computer domain.com pointing to 127.0.0.1 it would render https://domain.com inaccessible and would solve your issue

Author

Commented:
In Office 365 I ran the Check DNS, and returned "All DNS records are correct no errors found.

Author

Commented:
Akhater,
Ok, could this cause any issues browsing to the website?

Thanks for your input.
AkhaterSolutions Architect

Commented:
Off course they won't be able to reach domain.com anymore but they will be able to reach www.domain.com
AkhaterSolutions Architect

Commented:
And it's not an error with the dns configuration but an expired certificate in your website so it is normal that office 365 will detect no errors
Commented:
I ended up using the following registry edit:  

[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\AutoDiscover]
"ExcludeHttpsRootDomain"=dword:00000001
AkhaterSolutions Architect

Commented:
Thanks for sharing your solution
AkhaterSolutions Architect

Commented:
Question answered, OP solved it on the client side

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial