Exchange 2010 - how to send from accepted domain

I have a user who I want to send and receive email for two domains.
e.g. fred@domain1 and fred@domain2. The SBS2011 server is domain1 and I have configured Exchange to accept domain2
I would like the user to receive email sent to fred@domain1 and fred@domain2. If he receives email to fred@domain2 I would like him to be able to reply from fred@domain2

Is this possible?
ClintonKAsked:
Who is Participating?
 
AkhaterConnect With a Mentor Commented:
The (only?) way to do it is

- Creating another mailbox with the second address fred@domain2
- Forward emails from the fred@domain2 mailbox to fred@domain
- Give the Fred@domain send as permission to the user Fred@domain2
- Teach the user to send the "from"  in outlook so he can send from any of the 2 addresses
0
 
ClintonKAuthor Commented:
I get the option to create a mailbox for a new user or an existing user. Which one?
0
 
AkhaterCommented:
a new user
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
ClintonKAuthor Commented:
I only get the option to create a new user in domain1 and of course, fred already exists
0
 
AkhaterCommented:
call it anything fred2 or whatever

Then go to his email addresses and change it to fred@domain2
0
 
ClintonKAuthor Commented:
Nearly there I think.
I've created the new user but it doesn't appear in the "From" list in Outlook. Do I need to do anything to give it a shove?
0
 
Schnell SolutionsSystems Infrastructure EngineerCommented:
Yes. You need to go to the new account, and assign "Send As" permission to the account that you want to use to send emails from.
0
 
AkhaterCommented:
- Forward emails from the fred@domain2 mailbox to fred@domain
- Give the Fred@domain send as permission to the user Fred@domain2

All these done?
0
 
ClintonKAuthor Commented:
I haven't done the redirect as I thought I keep them as two users; one at domain1 and the other at domain2. I've given full permission for fred@domain2 to fred@domain1 and added fred@domain2 account to fred@domain1 in Outlook.
I can receive emails to fred@domain2 but when I try to reply I can't see fred@domain2 in the list (he's actually called fred_domain2@domain1)
0
 
AkhaterCommented:
Full access won't be enough you need to give sendas

In outlook you have from other email address click it and select fred2
0
 
ClintonKAuthor Commented:
Outlook 2007?
Can't see other email address
0
 
Schnell SolutionsSystems Infrastructure EngineerCommented:
Outlook 2007 is not going to be aware of that account until you add the mailbox to the user account.

Mean while...

Also try writing the 'sending' address on the box, rather than trying to select it from a drop down box.

If it does not allow it add the mailbox to the account.
0
 
AkhaterCommented:
If memory serves me next to the from you should be able to type in. Just type fred@domain2
0
 
ClintonKAuthor Commented:
when I type in fred@domain2 I get "you can't send a message on behalf of this user...."
0
 
AkhaterCommented:
Did you give send as permission?
0
 
ClintonKAuthor Commented:
Yes
0
 
AkhaterCommented:
Ok can you please try to restart the information store service?
0
 
ClintonKAuthor Commented:
Sorry chaps but I have to pause here and leave the building. I can pick this up again on Tuesday. Annoying cos I think we're nearly there.
0
 
ClintonKAuthor Commented:
Back on the case now.
I've been through the setup as suggested but fred_domain2@domain1 doesn't appear in the GAL at all.
As a test I've just created a new user (joe@domain1) using the SBS Console but he doesn't appear in the "to" list either. More of a fundamental problem going on here I think.
0
 
ClintonKAuthor Commented:
If I select "All Users" and then expand All Users, Joe@domain1 appears
0
 
Schnell SolutionsSystems Infrastructure EngineerCommented:
Many things need to happen before the user appears there.

Ad replication, oab update on the exchange server, oab replication to other exchange servers, and finally outlook synchronization (if cache mode is used).

It can take more rhan one day in total and if any step has problems it will not complete.
0
 
ClintonKAuthor Commented:
ok, I'll sit tight until tomorrow and see if anything appears. Thanks
0
 
Schnell SolutionsSystems Infrastructure EngineerCommented:
But were you able to use the send as box and send an email writing the address manually?
0
 
ClintonKAuthor Commented:
Yes. Using the Send To box
0
 
ClintonKAuthor Commented:
My new user is joebloggs@mydomain and I can send to him from my user if I type his name in the "to" box because he doesn't appear in the GAL dropdown.
I have given full permission and send as permission to me for Joe Bloggs but when I try to send an email on his behalf it says I haven't got permission. Is this because it hasn't filtered through yet?
0
 
Schnell SolutionsSystems Infrastructure EngineerCommented:
It sounds like as if you still do not have "send as" permission on his account or if has not been applied.

How many DCs do you have? Can you recheck 'Joe Bloggs' properties and confirm that you appear in the list of send as permissions?

Can you send us a print screen of the window where you are trying to send the emal as Hrobbs?
0
 
ClintonKAuthor Commented:
Making progress. My Joe Bloggs user filtered through and I was able to send and receive using his account.
Back to my original issue now. I have created my new users at domain2 and will now wait for them to propagate.
0
 
ClintonKAuthor Commented:
I can now send to my new user (even though they don't appear in the GAL.
However, I can't "send as" even though I've given full permission and send permissions to my user. It says "you can't send a message on behalf of this user..."
0
 
AkhaterCommented:
Hi Clinton please give also send-as and send-on-behalf permissions full access is not enough (re my first post)

thanks
0
 
ClintonKAuthor Commented:
I can see "Send on behalf" permission in Exchange settings. Can "send-as" be set from the Exchange server too or do I need to log into the new account and set that through Outlook?
0
 
AkhaterCommented:
0
 
ClintonKAuthor Commented:
I've added my user ID to "Manage Send As Permission" and "Manage Full Access Permission".
I've also added myself to the user's "MailFlow Settings-->Delivery Options-->Send on behalf"
0
 
AkhaterCommented:
did you just give the send-as permission ??

I'm asking because

The Send As permission isn't granted until after replication has occurred. Replication times depend on your Exchange and network configuration. To grant the permission immediately, stop and then restart the Microsoft Exchange Information Store service.
0
 
ClintonKAuthor Commented:
I did it yesterday. However I'll try the stop/start trick
0
 
AkhaterCommented:
ok if that doesn't work please do the below

as you know send-as is an AD permission so let's check if the permission is actually given to the users

In Active Directory Users and Computers, View, and then click Advanced Features.

Right-click the user account account (the one on which sendas should be applied not the one to receive the permission), and then click Properties.

Click Security, do you see the user that you gave permission to ? does it have "Send-as" allow ?

if not please add the user directly from AD and click on allow next to send-as.
0
 
ClintonKAuthor Commented:
Yes, "Send as" Allow is ticked for the user to who I want to give permission
0
 
AkhaterCommented:
And you still have the error?
0
 
ClintonKAuthor Commented:
Yes, still get the error. What puzzles me is why the new user doesn't show in the GAL for the From or the To dropdowns
0
 
AkhaterCommented:
0
 
AkhaterCommented:
0
 
ClintonKAuthor Commented:
I can't get the "From" box to appear because I don't have a "Options –> Settings –> Mail –> Message format". However, when I click "To" my new users do appear in the dropdown where they don't in Outlook, ( I am using Outlook 2007 so whether that's the cause I wonder?)
0
 
AkhaterCommented:
Try from owa please
0
 
ClintonKAuthor Commented:
that was from owa.
When I follow the instructions in https://exchangeshare.wordpress.com/2009/07/06/exchange-2010-send-as-and-send-on-behalf-of-in-owa/ I don't get the option to configure the display of the "From" box. However, the "To" box does show my new users.
0
 
AkhaterCommented:
Can you share a screen shot?

Do me a favor find a new pc setup logon with the user setup outlook (without offline mode) and try again
0
 
AkhaterCommented:
Can you share a screen shot?

Do me a favor find a new pc setup logon with the user setup outlook (without offline mode) and try again
0
 
ClintonKAuthor Commented:
so a PC where the user hasn't logged into before? That might be tricky
0
 
AkhaterCommented:
Or delete the user windows profile and login again clean
0
 
ClintonKAuthor Commented:
Selected a PC and deleted the Windows profile then logged on as me. Outlook files were configured etc. and then I tried a send from and a send to. Both appeared in the GAL and both arrived!
0
 
AkhaterCommented:
yea I thought it was a PC issue ....
0
 
ClintonKAuthor Commented:
thanks. I'll do some more tests and report back.
0
 
ClintonKAuthor Commented:
All working now thanks. Distracted from the original question by some strange goings-on with the PC in that it wouldn't display the new user or allow me to "send-as". Akhater's suggestion proved that the problem was PC based so by deleting the user's Windows profile, all worked. On the user's main PC, rather than deleting the user's profile, I deleted the email account and allowed Windows to auto set it up again and this had the desired effect.
Thanks to schnellsoutions too for the suggestions.
0
 
AkhaterCommented:
Glad I was able to help
0
All Courses

From novice to tech pro — start learning today.