Solved

Setting up new voicemail with unified messaging

Posted on 2016-09-16
13
53 Views
Last Modified: 2016-09-23
We have an Exchange Server 2010, we just swapped out our old voicemail system and I'm trying to setup Toshiba unified messaging. in the setup I wants use to set up SMTP and use an email address dedicated to forwarding the voice massages to email accounts. When we try to use port 25 it will not deliver because our Exchange denies this port, when we try to use port 443 nothing happens and then it just gives up. The vendor is asking if there is a way to whitelist SMTP which is coming from internal IP: 192.168.1.8 to my exchange server 192.168.1.26?

any suggestions are appricated
0
Comment
Question by:jsarinana
  • 6
  • 6
13 Comments
 
LVL 17

Expert Comment

by:Serena Hsi
ID: 41803396
There's quite a lengthy walk-through of how to set this up with Exchange 2010 and Unified Messaging:
http://www.networkworld.com/article/2232578/microsoft-subnet/unified-messaging--voicemail--in-exchange-2010.html

And, here's a TechNet article that explains how to whitelist an IP address with Exchange 2010:
https://technet.microsoft.com/en-us/library/bb123964%28v=exchg.141%29.aspx?f=255&MSPPError=-2147217396
0
 
LVL 76

Expert Comment

by:arnold
ID: 41803397
Check which ports you ave exchanged configured on for inbound SMTP traffic as well as make sure you allow the phone system relay rights.

443 is a web related interface.
SMTP commonly uses, 25, 465 SSL, 587
Your issue might be the setting require authentication.  In this case on the toshiba config, include a toshiba service account you create in your AD to use when authenticating with exchange server prior to transmitting tge message with the voucemessage attached.
0
 
LVL 76

Expert Comment

by:arnold
ID: 41803398
On the exchange server run netstat -an | find /I "listen"

One of these ports is exchange listening got incoming connection, check the external firewall to see how and to what port you direct SMTP traffic from the outside.
0
 
LVL 1

Author Comment

by:jsarinana
ID: 41804973
I have an account vmail@mycompany.com already and Toshiba is asking for port 465
0
 
LVL 76

Expert Comment

by:arnold
ID: 41805203
465 is an encrypted port, why is it asking?
Do you have your exchange configured with one Secure SMTP port (SSL required to connect)?

When configuring the outgoing email, do you have an option to specify another port other than 465 if 25 is unavailable, see if you can configure your exchange to listen with SSL certificate on port 465, or if toshiba can be directed to port 587, configure an inbound SMTP connector on the exchange on 587 similar to the port 25 no ssl required to connect.
0
 
LVL 1

Author Comment

by:jsarinana
ID: 41805525
Ok Toshiba support is asking to allow the IP of the voicemail 192.168.1.8 using any port we want except for port 443. Where do I do this in Advance Firewall?
would this be an outbound rule or both?
I'm lost here
0
Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

 
LVL 76

Expert Comment

by:arnold
ID: 41805564
I do not understand what they are asking you to do.  Authorize access from the Toshiba Voicemail to what destination? To external sources that will be on your external firewall.  Access to LAN devices would be on inter-vlan traffic if you separate your VOICE devices from your DATA/LAN.
Access to specific clients, would be on your system's firewall if setup.
0
 
LVL 1

Author Comment

by:jsarinana
ID: 41805634
they are trying to forward voicemail messages to our email accounts using a dedicated email account vmail@ourcompany.com
here is a snap shot of the interface to setup smtp. We also tried the certificate name instead of the internal IP and also the external IP for the "Mail Server"
vmail-smtp.jpg
0
 
LVL 76

Expert Comment

by:arnold
ID: 41805698
Ok, but what is being setup as the destination mail server? Do they use a PUBLIC mail.somedomain.com as the destination, in which case you would need to grant on the external firewall access from the 192.168.1.8 to the outside (outbound) rule.
If you want access from the toshiba directly to your local exchange, make sure the internal routing (VLAN/ACCESS/local firewall on the exchange server) allow 192.168.1.8 to connect, and if no authentication is included in the configuration, allow 192.168.1.8 to relay through your Exchange server.

443 is not a valid port for Mail exchange. Port 443 is a secure web port (........)

The port for 192.168.1.26 should be 25 without SSL. Default SMTP port. If your setup is (exchange console) is such that you have incoming SMTP connector set to a different port, use that other port in the configuration of the Toshiba.
If you want an SSL connection, use port 456 and make sure your exchange has a connector that is using encryption on port 456 or any other port.
If your exchange server allows TLS, you can check that box and either use port 25 or 587 provided your exchange server has either/both of these ports configured.

Please note that you have a test section, check your settings and generate a test message until you succeed.

To simplify further, open your email client, and look at the account configuration there..
Match the toshiba configuration to the one reflected in the email client you use that works.
Presumably, your email client is configured to talk to the exchange server...
0
 
LVL 1

Author Comment

by:jsarinana
ID: 41806675
Thanks LVL 76
Where do I check for my Default SMTP port?
If I open Exchange Management Console and go yo Server Configuration and select the properties of the severname I don't see what port I'm using
0
 
LVL 1

Author Comment

by:jsarinana
ID: 41806697
I see under Hub Transport
"Use these local IP addresses to receive mail"
192.168.1.26 port 25
"Receive mail from remote servers that have the these IP addresses"
192.168.1.0-192.168.1.68.0
192.168.1.2-192.168.1.255

Do I simply add 192.168.1.8 to
"Receive mail from remote servers that have the these IP addresses"
then use port 25 on the Toshiba smtp setup?
0
 
LVL 76

Accepted Solution

by:
arnold earned 500 total points
ID: 41806982
192.168.1.8 is in the 192.168.1.2-192.168.1.255 the other seems to be a typo 192.168.1.68.0??
You need not only allow connecting
yes, use port 25 instead of the 443 in the image.

Look at the exchange log for incoming connection to see what happens when Toshiba connects......

You could allow 192.168.1.8 to relay meaning without the need to authenticate.....

Since your Toshiba is in production, usually, a test would be to bring up a computer/laptop with the IP 192.168.1.8 and then test whether the connection to the 192.168.1.26 can be made.

To check ports, you have to look a the connectors you have.
The link if for exchange 2013, similar .... applies in the older versions.

https://technet.microsoft.com/en-us/library/jj657461(v=exchg.150).aspx
0
 
LVL 1

Author Closing Comment

by:jsarinana
ID: 41812983
thanks I made a relay connector and it works now
0

Featured Post

What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
This story has been written with permission from the scammed victim, a valued client of mine – identity protected by request.
Familiarize people with the process of utilizing SQL Server views from within Microsoft Access. Microsoft Access is a very powerful client/server development tool. One of the SQL Server objects that you can interact with from within Microsoft Access…
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now