Solved

How to stop TextEdit from showing recently accessed files in Mac

Posted on 2016-09-17
2
195 Views
Last Modified: 2016-09-19
HI,
I am using Textedit and when it appears in Dock and i do a right click on it it shows the following :
Screen-Shot-2016-09-17-at-6.08.34-PM.pngOn the top of this list it shows the list of recently accessed files.
How do i clear this and stop it from displaying anything.
Although if i go to Open Recent the list is Blank...
Screen-Shot-2016-09-17-at-6.10.46-PM.pngThe recent list i set an option generally to not show anything.. But its still shows when i right click on the TextEdit.

Thanks
0
Comment
Question by:Rohit Bajaj
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 53

Assisted Solution

by:strung
strung earned 150 total points
ID: 41802989
You can globally stop all applications from showing recent items by going to System Preferences > General and setting Recent Items to Zero.
0
 
LVL 30

Accepted Solution

by:
serialband earned 350 total points
ID: 41803056
The setting may be None instead of Zero
That stops all applications that use the system, such as TextEdit from showing recent items, but unfortunately that doesn't stop the system from saving them to the 2nd plist file that shows on the dock.  Some applications use their own recent items list, such as Microsoft Office.

I've just clear them manually as I use them, since I find some of the recent items useful.

I haven't yet tried myself, since I want to keep my textedit plist, but you may be able to also clear each app individually if you still want to show recent items in other apps
defaults delete com.apple.TextEdit.LSSharedFileList.plist RecentDocuments
defaults delete com.apple.TextEdit.SandboxedPersistentURLs.LSSharedFileList.plist RecentDocuments

You'll find them in ~/Library/Preferences/

I think it may be due to the extra plist, com.apple.TextEdit.SandboxedPersistentURLs.LSSharedFileList.plist
I Got the idea from https://simon.heimlicher.com/articles/2011/07/26/disable-recent-items then examining ~/Library/Preferences/ to find 2 plists for TextEdit and Preview.  I suspect that setting the global setting toggles the first plist file, but not the SandboxedPersistentURLs.
1

Featured Post

Enroll in July's Course of the Month

July's Course of the Month is now available! Enroll to learn HTML5 and prepare for certification. It's free for Premium Members, Team Accounts, and Qualified Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article we have discussed about the OS X EI Capitan and how to fix Wi-Fi issue in OS X El Capitan. We have explained how to delete system level preferences and create a new Wi-Fi location to resolve Wi-Fi issue.
In this article we discuss how to recover the missing Outlook 2011 for Mac data like Emails and Contacts manually.
Users will learn how to set proper sequence settings, scale images, paste attributes, add transitions, fades, and music. Open up Final Cut Pro 7 and Create a new Project: Set the Sequence Settings. a) Click File > Easy Setup > Format > Apple ProRe…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

636 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question