Solved

old email cache issue

Posted on 2016-09-19
14
61 Views
Last Modified: 2016-09-26
I had this question after viewing OLD email address in CACHE.

 
Hello Following this issue mention in above question

now as suggested X.500 address has been updated, But now issue is, if any user reply to any old email of user. still getting rejected emails

any suggestion on that

Thanks,
Email Team
0
Comment
Question by:Addy Nadia
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 5
14 Comments
 
LVL 46

Expert Comment

by:Jackie Man
ID: 41804628
Have you tried to add an X.500 proxy address through the Exchange Management Console?

Source:  https://www.simple-talk.com/sysadmin/exchange/exchange-e-mail-addresses-and-the-outlook-address-cache/
0
 
LVL 5

Author Comment

by:Addy Nadia
ID: 41804640
yes, we already did this, but still getting issue
0
 
LVL 5

Author Comment

by:Addy Nadia
ID: 41805974
still there is issue, one more thing, if i can see the current legacy DN that is new and it is not in email address as a x.500 address

so anything need to be done with current legacydn ??

issue is when user trying to replying his old emails, he getting NDR

Thanks,
andy
0
Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 46

Expert Comment

by:Jackie Man
ID: 41805999
Have you added the old legacyExchangeDN X.500 address to the new mailbox as a proxy address?
0
 
LVL 5

Author Comment

by:Addy Nadia
ID: 41806032
yes.. i have added that, but still if user reply to any new email of that user, they get NDR
and user tried to send email to himself from webmail.. still NDR
0
 
LVL 5

Author Comment

by:Addy Nadia
ID: 41806036
Also we can see disconnected mailbox is still showing in disconnected state
0
 
LVL 46

Accepted Solution

by:
Jackie Man earned 500 total points
ID: 41806051
I think that you need to purge the disconnected mailbox as new mail is still pointing to it.

Exchange version?
0
 
LVL 5

Author Comment

by:Addy Nadia
ID: 41806061
exchange 2013
0
 
LVL 46

Expert Comment

by:Jackie Man
ID: 41806074
Permanently delete a disconnected mailbox

Use the Shell to permanently delete a disconnected mailbox

There are two types of disconnected mailboxes: disabled and soft-deleted. You must specify one of these types when running the cmdlet to permanently delete the mailbox. If the type you specify doesn't match the actual type of the disconnected mailbox, the command fails.

Run the following command to determine whether a disconnected mailbox is disabled or soft-deleted.

Get-MailboxDatabase | Get-MailboxStatistics | Where { $_.DisplayName -eq "<display name>" } | fl DisplayName,MailboxGuid,Database,DisconnectReason

Open in new window


Source: https://technet.microsoft.com/en-us/library/jj863440(v=exchg.150).aspx

Check with the user that the content inside the disconnected mailbox is of no practical use and the disconnected mailbox can be
removed.
0
 
LVL 5

Author Comment

by:Addy Nadia
ID: 41806085
so do you think, after purge the disconnected mailbox, will it Resolve  the issue permnanetly

means if any user reply to any old email of that user, will not get the NDR ?
0
 
LVL 5

Author Comment

by:Addy Nadia
ID: 41806108
i ran this command, but not giving any result, But in EAC i can see the mailbox in disconnected state.,
i also fetched the legacydn of that mailbox in Powershell using this

Get-MailboxStatistics -Server chlte312 | ?{$_.DisconnectDate -ne $null -and $_.DisplayName -like “craig kelly”} | Select LegacyDN
0
 
LVL 5

Author Comment

by:Addy Nadia
ID: 41808513
now after mailbox get purged from disconnected mailbox.

i checked with user, and from OWA issue resolved, when replying any old email before disconnected . it works now
but from outlook, still issues, getting NDR

i have cleared cache too, but still same.. on new email it works, but old email reply not works

Any suggestion
0
 
LVL 46

Expert Comment

by:Jackie Man
ID: 41809887
If OWA works, the problem is on the client side.

Request a copy of the NDR and the message of the sent mail and inspect the header.
0
 
LVL 5

Author Closing Comment

by:Addy Nadia
ID: 41815838
Thanks
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many people use more than one email account and so it becomes difficult for them to manage them when they use separate accounts,  so, in this article, I have shared an easy way to add Other Mail Accounts in your Google Inbox. It helps to combine all…
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question