Solved

W2012 R2 permission question

Posted on 2016-09-19
4
41 Views
Last Modified: 2016-09-22
I have an application that has a setting to allow users to use a file on a share on the server. This worked fine for all workstations but did not work to the T/S. The T/S is a W 2012 R2 server. What I discovered was this. If I address the file as \\servername\c$\share\my file.dat all is fine. However, if I address the file as \\servername\share\my file.dat no users including the domain administrator has no rights to this file. So it appears that there is a security issue with the share. I checked both the security and permissions and everyone has full control. What else can I check? I can go to any other computer and everyone has full control. It is only from the T/S where I have this issue.
0
Comment
Question by:rwheeler23
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 34

Expert Comment

by:ste5an
ID: 41804713
You need to check two things:

1) The rights on the share \\servername\share.
and
2) The rights on the folder of this share (NTFS).

And to clarify your problem: From where do you try to read that file and where is that share located?
0
 
LVL 4

Expert Comment

by:Stephen McTigue
ID: 41804803
I concur with ste5an, you need to check the NTFS permissions. Simply giving the Everyone group full control to the share is not going to allow the users to access the files using their AD security credentials (NTFS permissions). The share permissions basically give access to the directory across the network but not the files and folders within that directory at a granular level.

Here's a link that give a quick overview of the concept:

http://www.techrepublic.com/article/learn-the-basic-differences-between-share-and-ntfs-permissions/

Best of luck,
0
 
LVL 4

Accepted Solution

by:
Stephen McTigue earned 500 total points
ID: 41804827
So, I think I replied too quickly and read your issue again. I see that you stated that the security settings work since you can access the share from other workstations, just the terminal server is the issue. Did you see if the path works by replacing the servername with the IP address? If this works then it could be name resolution issue which could require flushdns on the local terminal server. If this also fails check the firewall settings on the terminal server. It's possible this is blocking communication to and from shares on other servers.
0
 

Author Closing Comment

by:rwheeler23
ID: 41811594
Thanks
0

Featured Post

Free eBook: Backup on AWS

Everything you need to know about backup and disaster recovery with AWS, for FREE!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

My GPO's made for 2008 R2 servers were not allowing me to RDP into a new 2012 server by default.  That’s why I tried to allow RDP via Powershell, because I could log into a remote shell without further configuration. Below I will describe how I wen…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question