• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 86
  • Last Modified:

Cannot Manage RDS 2012R2 Deployment

I have an odd problem that I can't seem to figure out.

I have a 2012R2 RDS deployment with a gateway, connection broker, and 3 session hosts. All the sudden, I can't seem to be able to manage the deployment.

If I log into any of the servers that are part of the deployment, add all of them to a server group, and then click on Remote Desktop Services, computer management tells me that an RDS deployment does not exist. The actual environment is working just fine, all users are working without issue, but I can't seem to manage it anymore.

The only thing that I haven't done is reboot the encironment, but wanted to see if anyone has seen this before.
0
jschweg
Asked:
jschweg
  • 2
1 Solution
 
Cliff GaliherCommented:
That occurs when communications to, or on, the connection broker are failing. WMI and SQL must both be up and working properly for Server Manager to properly read the topology.
0
 
jschwegAuthor Commented:
The connection broker is not in HA, just a single one. The WMI service appears to be running on the CB and the Remote Desktop Connection Broker Service appears to be running as well. Event log doesn't have anything in it of note.

Is there anything really I can "do" other than rebooting the CB?
0
 
Cliff GaliherCommented:
Check firewall settings. Dns. The usual suspects that'd block communications with WMI or SQL. Even non HA CBs use SQL express.
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now