Solved

OWA and AppPool problem

Posted on 2016-09-19
20
158 Views
Last Modified: 2016-10-06
Hi Experts,

I have the following setup.
EXCH 2007 with 2 HUB-CAS server and 2 mailbox server.
For intern, we use a network load balancer (NLB) , which is also installed on both HUB-CAS servers.

But for some reason, on one HUB-CAS server, the APP-POOLS in IIS are stopped.
Then we have problems with OWA, OoO and Autodiscover.

Can you help me to find out why always the APP-POOLs on the same HUB-CAS gonna stop ?
0
Comment
Question by:Eprs_Admin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 16
  • 3
20 Comments
 
LVL 17

Expert Comment

by:Emmanuel Adebayo
ID: 41806015
What are the errors in the application and system event logs

Regards
0
 

Author Comment

by:Eprs_Admin
ID: 41806021
I cannot find any related logfile.
Now I started the APP pools again and will wait until the first fails....
It takes some minutes.
0
 
LVL 17

Expert Comment

by:Emmanuel Adebayo
ID: 41806047
Ok
0
Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

 

Author Comment

by:Eprs_Admin
ID: 41806055
Ok, when I add this node to the NLB the APP Pools will stop.
0
 

Author Comment

by:Eprs_Admin
ID: 41806060
I get many errors now : ID 2280 , 5002 , 5139
0
 
LVL 17

Accepted Solution

by:
Emmanuel Adebayo earned 500 total points
ID: 41806095
There is a problem with one of your DLL module

I would suggest you perform the following steps to troubleshoot this issue:

Remove the exppw.dll entry from applicationhost.cofig (c:\windows\system32\inetsrv\config)Note: Remember take a backup before you remove the line.
Then registered the exppw.dll by following the below steps:

IIS Manager -> Select the Server Name in the left Pane -> Open Modules in the middle pane.
Click on ‘Configure Native Modules’ in the right pane -> Click the button ‘Register’ -> Type the name as ‘exppw’
Browse and select the path of above file as: c:\Programme Files\Microsoft\Exchange Server\V14\Client Access\OWA\Auth\exppw.dll.
Made sure that the 'exppw.dll' is only present at OWA level and not at any of the top heirarchy.
Then ensured for this module in OWA (VDir), ‘Module Type’ is set to ‘Native’ and ‘Entry Type’ is ‘Local’
Run IISreset /noforce
0
 

Author Comment

by:Eprs_Admin
ID: 41808184
Hi,

is it just this line ?
<add name="exppw" image="C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll" />
0
 

Author Comment

by:Eprs_Admin
ID: 41810550
Hi need your confirmation....please.
0
 

Author Comment

by:Eprs_Admin
ID: 41811995
Hello ?
0
 

Author Comment

by:Eprs_Admin
ID: 41815436
???
0
 

Author Comment

by:Eprs_Admin
ID: 41815438
Hi,

is it just this line ?
<add name="exppw" image="C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll" />
0
 

Author Comment

by:Eprs_Admin
ID: 41829428
I get the error message that a module with this name is still existing.

Just change the name ?
Or do I have to restart services after I deleted the line ?
0
 

Author Comment

by:Eprs_Admin
ID: 41829444
Then ensured for this module in OWA (VDir), ‘Module Type’ is set to ‘Native’ and ‘Entry Type’ is ‘Local’


Under the vDir I cannot change it. Just when I select the server and click modules, here its set to NATIVE and LOCAL.

Is it ok ?
0
 

Author Comment

by:Eprs_Admin
ID: 41829457
Now I have alot of errors with cgi.dll
can you help me out ?

When I check the config again there is no new line with EXPPW.
<add name="exppw" image="C:\Program Files\Microsoft\Exchange Server\ClientAccess\Owa\auth\exppw.dll" />

This line is missing and looks now :  <add name="exppw" />
0
 

Author Comment

by:Eprs_Admin
ID: 41829462
Please help me out.

When I start the app pools:

  • DefaultAppPool
  • MSExchangeAutodiscoverAppPool
  • MSExchangeServicesAppPool
  • MSExchangeUMAppPool

...then these pools are stopped within 5 seconds.

What is the problem ?
0
 

Author Comment

by:Eprs_Admin
ID: 41829467
Error 2280 each second
0
 

Author Comment

by:Eprs_Admin
ID: 41829474
Fehler beim Laden der Modul-DLL C:\Windows\System32\inetsrv\cgi.dll. Die Daten enthalten Fehlerinformationen.
0
 

Author Comment

by:Eprs_Admin
ID: 41829480
I changed back to the old config but still a lot of errors in the event log

each second:

Modul-DLL C:\Windows\System32\inetsrv\cgi.dll
0
 

Author Comment

by:Eprs_Admin
ID: 41831710
I think this is solved now.
0

Featured Post

How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

There is a lot to be said for protecting yourself and your accounts with 2 factor authentication.  I found to my own chagrin, that there is a big downside as well.
Postmortem reporting allow us to examine mistakes in a way that focuses on the situational aspects of a failure’s mechanism and the decision-making process of individuals proximate to the failure. Read our guide on how to handle IT post-mortem repor…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question