Windows 2012 Essentials - change of router

Hi There

We have just change ISP and also changed the router we are using. The new router has the same internal IP address and subnet mask as the old one.  With the change of ISP we have a different external IP address.

Everything is working fine, clients can access the internet no problem - however I cannot browse the internet from the server. I can ping a domain name from the server and it works returning the corresponding IP address, but cannot browse the web.

This is causing me a problem as I have a couple of applications which send emails automatically to customers but these are failing as the server seems unable to access the internet.

Where do I start please?
SJHAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Randy DownsOWNERCommented:
Your server is setup to use static ip so you need to know information like gateway & DNS servers. The easy way to find that is to connect a laptop setup for DHCP to the router directly. It should have no problem connecting to the Internet.

After laptop is connected do ipconfig /all from CMD prompt to find the information for your server static ip.
0
SJHAuthor Commented:
OK, so here is some more information:

Note all clients can access the internet perfectly as well as access resources on the server, there is only one server on the network.

ipconfig /all on a client
C:\Users\stephen>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : HEDPC033
   Primary Dns Suffix  . . . . . . . : HOYLES.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : HOYLES.local

Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 4C-CC-6A-22-DB-E5
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::78c3:fb32:f23e:4e67%5(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.102(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 16 September 2016 11:55:53
   Lease Expires . . . . . . . . . . : 21 September 2016 11:55:53
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 55364714
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1F-27-7B-E3-4C-CC-6A-22-DB-E5
   DNS Servers . . . . . . . . . . . : ::
                                       192.168.0.24
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{411AA243-E869-43BF-AEC6-530AEDE80DD3}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes



Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.


IPCONFIG /all on the server

C:\Users\sandywash>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : HOYLESSVR
   Primary Dns Suffix  . . . . . . . : HOYLES.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : HOYLES.local

Ethernet adapter NIC2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet #2
   Physical Address. . . . . . . . . : 90-B1-1C-56-E1-87
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter NIC1:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
   Physical Address. . . . . . . . . : 90-B1-1C-56-E1-86
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8911:3a2f:52cd:3ec8%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.24(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 261140764
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-48-72-F1-90-B1-1C-56-E1-86

   DNS Servers . . . . . . . . . . . : ::1
                                       127.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{46D43D6C-2854-4ED0-8805-1F30F7895B7F}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{977C21B2-6036-4B60-B428-5240353D5314}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\Users\sandywash>



The server has a static IP address which is 192.168.0.24
The IP address of the router is 192.168.0.1
The router is providing DHCP.

Like I say, everything seems to work except the server doesn't seem able to access the internet although the clients can.
0
Randy DownsOWNERCommented:
Try setting server DNS to itself 192.168.0.24. Have you rebooted server since the router change?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

SJHAuthor Commented:
Yes, I rebooted it earlier.

Just changed the DNS setting as below - this has made no difference.

Microsoft Windows [Version 6.2.9200]
(c) 2012 Microsoft Corporation. All rights reserved.

C:\Users\sandywash>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : HOYLESSVR
   Primary Dns Suffix  . . . . . . . : HOYLES.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : HOYLES.local

Ethernet adapter NIC2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet #2
   Physical Address. . . . . . . . . : 90-B1-1C-56-E1-87
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter NIC1:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
   Physical Address. . . . . . . . . : 90-B1-1C-56-E1-86
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8911:3a2f:52cd:3ec8%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.24(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 261140764
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-48-72-F1-90-B1-1C-56-E1-86

   DNS Servers . . . . . . . . . . . : ::1
                                       192.168.0.24
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{46D43D6C-2854-4ED0-8805-1F30F7895B7F}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{977C21B2-6036-4B60-B428-5240353D5314}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\Users\sandywash>
0
Randy DownsOWNERCommented:
Are you trying to access the Internet via Internet Explorer? If you have another browser, give that a try. If you don't have another browser download stand alone copy onto a USB drive & install.

What error do you get accessing Internet?
0
sarabandeCommented:
did you check in System Settings - Network ... Center?

how many connections/adapters do you see? it should be two beside the router also is used as a switch.

in any case the connection to your router should not be 'public' but 'private' and 'workplace'. it also should show that the internet is enabled.

if you have only one adapter you should be able to alter wrong settings for the connection (double-click at the icon). hen go to advanced adapter settings and check the properties, then the propertiess of the services, especially IP4 and IP6. you can temporarily disable ip6 (remember the old settings somehow) and try only with ip4. if that doesn't help, try to using dhcp and dns of the router. as it worked with the Client it also should work with the server. on success print the ipconfig /all and try to keep all settings beside of the fixed ip4 address.

Sara
0
SJHAuthor Commented:
Thanks for your help so far, but the problem continues...

I have disabled IPv6, this has made no difference.

To be clear of the setup here. Server is Windows Server 2012 essentials with 1 NIC. This NIC has a fixed IP address, DNS is set as 127.0.0.1 as it should be. Default gateway is set to 192.168.0.1 which is the IP address of the router.

Clients are DHCP which is obtained from the router, however they have their DNS set to 192.168.0.24 which is the IP address of the server. This must be setup by the Essentials client connection wizard because I haven't set it manually.

Router is a brand new TP-Link Archer VR2600 which was installed at the same time as changing ISP.

The clients have no problems at all accessing websites via IE or Chrome.

The server is the problem. The server needs to be able to send emails automatically from a couple of applications, but this fails. I have found that on the server I am unable to browse the web.
I have installed Chrome on the server and still cannot browse the web. Interesting though that I can access www.google.co.uk no problem and searches are returned quickly. I can also access facebook. However other sites such as www.bbc.co.uk just time out and are not displayed, the following is displayed in Chrome:
The www.bbc.co.uk page isn’t working
www.bbc.co.uk didn’t send any data.
ERR_EMPTY_RESPONSE

However from the command prompt I can ping www.bbc.co.uk with the following results:

C:\Windows\system32>ping www.bbc.co.uk

Pinging www.bbc.net.uk [212.58.246.54] with 32 bytes of data:
Reply from 212.58.246.54: bytes=32 time=22ms TTL=55
Reply from 212.58.246.54: bytes=32 time=17ms TTL=55
Reply from 212.58.246.54: bytes=32 time=18ms TTL=55
Reply from 212.58.246.54: bytes=32 time=18ms TTL=55

Ping statistics for 212.58.246.54:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 17ms, Maximum = 22ms, Average = 18ms

C:\Windows\system32>

Anyone any ideas?
0
Randy DownsOWNERCommented:
Best practice is to run DHCP on your server, not the router.
0
SJHAuthor Commented:
Maybe it's best practice but Essentials comes without it configured by default, also this configuration has been working perfectly for 3 years. There is just the change of router that has caused this problem
0
Lionel MMSmall Business IT ConsultantCommented:
The problem as I see it is that the internet DNS servers are missing. Your ISP should have given these to you but you can use google's to test. Add the secondary DNS as 8.8.8.8; you can also add a 3rd one then use 4.4.4.4. If the primary DNS is not working on its own it points to an issue with your internal DNS server -- check its log files -- did you change it w/this change?
0
SJHAuthor Commented:
Here is the current ipconfig on the server:


C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : HOYLESSVR
   Primary Dns Suffix  . . . . . . . : HOYLES.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : HOYLES.local

Ethernet adapter NIC1:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
   Physical Address. . . . . . . . . : 90-B1-1C-56-E1-86
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::8911:3a2f:52cd:3ec8%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.0.24(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 261140764
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-48-72-F1-90-B1-1C-56-E1-86

   DNS Servers . . . . . . . . . . . : 127.0.0.1
                                       8.8.8.8
                                       4.4.4.4
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{977C21B2-6036-4B60-B428-5240353D5314}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 12:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\Windows\system32>


This is a Windows 2012 Essentials server which has the DNS server enabled by default.

With these settings I still have the problem. I'm testing with Chrome browser. I can do Google searches no problem but cannot access sites such as www.bbc.co.uk.

All of the clients point to the server IP address for their DNS and all work perfectly. The problem is only on the server itself.

The router itself has automatically obtained the ISP's DNS server details.

If I swap back to the old router on the old broadband connection everything works - however I do need to get the new router/broadband working.

it's almost as if the server cannot route certain traffic through the router for some reason.
0
SJHAuthor Commented:
Note also that I can successfully ping any domain from the server - so I wonder if DNS is not the issue.
0
Davis McCarnOwnerCommented:
Many newer routers will refuse traffic from devices which were not assigned an ip address from its own DHCP; but, the fix is relatively easy.  Add the server to the reserved IP addresses in the router which is an option in its web management.  You will need to have the mac address of the server to do it which is in the ipconfig entries you posted above and listed as Physical address.
0
SJHAuthor Commented:
I did try that yesterday and it didn't work. Just done the same now and it's still not working. here is the router config screen:

Capture.PNG
It did try also making the server DHCP client so that it had to get its address from the router, but that still didn't work.

I have just noticed something else - all https sites seem to work but no http only sites do - is this a clue? This behavior is only occurring on the server.
0
Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
It almost sounds like enhanced internet security is installed on the server. Especially since pings works. That blocks access to a lot of web sites. This originated from the security practice that you shouldn't normally need to browse web sites from the server.

For that matter make sure the windows firewall if turned off, at least for now while you are troubleshooting this problem. Also check firewall settings on your router to make sure it isn't blocking web traffic (port 80).

Maybe I misunderstood some advice above, but splitting your DNS and pointing it to an outside source is a bad idea. Your DNS should already be configured to use forwarding. So setting an outside DNS server on the machine providing DNS services is not required.
0
SJHAuthor Commented:
I Agree. The thing I can't figure is that with my old router everything works.

If the router is blocking port 80 then it's only doing it for traffic from the server because all of the clients are working fine.

The clients are pointed to the server for DNS and they work fine.

The DNS Manager on the server shows as single forwarder which is 192.168.0.1 - which is the router. I have tried adding in the ISP's DNS servers as forwarders, but that has made no difference.
0
Brian BEE Topic Advisor, Independant Technology ProfessionalCommented:
I have tried adding in the ISP's DNS servers as forwarders, but that has made no difference.

If pinging an external site by name works, I am thinking you can safely assume DNS is not the issue. I was just trying to steer you away from some other advice which may cause you problems.

Perhaps the router is actually defective. I would be tempted to ask your ISP for another one, just to be sure. (Hopefully it wasn't too much work to set it up).

Now to contradict myself... The fact you got err_empty_response from Chrome also indicates some sort of underlying problem. Perhaps the new router is not the cause and this is just a co-incidence? Every solution I have found for that error has been something to do with cache settings or cookie or something like that.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Davis McCarnOwnerCommented:
In an elevated CMD window, type ipconfig /flushdns which will clear the DNS cache on the server.  Did that change things?
0
sarabandeCommented:
If pinging an external site by name works, I am thinking you can safely assume DNS is not the issue.
is that a valid conclusion?

as we have, that clients successfully used the server for dns and the server itself can resolve names for ping, we know that the server has a working dns. but we don't know which name service was used by the browser. also the issue might be that the browser has a proxy or vpn or that the browser ports at the server were locked by a firewall or anti-malware.  

did you try to use the browser with an ip number?

Sara
0
SJHAuthor Commented:
In an elevated CMD window, type ipconfig /flushdns which will clear the DNS cache on the server.  Did that change things?

No, I'd previously tried that, but have done it again - still no joy.

I've obtained a different router to try so will do that out of hours tonight.

I've tried clearing browsing history etc, Are there any other cache or cookie related thinks I could look at?
0
SJHAuthor Commented:
did you try to use the browser with an ip number?
Could you suggest an IP address I can try this with, ones I have tried in the browser fail to respond

I've turned off windows firewall and also anti virus while testing.

There are no VPN's or proxys set to my knowledge.
0
Davis McCarnOwnerCommented:
Try http://212.58.246.54 which is the BBC.UK ip you posted earlier.
Server 2003, 2008, and 2012 all come with "enhanced security" enabled for the browser.  Did you, perchance, mess with that at all on the old router?
0
SJHAuthor Commented:
Thanks for your help everyone. It turns out that replacing the router with one of a different make has solved the problem. Whether the router I had was faulty or there was just some very strange incompatibility I'll never know.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.