Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 182
  • Last Modified:

NetWorker On CentOS

Hello Guys,
Does anybody works on networker on CentOS. I need some help starting it. It gives the error :
nsrexecd: Failed to resolve hostname Server1to an internet address. Please verify a mapping for Server1exists in the /etc/hosts file or DNS

Best Regs
0
mos1234
Asked:
mos1234
  • 8
  • 6
1 Solution
 
omarfaridCommented:
From the error message, it is trying to do reverse lookup for IP address to DNS name.

if you are using DNS, then add PTR record to your DNS. Please see:

https://www.centos.org/docs/5/html/Deployment_Guide-en-US/s1-bind-zone.html

If not using dns, then add line to /etc/hosts file for the IP and map to host name.
0
 
mos1234Author Commented:
Hello,
Why are you giving me bind config link....my DNS server is a Windoze!!!

Best Regs & Thank you
0
 
omarfaridCommented:
ok, please below link on how to add on windows dns:

https://technet.microsoft.com/en-us/library/cc844045(v=ws.10).aspx
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
mos1234Author Commented:
Thanks for feedback...i guess this is true...but i dont wanna make change on dns server side...is there a way to force NetWorker to reverse lookup locally on the linux box
0
 
omarfaridCommented:
try to add to local hosts file
0
 
mos1234Author Commented:
thank you omarfarid...i have tried it several times...does not work....am now with EMC NetWorker Support...i'll keep you updated if we find some solution without modif on DNS Server.
0
 
omarfaridCommented:
What is the config in /etc/resolv.conf file?
0
 
mos1234Author Commented:
i will check tokorrow for this and let you know
0
 
omarfaridCommented:
Also, look at hosts: entry in /etc/nsswitch.conf
0
 
omarfaridCommented:
@ mos1234,

Is the issue resolved?
0
 
mos1234Author Commented:
solution was not found here ...am sorry
0
 
serialbandCommented:
Then the question should be deleted.
0
 
mos1234Author Commented:
Solution was through correcting name resolution problem on thé Linux.
It seems that NetWorker client is very sensitive to name resolution on Clients.
0
 
mos1234Author Commented:
Simply issuing hostname HOSTNAME command resolved the issue...!!!
0
 
mos1234Author Commented:
That was Support solution
0

Featured Post

Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

  • 8
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now