Solved

create default folder structure and ownership on user creation

Posted on 2016-09-20
5
117 Views
Last Modified: 2016-10-26
Dear Experts,

I'm involved in a rather big project and I'm trying to automate as much of it as possible.
The problem I'm tackling right now consists of the following.
Assume I have a web interface that accepts a domain (for this example, we shall use banana.com)
the web interface then removes any dots, hyphens or any other special character from the domain name and passes the resulting string as a parameter to a bash script, which in turn invokes the useradd command.
so in this case, the command will be invoked as
useradd -m bananacom

Open in new window


This is all good and well and works fine.
I have also modified the /etc/skel folder to automatically create public_html and tmp folders in each users home directory.
Since we are using a very heavily customized NGINX version (Running on Centos 7) I need that everything under /home/$user/public_html (including the public html folder itself)
will always be set to 750 permissions, and $user:nginx ownership.

Meaning the as soon as I cerated the user, if I'd go to /home/bananacom
I'd see 2 folders in it:
/home/bananacom/public_html
/home/bananacom/tmp
Both will have drxw for bananacom, r-x for nginx and --- for other.
also, I need anything created under the public_html to defualt to those settings as well.
How would I go about creating such a thing?
0
Comment
Question by:David Sankovsky
  • 2
  • 2
5 Comments
 
LVL 29

Accepted Solution

by:
serialband earned 500 total points
ID: 41809357
I believe you just need to set the default umask as 0027 for all users and they should be set correctly.
0
 
LVL 7

Author Comment

by:David Sankovsky
ID: 41810133
This will help with the permission Settings.
I still need to know how to set the default ownership.
Seeing as I need the skeleton to be created with nginx as the group
0
 
LVL 6

Expert Comment

by:huacat
ID: 41830135
# please create other folders first before below commands!
# set ownership command:
chown -R bananacom:nginx /home/bananacom/
# set permission command:
chmod -R 750 /home/bananacom/
0
 
LVL 7

Author Closing Comment

by:David Sankovsky
ID: 41856733
That worked better than expected Thank you
0
 
LVL 29

Expert Comment

by:serialband
ID: 41861423
Did you mean to give me all the points?  If you meant to split the points I can request attention and let you divide it properly.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Ubuntu Apache Webserver - File Permissions 5 71
sticky session 2 34
rsyslog raw message 4 35
Can't "Unset" Proxy in Apache headers for PCI compliance... 4 31
Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
​Being a Managed Services Provider (MSP) has presented you  with challenges in the past— and by meeting those challenges you’ve reaped the rewards of success.  In 2014, challenges and rewards remain; but as the Internet and business environment evol…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

680 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question