Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

SQL DBmail taking ages to send emails

Posted on 2016-09-21
9
Medium Priority
?
57 Views
Last Modified: 2016-10-25
We send around 300 emails out at 4pm every day however there is something i suspect on my exchange server that limits the amount SQL is allowed to send to it within a certain period.

I have set SQL to keep retying until the emails send but thats just a work around.

Is there a setting i can change on my exchange server to allow SQL to send more emails at once? We are using exchange 2016 with sql 2012.

Thanks in advance for any help.
0
Comment
Question by:CaptainGiblets
  • 6
  • 3
9 Comments
 
LVL 44

Expert Comment

by:Amit
ID: 41809261
Any error you see?
0
 
LVL 6

Author Comment

by:CaptainGiblets
ID: 41810253
The mail could not be sent to the recipients because of the mail server failure. (Sending Mail using Account 3 (2016-09-21T16:57:11). Exception Message: Cannot send mails to mail server. (Service not available, closing transmission channel. The server response was: 4.4.2 Message submission rate for this client has exceeded the configured limit).
)

however if i run Get-ReceiveConnector | select identity,messageratelimit i get the attached.

My 2 sql connetors depeding on what server i point them to both have "unlimited"

message rate limit
0
 
LVL 44

Expert Comment

by:Amit
ID: 41810671
How is CPU usage on Exchange server. Total how many servers you have?
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 
LVL 6

Author Comment

by:CaptainGiblets
ID: 41810688
2 exchange servers, there cpu usage is at around 5% on server db mail profile points to.
messageratelimit.png
0
 
LVL 44

Expert Comment

by:Amit
ID: 41810842
How about mail flow for normal users? Do you see any delay. I suggest you to create separate relay connector for application mail flow. Then test again.
0
 
LVL 6

Author Comment

by:CaptainGiblets
ID: 41810844
the delay is only for the SQL server.
0
 
LVL 44

Accepted Solution

by:
Amit earned 2000 total points (awarded by participants)
ID: 41810850
Create new relay connector and test it. Or you can enable pipe line tracing to troubleshoot this further. How to do it:
https://technet.microsoft.com/en-us/library/bb125018(v=exchg.150).aspx
0
 
LVL 44

Expert Comment

by:Amit
ID: 41832053
Hi CaptainGiblets,

Did you created the relay connector, I suggested? Or issue still persist
0
 
LVL 44

Expert Comment

by:Amit
ID: 41858228
Creating relay connector is best option.
0

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

With so many activities to perform, Exchange administrators are always busy in organizations. If everything, including Exchange Servers, Outlook clients, and Office 365 accounts work without any issues, they can sit and relax. But unfortunately, it…
In this post, I will showcase the steps for how to create groups in Office 365. Office 365 groups allow for ease of flexibility and collaboration between staff members.
This video discusses moving either the default database or any database to a new volume.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
Suggested Courses

885 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question