Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 253
  • Last Modified:

Can't Make Laptop Computer Connect To Homegroup

Hello Experts:

For some reason my laptop can't communicate across a network to see files on a desktop computer.

The laptop hasn't moved from being connected to my home network (when there was a time when the thing work).

If seems when I select My Computer / Homegroup it says "No other Homegroup computers are currently available." That observation is not true. The problem is that the laptop won't connect to the network.

I've tried everything and can't get the darn thing to connect. What's the secret? The computer I am trying to connect to has no problem indicating it is attached to the network.

Thanks.

Gordon
0
gbmcneil
Asked:
gbmcneil
  • 18
  • 15
1 Solution
 
John HurstBusiness Consultant (Owner)Commented:
Make sure for starters that the Homegroup services are running. If not, restart the service then restart the computer.

The problem is that the laptop won't connect to the network.  I assume you mean the homegroup network, not the physical network.

If you cannot make the one computer work, you may need to stop the homegroup, remove it, and then set it up again.
0
 
gbmcneilAuthor Commented:
Hi John -

How would "shut down" and "restart" the Homegroup service?
0
 
John HurstBusiness Consultant (Owner)Commented:
Admin Tools, Services, find the Homegroup services, right click, stop, then start.

For the computers, Homegroup is also in Control Panel and you can remove the Homegroup associations there.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
gbmcneilAuthor Commented:
Hi John -

I stopped and restarted the Homegroup Service.

Can you give me a hint as to how I would go about re-adding the laptop (the offending computer) to the Homegroup local area network? Right now, the laptop is off-line.

Thanks.
0
 
John HurstBusiness Consultant (Owner)Commented:
Please be clear. Is the laptop on line and just not on Homegroup?  I think so but please be clear.

Go to Control Panel on the Laptop, Homegroup and try to join the main Homegroup.
0
 
gbmcneilAuthor Commented:
If by on-line you mean connected to the outside world via a router, the answer is "yes".

But, I get back to the fundamental question: "How do I add the laptop to the Homegroup"?

I've got Windows 7.
0
 
John HurstBusiness Consultant (Owner)Commented:
As above. Control Panel, Homegroup and join the main group.
0
 
gbmcneilAuthor Commented:
John, I'm at an impasse.

Control Panel / Homegroup doesn't buy me anything.

In addition the desktop computer that was a few minutes ago connected to the Homegroup, is no longer. Then mysteriously it re-connected to the Homegroup. But, the laptop is still not on the local area network.

160921-Pic-Of-Homegroup-Dialog.jpg
0
 
John HurstBusiness Consultant (Owner)Commented:
So then (as also mentioned above), pick one main computer (not the laptop) and set up Homegroup on it again. That is start over with a new Homegroup. Then join the other computers.

Use the Troubleshooter if necessary as it may have useful information .

Also remember Homegroup services must be running on all computers.
0
 
gbmcneilAuthor Commented:
The desktop is successfully running on the desktop computer. I can click on the My Computer and then Homegroup and I can see the files local to the desktop computer and the files on the laptop.

But, it is looking the other way which is the problem. I want to repeat the above on the laptop so that I can copy a file to the desktop.

It is at this point that I am at a loss. Clicking on Homegroup on the laptop leads me to a dialog that says nothing about adding the current computer to the Homegroup.  

That's the picture I'm showing above. Stumped.
0
 
John HurstBusiness Consultant (Owner)Commented:
Did you follow all the steps in the Homrgoup setup above (use the Desktop computer)

Make sure that the Network location is properly set (Network and Sharing Center, Advanced).
Make sure the Homegroup password is used by all.
Make sure again services are running.

What did the Troubleshooter say on the Laptop?

When done, restart the laptop.

I get the impression you may not be trying all steps on all computers.

There also could be some issue with the laptop. Check Network setup (Home not Work) carefully on this computer.
0
 
gbmcneilAuthor Commented:
I'm giving up for tonight. Have been at it almost 7 hours.

Still no success.
0
 
John HurstBusiness Consultant (Owner)Commented:
It appears the desktop computer is working properly at least so far as we know.
Do you have another computer OR just the laptop?

To review the Laptop again:

Go to Control Panel, Network and Sharing Center and make sure Network Discovery, File and Print Sharing and Homegroup are all ON.
Go to Services and make sure the TWO Homegroup services are not stopped.
Check Computer, Properties, Advanced System Settings, Name and make sure you are on the SAME Workgroup as the desktop.

Restart the Laptop.

Now go to Control Panel, Homegroup and run the Troubleshooter.

What error do you get?  Please post all of the error text,
0
 
gbmcneilAuthor Commented:
Hi John -

Thanks for your help and your persistence.

There is something flaky going on. I turned my laptop "off" last night. Just moments ago, I got up and powered up laptop. Lo and behold  the connection was established and from my laptop I could see all the files on the desktop because Drive C on the desktop had been setup as a "shared".

Then I left my computer for a couple of minutes (to get the coffee brewing), came back to the laptop, and discovered that I had lost the connection to the desktop.

If that is weird enough, I went to the desktop computer and I can see the connection back to the laptop.

I repeat. I can't see the desktop from the laptop, but can see the laptop from the  desktop. And, the Troubleshooter can figure it out.

Baffled.
0
 
gbmcneilAuthor Commented:
Get this, John -

I just left the Experts Exchange and went back to Windows Explorer on the laptop.

Now, it's working. This is twilight zone stuff!

Gordon
0
 
gbmcneilAuthor Commented:
160922-Pic-Of-Homegroup-Vs-Network.jpgNow, when I go to Windows Explorer on the laptop and click on "Homegroup," I get taken to the screen that says that "No Computers Are Currently Connected To The Homegroup".

But when I click on "Network" in Windows Explorer on the laptop, I can see that both the laptop and the desktop are in fact connected to my little local area network. Then I can click on the variety of shared drive icons and see all my files.

Very weird!

160922-Pic-Of-Homegroup-Vs-Network.jpg
0
 
John HurstBusiness Consultant (Owner)Commented:
Now, it's working. This is twilight zone stuff!

So it IS working now, correct. That is great.

Homegroup requires:

1. A Homegroup:  Set up on one computer in Control Panel
2. Two Homegroup Services to be OK to start

So with the changes and restarts, that is probably what finally got it going.
0
 
gbmcneilAuthor Commented:
Hi John -

After tending to emails, I went back to Windows Explorer and discovered that my connection was lost again.

I did a Google search and I see that I am not the only one who has experienced this problem. Let me do some research and I will get back to you.

160922-Pic-Google-Drop-Connection.jpg
0
 
John HurstBusiness Consultant (Owner)Commented:
As a troubleshooting step, try the following traditional step at a command prompt on the laptop.

NET USE T: \\name_of_desktop\folder  If asked to authenticate, do so.  

If that does not connect:

NET USE T: \\IP_address_of_desktop\folder and authenticate.

What numerical errors do you get?
0
 
gbmcneilAuthor Commented:
John -

No matter whether my laptop is connected to the Homegroup network, there is always a red cross visible in the icon tray in the lower right corner of my screen. See below.

160921-Icons-In-Lower-Right-Screen.jpg
0
 
John HurstBusiness Consultant (Owner)Commented:
First please address the questions above.

Second, with respect to the error screen above, that suggests an operating system issue and NOT Homegroup.

Run TCP/IP Reset and Please report back

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

If that does not work, do the following:

Go to Device Manager, and uninstall (remove) the network card. Shut down, start up and let it find and install the network card.

Does that provide proper operation.

This now is NOT a Homegroup issue at all.
0
 
gbmcneilAuthor Commented:
John -

Per your recommendation, what do I do to "authenticate"?

"NET USE T: \\name_of_desktop\folder  If asked to authenticate, do so."

I'm not a network-type of guy. This stuff is Greek to me (no slander intended; I love the Greeks).
0
 
gbmcneilAuthor Commented:
Hi Again John -

Keying "NET USE T :\\name_of_desktop\folder"

I Get:   System error 67 has occurred.  
           
             The network name cannot be found.
0
 
John HurstBusiness Consultant (Owner)Commented:
Look at this Microsoft article about System Error 67 and try what can be applied to your system.

https://support.microsoft.com/en-ca/kb/843156

Also look at this article as well

https://social.technet.microsoft.com/Forums/office/en-US/9c429bef-edf0-4bad-83a3-644e6ba28ea8/net-use-system-error-67?forum=winservergen
0
 
gbmcneilAuthor Commented:
John -

Keying "NET USE T:\\address_of_desktop\folder


I Get:   System error 67 has occurred.  
             
              The network name cannot be found.


0
 
John HurstBusiness Consultant (Owner)Commented:
Please review the articles I posted.
0
 
gbmcneilAuthor Commented:
In the #1 article you recommended above, it is telling me to go into the Device Manager and disable the driver "IP Network Address Translator" in the hidden device section.

Unfortunately, I don't have a driver named "IP Network Address Translator". See below.

160922-Pic-Of-Hidden-Device-Drivers.jpg
0
 
John HurstBusiness Consultant (Owner)Commented:
Did you try?

1.  The TCP/IP Reset above.
2.  Reinstalling the Network Card (above).
0
 
gbmcneilAuthor Commented:
You want me to disable all three of these Network Adapter entries?

160922-Pic-Network-Adapters-Disable.jpg
0
 
John HurstBusiness Consultant (Owner)Commented:
Only the adapter you are using. You do not need to concern yourself about the Miniport adapters - just the first two real adapters. Uninstall the one you are using that shows the red x

If it is the wireless adapter, make sure first you have the manufacturer's driver on hand.
0
 
gbmcneilAuthor Commented:
Hello John -

Well it is time to award you a trophy. It seems to be working perfectly.

The critical step seems to be resetting the TCP / IP arrangement with the series of three commands.

Thanks very much for your help. You can be sure that you will never find me competing against you on the Experts Exchange.

Gordon
0
 
gbmcneilAuthor Commented:
You should have received 5000 points.
0
 
John HurstBusiness Consultant (Owner)Commented:
Thank you for the update and for the kind compliments. I appreciate it. I am glad all is working well.
0

Featured Post

Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

  • 18
  • 15
Tackle projects and never again get stuck behind a technical roadblock.
Join Now