Windows 10 Peer to Peer Access

I know. Not my idea...  very odd. Sue cannot ping (by name or IP) Larry's computer but Larry can ping Sue's computer. Same story. It use to work fine but today it doesn't. I shut the firewall service off on both. No joy. Any ideas?
LVL 15
LockDown32OwnerAsked:
Who is Participating?
 
crystal (strive4peace) - Microsoft MVP, AccessRemote Training and ProgrammingCommented:
> "Something changed between yesterday and today"
Windows updated -- you may need to change settings again
0
 
JohnBusiness Consultant (Owner)Commented:
Please read my article on Modern Folder sharing

https://www.experts-exchange.com/articles/16639/Folder-sharing-on-modern-machines.html

and make the settings changes on both machines and then restart both.

Then test again.
0
 
LockDown32OwnerAuthor Commented:
Their peer to peer is set up fine. Something changed between yesterday and today. Looking for ideas...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
JohnBusiness Consultant (Owner)Commented:
Try resetting TCP/IP on both machines.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer
0
 
McKnifeCommented:
Turning off the firewall service does not open ports. Turning off the firewall (through the firewall GUI) does and should be tried.
0
 
LockDown32OwnerAuthor Commented:
I have to ask. Throughout the years the biggest fix to connectivity has been to stop the firewall service. Turning off the firewall via the GUI has not work. Stopping the service has. EE is littered with this solution. If the firewall service is off what process is blocking ports?
0
 
McKnifeCommented:
No, since Vista (came out late 2006), this is no longer true. You need to disable the firewall through the GUI, not the service.
" If the firewall service is off what process is blocking ports?" - I have no idea, but I don't care, I have to say.
0
 
LockDown32OwnerAuthor Commented:
I'll find out and let you know.....
0
 
LockDown32OwnerAuthor Commented:
The netsh does about 5 resets and on the sixth one it comes back with a failed, access denied. Ideas?
0
 
McKnifeCommented:
"The netsh"... what did you do with netsh?
There are predefined firewall setting for ping (="ICMP echo request"), just use these.
0
 
LockDown32OwnerAuthor Commented:
John's suggestion above was to reset TCP/IP. It happened to another one today. P2P is bad enough with just 2 or 3 computers. They have 7. Then throw in Windows 10...
0
 
McKnifeCommented:
The firewall GPOs should be used. That's how companies open computers for pings, they adjust the firewall policies with GPOs. Called ICMP echo request inside the predefined rules, as noted before.
0
 
LockDown32OwnerAuthor Commented:
Pinging was just one of the symptoms. Not the only symptom. One computer could browse the shares on the other but now visa versa. One could ping the other but not visa versa. The way the other people set up the shares was by giving "everyone" full access to the shares and not using passwords. Then the just has to browse via File Explorer and open other computers at will

Then all of a sudden the other day when this lady tried browsing another workstation it popped up for the first time and started asking for credentials. Then yesterday they couldn't scan from the copy machine to a workstation. Just basic W10 P2P issues. It doesn't appear to be Firewall related but I haven't put my finger on it yet.

Resetting the TCP/IP Stack, disabling IPV6, enabling Netbios , setting Advanced Sharing to use passwords and editing the registry to allow blank passwords seems to fix it but know one know why it started happening or which "fix" actually did the trick.
0
 
JohnBusiness Consultant (Owner)Commented:
setting Advanced Sharing to use passwords   <-- This option is related to Homegroup. The machine either uses Homegroup or it uses password protected sharing. The options are mutually exclusive.
0
 
LockDown32OwnerAuthor Commented:
The implication was password protected sharing. Homegroup is dangerous. Never use it. Did you see my question regarding netsh?
0
 
JohnBusiness Consultant (Owner)Commented:
The netsh does about 5 resets and on the sixth one it comes back with a failed, access denied. Ideas?  

That does not happen on my machines or any client machine, so I am not sure why that happened, or indeed, if it is related to making things work.
0
 
LockDown32OwnerAuthor Commented:
I hate to be the bearer of bad news but it happens on my computer and all my client's computers (Windows 10). At the least Windows 10 computers. See screen shot.....
Capture.PNG
0
 
JohnBusiness Consultant (Owner)Commented:
Sorry about my confusion over "5 times". Your screen shot clarifies things. That is the way NETSH works and always has for me. It still resets the stack.

So back to the password / homegroup change as the variable that fixed things
0
 
LockDown32OwnerAuthor Commented:
Still no definitive answer on which step actually fixed things. The options was under Homegroup and "Use User Accounts and Passwords to connect to other computers" but since Homegroup wasn't being used that option is moot.

This is basically normal Windows 10 P2P issues. No rhyme or reason. No definitive fix (yet). You just try enough things and all of a sudden it starts working again.....
0
 
JohnBusiness Consultant (Owner)Commented:
That is because more than one variable can cause issues.
0
 
LockDown32OwnerAuthor Commented:
There you go. The real question is "which variable changed and caused the problem". That is what I meant above by "This is basically normal Windows 10 P2P issues. No rhyme or reason. No definitive fix (yet). You just try enough things and all of a sudden it starts working again....."
0
 
JohnBusiness Consultant (Owner)Commented:
I have my two personal machines set up for peer to peer access and it works great.

Last week we were at our cottage for a week and I assisted a person here with Homegroup issues (making it work). To do that, I was in Control Panel, Homegroup and also Services.

All was well and I thought nothing more about it until Monday at a client and I could not connect to their server. Since networking was fine, the first port of call here was Advanced Sharing Settings in Network and Sharing Center. The password setting had been disabled.

I enabled Passwords, restarted and all was normal again.
0
 
LockDown32OwnerAuthor Commented:
John, you keep using the phrase "I do it on mine and it works great". Well.... as a rule things do but not always. I know peer to peer works. Has for a long time and it does work great when it works. I am happy it is working great for you but the problem is that it isn't working great for this one customer. If everything worked great all the time there would be no need for EE :)

I don't use home Homegroup and neither did the IT place that initially set up this network. Something changes and as is sometimes the case with Windows there is no definitive answer. This appears to be one of those cases. All you can do it ask others what can be tried....
0
 
JohnBusiness Consultant (Owner)Commented:
This appears to be one of those cases. All you can do it ask others what can be tried....

Yes. I keep a list of fixes in One Note for easy access if I need to troubleshoot.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.