[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 109
  • Last Modified:

Exchange 2013, shared mailbox, unable to send due to permissions

I have created a new shared mailbox on my Exchange 2013 server in the building here.  I have given several people FULL access to the mailbox and at least two users SEND AS permissions.

When I opened my Outlook, the shared mailbox shows up just like it should and mail flows into the mailbox.  However, when anyone tries to send as from the mailbox by changing the FROM address, it fails and the message is that "You do not have permission to send the message on behalf of the specified user."

This seems like such a simple and straight forward thing, but clearly I am missing something.  Can anyone assist?

Thanks

Cliff
0
crp0499
Asked:
crp0499
  • 3
1 Solution
 
Edwin HofferTechnical ExpertCommented:
Error: " You do not have permission to send the message on behalf of the specified user"

Hi crp0499,
Yes there are certain workaround you need to do. Sending the message is failed because the "From" field is populated by a distribution list. The distribution list rights are cached in the Information Store. After you give accounts the correct rights, you have to stop and restart the Information Store service.

So follow these steps to grant Send As rights for a distribution list:
1. Click on "Options" located on the "Tool" menu of the "Administrator program"
2. Now click on "Permissions" tab
3. Check on "Show Permissions Page for all objects" check box
4. Now open the "Properties for a distribution list" in the Administrator program
5. Click on Permissions tab
6. You will find a "Microsoft Windows NT account or group" add it.
7. Now change the role to "Send As".
8. Click OK to close properties.
9. Now Stop and restart the Information Store service.

A similar thread is solvd in th Exchange Expert. You can refer to the link below:
https://www.experts-exchange.com/questions/27688753/You-do-not-have-permission-to-send-the-message-on-behalf-of-the-specified-user.html

https://support.microsoft.com/en-us/kb/293773
0
 
crp0499CEOAuthor Commented:
Click on "Options" located on the "Tool" menu of the "Administrator program"

Where is that?  In Outlook or in Exchange?

Whoa...that's an exchange 5.5 article.  This is exchange 2013 and Outlook 2016
0
 
crp0499CEOAuthor Commented:
The fix was to add the account to the users outlook as an additional mailbox.
0
 
crp0499CEOAuthor Commented:
This was the correct fix.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now