How do I fix wireless connecting using 802.1x protocol after Windows 10 Anniversary upgrade?

After upgrading my laptop to Windows 10 Anniversary edition, I can no longer connect wirelessly to my company's network. Windows 10 worked fine, but after the Anniversary edition, I can no longer connect. i can connect hard wired but not wirelessly. At home wireless works just fine. To connect at work I need to have 802.1x checked off. I have an HP Elitebook Revolve 810 G1 with Intel Centrino Advanced-N-6235 wireless adapter. All drivers on the system are up to date. The system bios is also the latest version. Any ideas? I sure appreciate any help you can give me. Thank you
LVL 1
scennimoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
I find the best way is to uninstall (remove) the wireless card in Device Manager, shut down, start up and install the newest driver. This almost always works.

You can also try TCP/IP Reset.

Open cmd.exe with Run as Administrator
Then  netsh int ip reset c:\resetlog.txt
Also, ipconfig /flushdns followed by net stop dnscache followed by net start dnscache
Then restart the computer

I have an Intel 6205 on my Windows 10 Anniversary machine and it works fine.
0
bigeven2002Commented:
What errors are you getting when trying to connect to the company wireless?
0
scennimoAuthor Commented:
Bigeven2002, I have just been using it on a docking station so I am not sure so I have not tried it in over a week. I believe I just get a message that says I cannot connect to this network and to contact the administrator. I will have to double check tomorrow when I get in. If it is different I will post it here.
John, I will try your recommendations and post the results.
Thanks guys for your help. Much appreciated.
0
Redefine Your Security with AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Check out our on-demand webinar to learn more about how AI can help your organization!

bigeven2002Commented:
Ok thanks for the update.  I would be curious to know if the company network uses WPA2 or something older.
0
scennimoAuthor Commented:
bigeven2002 we are using WPA2 - Enterprise
0
scennimoAuthor Commented:
By the way our network consist of Open Enterprise Server by Micro Focus formerly Novell, Zenworks Client. It is not a Microsoft Domain Network. Not sure if this information can help.
0
bigeven2002Commented:
Seeing as wpa2 enterprises uses radius or a pki certificate, do you use either?  If radius, I wonder if the user account got locked out or if pki, the very was removed or invalidated on the win 10 machine.

Can you try logging in as a different user on the win 10 box to see if it can access?  Preferably use a user account that can connect on another machine.
0
Jackie ManCommented:
Try the workaround below.

"Open Network and Sharing Center
Click Set up a new connection or network a. Select Manually connect to a wireless network b. Enter ASI-NET for the Network name. (Please note that this is case-sensitive.)
Click on Change connection settings
Click on the security tab, then Settings to open the Protected EAP Properties window.
Deselect Validate Server Certificate
To the right of Secured password (EAP-MSChap v2), open Configure and deselect the Automatically use my Windows login name and password option (and domain, if any). (Figure 3)
Select OK to close this window, then click on OK to close the Protected EAP Properties window.
Click on OK to close the ASI-NET Wireless Network Properties window, and finally select Close for the Manually connect to a wireless network window option.
Finally, click on the internet access icon and connect to the ASI-NET232 network"

Source: https://www.reddit.com/r/Windows10/comments/4esum3/halfbroken_wifi/
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Danny ChildIT ManagerCommented:
As this is a corporate device, you should be approaching your in-house IT first... Unless you are them, of course!

That update is fairly notorious for breaking WiFi drivers.
Here's a similar post, where they had to revert to a previous version of the driver (NOT the most recent).
http://www.bleepingcomputer.com/forums/t/622763/anniversary-update-broke-my-wifi/ 

HP Support may also have some recommendations here.
0
scennimoAuthor Commented:
Guys, I appreciate all your help with this issue. I have tried all suggestions except Jackie Man. No luck. I will try Jackie Man's suggestion sometime today. I will update results. Thanks again.
0
scennimoAuthor Commented:
Jackie Man, I tried your suggestion and no luck. (EAP-MSChap v2), open Configure and deselect the Automatically use my Windows login name and password optionEAP-MSChap v2), open Configure and deselect the Automatically use my Windows login name and password option) This option was not available when selecting Configure. Window pops up and says that I cannot do this. Back to the drawing board. If anyone has any other ideas, please let me know. by the way, when trying to logon the error says the following, NCLOGINUI 802.1x Authentication failed. An RPC error occurred. Network Login not Attempted. Thanks
0
scennimoAuthor Commented:
Just wanted to post what I found out today. I am not sure how but I got my system to login to our network wireless. We have an app called (OES) Client for Open Enterprise Server for Windows by Micro Focus. This was formerly known as the Novell Client. I logged in local. I right clicked on the app and selected Client Properties and then I just clicked on OK. Rebooted the computer and now I was able to login. I do not know why this corrected anything. We did not change anything. Just clicked OK. We will be looking into this further but to me it is a mystery. We will check out prior clients and see if it is because of this new client. We will also test it on multiple systems with different network adapters. Anyway, I just wanted to let you guys know what I found out. Thanks again for all your help.
0
bigeven2002Commented:
Ok great, glad you got that figured out.  That makes sense as clicking ok in the properties vs cancel will refresh the adapter or client selected.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.