Solved

OSPF Routing Problems

Posted on 2016-09-25
9
64 Views
Last Modified: 2016-10-13
I have a core switch at the main office that has three different connections coming off of it for remote sites.     I have configured OSPF routing to handle the routing between all the sites.   Some of remote sites have a wireless backup connection (10.200.200.XX) and a primary connection (10.10.200.X) via Fiber that the provider configured a L-3 VPN on there side.     If I turn the fiber connection off at the 4 sites all the routing works like a champ and I do not have any problems.   When I turn the fiber connection back on that's when the routing gets messed up.    Example a site that doesn't have a fiber connection, when a users needs to get back to the main office network, that user is leaving on the wireless port then it's jumping over to a site that has a fiber connection and ridding that back to the main office.    It should work like this a user leaves on the wireless port and then should hit the router at the tower site and then ride a microwave link back to the ISP and then a fiber link back to the main office .  

This is a part of the configure from the main office switch/router

interface GigabitEthernet4/47
 description lcf01gw01 --> Wireless MAN
 ip address 10.200.201.245 255.255.255.252
 ip flow ingress
 ip pim dense-mode
 ip ospf network point-to-point
 ip ospf cost 10
 mls netflow sampling
 mls qos trust dscp
 spanning-tree bpduguard disable
 spanning-tree guard root

interface GigabitEthernet9/1
 description Fiber to ISP
 ip address 10.200.201.242 255.255.255.252
 ip flow ingress
 ip pim sparse-dense-mode
 ip ospf network point-to-point
 ip ospf cost 1
 mls netflow sampling
 mls qos trust dscp
!
interface GigabitEthernet9/6
description Fiber InterLinks
ip address 10.10.200.1 255.255.255.252
 ip flow ingress
 ip pim dense-mode
 ip ospf cost 1
 mls netflow sampling
 mls qos trust dscp
 spanning-tree bpduguard disable
 spanning-tree guard root

router ospf 200
 log-adjacency-changes
 redistribute static subnets
 passive-interface default
 no passive-interface GigabitEthernet4/47
 no passive-interface GigabitEthernet9/1
 no passive-interface GigabitEthernet9/6
 network 10.10.200.0 0.0.0.3 area 200
 network 10.200.201.240 0.0.0.3 area 200
 network 10.200.201.244 0.0.0.3 area 200
 network 172.16.251.0 0.0.0.3 area 200
 network 172.16.0.0 0.0.255.255 area 200
 network 0.0.0.0 255.255.255.255 area 200
 maximum-paths 3
!
ip default-gateway 172.16.50.1
ip classless
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.250.2
ip route 0.0.0.0 0.0.0.0 172.16.251.1 10
ip route 10.2.225.0 255.255.255.0 172.16.250.4
ip route 10.2.226.0 255.255.255.0 172.16.250.4
ip route 10.2.240.98 255.255.255.255 172.16.251.1
ip route 192.168.25.0 255.255.255.0 172.16.251.1
ip route 192.168.95.0 255.255.255.0 172.16.251.10


Station Switch with two connections

interface FastEthernet1/0/48
 no switchport
 bandwidth 50
 ip address 10.200.200.70 255.255.255.0
 ip pim sparse-dense-mode
 ip ospf network point-to-multipoint
 ip ospf cost 50
 mls qos trust dscp
!
interface GigabitEthernet1/0/4
 no switchport
 ip address 10.10.200.5 255.255.255.252
 ip pim sparse-dense-mode
 ip ospf cost 1
 mls qos trust dscp

router ospf 200
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet1/0/48
 no passive-interface GigabitEthernet1/0/4
 network 10.10.200.4 0.0.0.3 area 200
 network 0.0.0.0 255.255.255.255 area 200
 maximum-paths 2

I tried to put in ip ospf network (point-to-point or (multi-point)) onto the fiber ports and the network will not come up.  Once I removed the ip ospf network the network comes ups.    

I don't know if the fiber is missed configured or something else is wrong in the configruation of these switches/router
0
Comment
Question by:pozy
  • 4
  • 4
9 Comments
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 41815330
I tried to put in ip ospf network (point-to-point or (multi-point)) onto the fiber ports and the network will not come up. Once I removed the ip ospf network the network comes ups.
This is typical for the case when timers do no mach (network type changes OSPF timers). If network type is not matching on both sides - timers might be different and neighbor relation will not be established.

OSPF neighbor values that must match on both routers:
    Area ID
    Authentication
    Hello and Dead Intervals
    Subnet must match
    Stub Flag
    MTU Size
Otherwise neighbor relation will not form.

One of the following debugs should give you an answer:
# debug ip ospf adj             <---- MTU, area ID and authentication mismatch
# debug ip ospf hello          <---- subnet , timers and stub mismatch,

Also, if this is the main office configuration where is your area 0?
:)
0
 
LVL 13

Expert Comment

by:SIM50
ID: 41816086
At what OSPF state does it stop during the neighbor establishment process? What is the MTU on the interfaces?
0
 

Author Comment

by:pozy
ID: 41816113
Currently I have everything set to area 200.  I do not have an area 0 setup in the network.   I should set the main office to area (0) and the wireless to area 200 and the fiber connections to area 100.?  I just turned debugging on now to see where it stops.
0
 
LVL 26

Expert Comment

by:Predrag Jovic
ID: 41816165
Typically you create area 0 as the first area for your network.
There is no need to create more than a single area until network become too big, however, in the moment you want to create more than one area you must configure area 0 otherwise traffic between areas will not be forwarded if there is no area 0. In other words... you should create backbone area (area 0) as the first area.

Can you, please, draw topology with IP addresses on interfaces that are connecting switches and configuration of OSPF, since according to configuration details that you provided there are no interfaces that are in the same IP address range. If those are all interfaces that are configured no neighbor relationships are possible.
10.10.200.1 255.255.255.252               <- 10.10.200.0 - 3
10.10.200.5 255.255.255.252               <- 10.10.200.4 - 7
are two different ranges....
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:pozy
ID: 41816371
Network Setup
0
 

Author Comment

by:pozy
ID: 41816374
The network runs ospf area 200.  Overall its a very small network and keeping it all in the same area would be great.
0
 
LVL 26

Assisted Solution

by:Predrag Jovic
Predrag Jovic earned 500 total points
ID: 41816608
Not sure what is actually configured there. Subnet masks are not properly marked in topology drawing. And looks too complicated (maybe it is not), the way it is on drawing I am not sure that I understand your topology. But the way you draw it I can't make any conclusions.
Here is summary what is unclear in the drawing:
Topology
And if you use single area it can work as area 200, but it would be way much better to change it to area 0.
0
 

Author Comment

by:pozy
ID: 41816640
The 32 is a typo on my end.. They are a /30 The green links are connected by the fiber provided as a L-3 VPN

The main office has a point to point fiber link to the ISP.   From ISP site there is a micro-wave link to a tower site that has point to point links.  From the tower site that's where the muti-site remote radio's come into play and they are on the 10.200.200.X/24 network.  Also coming from the main office to the tower site is a back link of 10mb in case something happens to the ISP.   The three main sites have a fiber connection that the provider setup a L-3 VPN.  I hope this clears up some of the confusion. Thank you
0
 
LVL 26

Accepted Solution

by:
Predrag Jovic earned 500 total points
ID: 41816708
One of the problems can be that VPN is not supporting multicast (maybe you need to configure GRE too). Check are neighbors established over VPN, if neighbor relationship is established multicast is supported.
#show ip ospf neighbor

Other potential problem problem is that maybe you do not advertise default route into OSPF (default-information originate). You need to have 2 default routes to point to your ASBRs and your primary one should be configured with lower cost than backup route.

Check route database (are all networks in database + default routes). - Primary default route should be type E1with low cost, secondary default route should be E1 type with high cost or can be type E2.
# show ip ospf database
# show ip route
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now