Solved

Failed to create connection config

Posted on 2016-09-26
17
33 Views
Last Modified: 2016-10-05
Hello Experts,

While browsing the Website I found the following error.

I enabled the Directory Browsing feature in IIS manager.

Failed to Create Connection Config
Help is needed.

Thanks in an advance,
D Patel
0
Comment
Question by:D Patel
  • 9
  • 8
17 Comments
 
LVL 26

Expert Comment

by:Dan McFadden
ID: 41817386
When you disable directory browsing, do the error occur?

Is there a database involved in this web application?

Dan
0
 
LVL 5

Author Comment

by:D Patel
ID: 41817391
Then the error is different.

MS SQL database is involved in this
0
 
LVL 26

Expert Comment

by:Dan McFadden
ID: 41817398
Can you post the error you mentioned above?

Dan
0
 
LVL 5

Author Comment

by:D Patel
ID: 41817405
Before DIrectory Browsing Enable
0
 
LVL 26

Expert Comment

by:Dan McFadden
ID: 41817434
What is the web page that the site should load by default?  The error above states that there is no default page found.

Typical names are (in no specific order):
- index.html
- index.htm
- index.aspx
- default.html
- default.htm
- default.asp
- default.aspx
- home.html
- home.aspx

The error you posted above is easily resolved by going into the "Default Document" feature and setting up the preferred web page to load when no specific web page is entered after the trailing slash in a URL.

Dan
0
 
LVL 5

Author Comment

by:D Patel
ID: 41817553
I have set the default document. Then also it throws the error "Failed to Create Connection Config".

THanks for the help.

Regards,
D Patel
0
 
LVL 26

Expert Comment

by:Dan McFadden
ID: 41817590
Can you post your web.config?  

Dan
0
 
LVL 5

Author Comment

by:D Patel
ID: 41817596
I've attached the said file herewith.
Web.config
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 26

Expert Comment

by:Dan McFadden
ID: 41817650
The web.config is quiet generic.  Can you describe what the application does?  Is this a web site or a wcf web service?

Are you the developer?

As for the web.config.  I wouldn't recommend using the 'runAllManagedModulesForAllRequests="true"' on the modules element.  It can cause performance issues.  What it is saying to do is to enable all managed modules for all inbound requests.

Link:  http://www.britishdeveloper.co.uk/2010/06/dont-use-modules-runallmanagedmodulesfo.html

Have you read thru the following article?

Link:  https://msdn.microsoft.com/library/ff426912(v=vs.91).aspx

Dan
0
 
LVL 5

Author Comment

by:D Patel
ID: 41817674
Thanks for your interest.

This is the Workbench application which deployed using the silverlight enabled form within Infor ERP.

The application successfully Uploaded and Deployed on the intranet site, The only problem is to run the deployed application.

I am the developer in Infor ERP modules (priorly it was BAAN).

Thanks,
D Patel
0
 
LVL 26

Expert Comment

by:Dan McFadden
ID: 41817695
Have all of the dependencies been installed on the destination server?

Dan
0
 
LVL 5

Author Comment

by:D Patel
ID: 41817705
Yes
0
 
LVL 26

Expert Comment

by:Dan McFadden
ID: 41817716
Then I suggest that you enable Failed Request Tracking so you can log, in more detail, the errors your app is throwing.

Also, I would look thru the Application Event Log for errors related to your application.  If you find any errors in the Application Event Log, can you post them, with full details?

Dan
0
 
LVL 5

Author Comment

by:D Patel
ID: 41821098
Hi Dan,

Please find the attached Application Event Log

Regards,
D Patel
EventLog.txt
0
 
LVL 26

Accepted Solution

by:
Dan McFadden earned 500 total points
ID: 41821575
It would appears that the error being thrown is line 225 in BasePage.cs which is called when making an http request to "https://localhost:443/qmptc8350m000_B61U_a_stnd/InspectionOrderGraphicalEasyEntry.aspx"

 Can you post what the code is doing?

Also, I noticed that the application is calling in on the IPv6 localhost address (::1).  This tells me that the Address bindings on the site are set to "All Unassigned" which means that the site can respond on any and all IP address set up on the server.

I suggest that you use the actual IPv4 address in the binding for the site.

Dan
0
 
LVL 5

Author Comment

by:D Patel
ID: 41821593
Hi Dan,

Thanks for suggestion.

Actually I do not have the code. Its compiled Object. and it's rights would be with software developer.

Thanking you again,
D Patel
0
 
LVL 5

Author Closing Comment

by:D Patel
ID: 41829482
Thanks for your help...
0

Featured Post

Free Trending Threat Insights Every Day

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

I annotated my article on ransomware somewhat extensively, but I keep adding new references and wanted to put a link to the reference library.  Despite all the reference tools I have on hand, it was not easy to find a way to do this easily. I finall…
#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now