• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 72
  • Last Modified:

Failed to create connection config

Hello Experts,

While browsing the Website I found the following error.

I enabled the Directory Browsing feature in IIS manager.

Failed to Create Connection Config
Help is needed.

Thanks in an advance,
D Patel
0
D Patel
Asked:
D Patel
  • 9
  • 8
1 Solution
 
Dan McFaddenSystems EngineerCommented:
When you disable directory browsing, do the error occur?

Is there a database involved in this web application?

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
Then the error is different.

MS SQL database is involved in this
0
 
Dan McFaddenSystems EngineerCommented:
Can you post the error you mentioned above?

Dan
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
D PatelD Patel, Software EngineerAuthor Commented:
Before DIrectory Browsing Enable
0
 
Dan McFaddenSystems EngineerCommented:
What is the web page that the site should load by default?  The error above states that there is no default page found.

Typical names are (in no specific order):
- index.html
- index.htm
- index.aspx
- default.html
- default.htm
- default.asp
- default.aspx
- home.html
- home.aspx

The error you posted above is easily resolved by going into the "Default Document" feature and setting up the preferred web page to load when no specific web page is entered after the trailing slash in a URL.

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
I have set the default document. Then also it throws the error "Failed to Create Connection Config".

THanks for the help.

Regards,
D Patel
0
 
Dan McFaddenSystems EngineerCommented:
Can you post your web.config?  

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
I've attached the said file herewith.
Web.config
0
 
Dan McFaddenSystems EngineerCommented:
The web.config is quiet generic.  Can you describe what the application does?  Is this a web site or a wcf web service?

Are you the developer?

As for the web.config.  I wouldn't recommend using the 'runAllManagedModulesForAllRequests="true"' on the modules element.  It can cause performance issues.  What it is saying to do is to enable all managed modules for all inbound requests.

Link:  http://www.britishdeveloper.co.uk/2010/06/dont-use-modules-runallmanagedmodulesfo.html

Have you read thru the following article?

Link:  https://msdn.microsoft.com/library/ff426912(v=vs.91).aspx

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
Thanks for your interest.

This is the Workbench application which deployed using the silverlight enabled form within Infor ERP.

The application successfully Uploaded and Deployed on the intranet site, The only problem is to run the deployed application.

I am the developer in Infor ERP modules (priorly it was BAAN).

Thanks,
D Patel
0
 
Dan McFaddenSystems EngineerCommented:
Have all of the dependencies been installed on the destination server?

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
Yes
0
 
Dan McFaddenSystems EngineerCommented:
Then I suggest that you enable Failed Request Tracking so you can log, in more detail, the errors your app is throwing.

Also, I would look thru the Application Event Log for errors related to your application.  If you find any errors in the Application Event Log, can you post them, with full details?

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
Hi Dan,

Please find the attached Application Event Log

Regards,
D Patel
EventLog.txt
0
 
Dan McFaddenSystems EngineerCommented:
It would appears that the error being thrown is line 225 in BasePage.cs which is called when making an http request to "https://localhost:443/qmptc8350m000_B61U_a_stnd/InspectionOrderGraphicalEasyEntry.aspx"

 Can you post what the code is doing?

Also, I noticed that the application is calling in on the IPv6 localhost address (::1).  This tells me that the Address bindings on the site are set to "All Unassigned" which means that the site can respond on any and all IP address set up on the server.

I suggest that you use the actual IPv4 address in the binding for the site.

Dan
0
 
D PatelD Patel, Software EngineerAuthor Commented:
Hi Dan,

Thanks for suggestion.

Actually I do not have the code. Its compiled Object. and it's rights would be with software developer.

Thanking you again,
D Patel
0
 
D PatelD Patel, Software EngineerAuthor Commented:
Thanks for your help...
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 9
  • 8
Tackle projects and never again get stuck behind a technical roadblock.
Join Now