Lost Ability To Control Restarts After Win 10 Updates

As far as I can remember, I used to be able to set Windows 10 to "Ask" me to restart Windows (after an auto-update).
That ability seems to be gone following an update to Ver 1607 - Build 14393.187

Am I correct?
Is there a workaround or have I ceded even more control to Microsoft?
LVL 24
EirmanChief Operations ManagerAsked:
Who is Participating?
 
McKnifeCommented:
I have both 1607 and 1511 in front of me. 1511 offered a choice "automatic" or "notify me to schedule a restart". The latter option is not gone yet, but needs to be configured through what you see.
 "Custom Restart Time" screen is only greyed out when there is no restart scheduled at the moment.
0
 
JohnBusiness Consultant (Owner)Commented:
I think that not a lot has changed.

Go to Settings, Update, Restart Options and check the option for Restart time. You may need to have active updates pending to set this. You can also set available hours.

The last Roll Up (After the Anniversary Update) asked me on both machines when I wished to restart.
0
 
McKnifeCommented:
1607 has added more options. Look at the update options / restart options. Active hours is new.
There is no new "more aggressive" restart behavior in 1607.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

 
EirmanChief Operations ManagerAuthor Commented:
I saw those restart options McKnife.
I had tried active hours but the "Custom Restart Time" screen is greyed out.
I definitely have fewer options.
0
 
JohnBusiness Consultant (Owner)Commented:
Do you have updates pending? That may be why it is greyed out.
0
 
JohnBusiness Consultant (Owner)Commented:
"When a restart is scheduled, this option is available to temporarily override active hours and schedule a custom time to finish installing the current update(s). Make sure your device is plugged in at the scheduled time."

You need to set this when updates are pending
0
 
EirmanChief Operations ManagerAuthor Commented:
notify me to schedule a restart
Yes McKnife - That's the option I miss now (I like to be in control)

"Custom Restart Time" screen is only greyed out when there is no restart scheduled at the moment
That computes! Thanks.
0
 
JohnBusiness Consultant (Owner)Commented:
Yes, as we have both said, you need updates to be pending. No updates will leave the option greyed out.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.