A description for this result is not available because of this site's robots.txt

Hi, When I search Google with a new site I put up, rockypointfishingservices.com, I get this message: A description for this result is not available because of this site's robots.txt

But on Friday I added a robots.txt file to the root. http://rockypointfishingservices.com/robots.txt

What can I do? Is it just that Google hasn't re-browsed me? Thanks for any advice.
Melody ScottAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Terry WoodsIT GuruCommented:
Your robots.txt file currently contains:
User-Agent: *
Disallow: /wp-content/plugins/
Disallow: /readme.html

Open in new window


You don't want to block your plugins folder from robots. Details explained here:
https://yoast.com/wordpress-robots-txt-example/

It might be easiest just to install the Yoast plugin; the author has clearly put some thought into it, and it's free.
Melody ScottAuthor Commented:
Thanks!
Melody ScottAuthor Commented:
I've already got an SEO plugin, I really don't want to add plugins if I can avoid it. I've made the robots.txt file simple:

User-agent: *
Disallow:

If anyone else can chime in, I'd appreciate another point of view as well. Thanks!
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

Terry WoodsIT GuruCommented:
In the Google Webmasters tools, there's a "robots.txt Tester" tool and also a tool for asking Google to load the site as a robot "Fetch as Google". Both these are under the Crawl section of the tools.

Have a play with those, in case Google needs to be told that the robots.txt has changed, or in case it gives any other clues as to what's happening.
Melody ScottAuthor Commented:
Thanks, will try that!!
Melody ScottAuthor Commented:
OK, that says this, does it mean that message will go away soon?

capture
Terry WoodsIT GuruCommented:
Maybe. You might try using "Fetch as Google" to fetch the site too, as once fetched I think you get an option Submit to Index, which may help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Melody ScottAuthor Commented:
Interesting. At first I got this "redirected" announcement, then I submitted and got this. The domain is registered and hosted at Bluehost.  It's a wordpress installation. What might I have done wrong, any idea?

screenshot v2
Melody ScottAuthor Commented:
Um... never mind that last. It's because I selected http://www.... as my preferred domain.
Melody ScottAuthor Commented:
I did it again on the www. version. It said Status: partial.

I read this, which seems to indicate again a problem with the robots.txt file.
https://productforums.google.com/forum/#!topic/webmasters/3X0X8c3c39U
Melody ScottAuthor Commented:
Finally got it, thanks for your help!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.