Solved

Windows 10 Updates Installation - Automatic and can't change?

Posted on 2016-09-27
20
55 Views
Last Modified: 2016-09-30
Here is the email from my customer: "Yesterday afternoon, I was entering an invoice in quick books and looked away for a minute.  When I turned back to my screen it was blue and an update was happening.  Any way to set those updates to happen over night?"

I look at my update settings and what I see is: "Available Updates will be downloaded and installed automatically". This doesn't look like it can be changed. Can it?
0
Comment
Question by:LockDown32
  • 9
  • 6
  • 4
  • +1
20 Comments
 
LVL 90

Assisted Solution

by:John Hurst
John Hurst earned 167 total points
ID: 41817774
For an individual Windows 10 License - Pro or Home - the options have changed and Updates continue to be automatic.

Go to Settings, Update and change the Active Hours so that restarts cannot happen in Active Hours.

That is the way to manage Updates.
0
 
LVL 15

Author Comment

by:LockDown32
ID: 41817789
You missed the question John. Active Hours you can change but that is when the computer restarts. The question was about changing the installation time.
0
 
LVL 1

Accepted Solution

by:
PeteVfi earned 167 total points
ID: 41817790
OK, yes they can be prevented somehow, more details in here

-> https://www.cnet.com/how-to/stop-windows-10-from-automatically-updating-your-pc/

but, still I recommend just the Active Hours or Reboot Timing settings.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41817799
Well, I think most of us know now that initial update installation will happen whenever. That cannot be changed. Only the restart time can be changed. I did not miss the question - I was responding with actions that can be taken.

The blue screen your client is talking about is the post installation and that MUST be done and should never be stopped. Setting the restart time fixes this to avoid improper downtime.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41817809
email from my customer: "Yesterday afternoon, I was entering an invoice in quick books  

I have such customers myself. I would not lead them into the complications suggested by the CNET article. Even that article says the correct way is to set restart time as I outlined above.
0
 
LVL 15

Author Comment

by:LockDown32
ID: 41817842
I love this. The question had nothing to do with Active Hours. Nothing. I am well aware what the "Active Hours" represents and how to change it. That was not the question. Let me rephrase the question: "I look at my update settings and what I see is: "Available Updates will be downloaded and installed automatically. This doesn't look like it can be changed. Can it?"

Wait. That wasn't rephrased. That was copied and pasted. Sorry my bad. So why do people get off topic so easily? Why do people want to answer questions that aren't asked? Wow.

So the short answer is "that option cannot be changed". Thank you.
0
 
LVL 53

Assisted Solution

by:McKnife
McKnife earned 166 total points
ID: 41817846
LD, Anyone getting angry about settings, I would advise to simply disable the service "windows update". Enable and start it via batch and trigger an update search either manually or as well scripted through powershell. Only way to be 100% in charge.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41817853
OK, I am not off topic.

Step 1. Windows 10 will start downloading and updating on its own so long as there is an active network connection. This cannot be readily changed in Windows 10 and was always like this.

Step 2. Once updating has completed, it must restart (true with every OS since Windows 3.1). This CAN be controlled. That is what Active Hours are about. The language changed

Step 3.  Post update blue screen "Do not turn off" . This has been true since Vista
0
 
LVL 15

Author Comment

by:LockDown32
ID: 41817871
Her objection was that the updates started automatically installing which generated the blue screen and interrupted what she was doing. I think she lost some work. Sure looks like a "oops" to me. Windows 7 automatically installed but did so in the background without interrupting the user.

Maybe we should just start calling Windows 10, Vista II? Stellar job Microsoft. Stellar.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41817893
Whatever you wish to call it.

If you allow Windows 7 to restart, it will blue screen and say "Do not turn off" exactly the same way. We have all seen this many times.

What happen to your client is that active hours were not set or she was operating outside of active hours. Yes she probably lost some work.

So: Lesson learned and set the options properly.
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 1

Expert Comment

by:PeteVfi
ID: 41817963
OK ... If the John's or CNET's hints maybe are not enough or complicated or acceptable or whatever, you could still do according to McKnife's advices above, which are all fully acceptable and right, and let the updates taken in own hands, and then maybe probably forgotten forever leading in a mess during the times ... as seen also already ages on user-responsible backups ...
0
 
LVL 15

Author Comment

by:LockDown32
ID: 41817973
Spoke with her a little further and looked at her computer. Her Active Hours were set to the default. 8am to 5pm. This reboot happened at 1pm. The options are set properly.

"So: Lesson learned and set the options properly."

So what lesson did we learn John?
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41817980
It is entirely possible that the update skipped a day waiting (I have seen that happen - machine turned off, suspended or some other event) and then said "cannot wait longer - here goes!"

Many times I have seen a Windows 10 Notification Icon saying Restart Required. I pay attention to these, but some do not, dismiss the icon and get on with there work.

What lesson have I learned?  To pay greater attention.
0
 
LVL 15

Author Comment

by:LockDown32
ID: 41818003
The computer was on 24/7. Not allowed to go in to hibernation so...... If you see a Restart Required notification that lasts longer then 24 hours then you need to pay attention to your Active Hours settings. "Can't wait any longer - here goes"????

Maybe the lesson is that Windows 10 doesn't quite work as advertised.......
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41818015
I am not sure why. People dismiss messages some times. In more than a year with Windows 10 including important work with customers, Windows 10 has never restarted at the wrong time. It has always asked "Restart required" and I can always defer to an appropriate moment.

It is possible she has an error in setup. I hope she is not using Windows 10 Home for business as that has fewer options that Windows 10 Pro.
0
 
LVL 1

Expert Comment

by:PeteVfi
ID: 41818020
OK, well, thanks giving me attention to this topic, will now asap check these things more thoroughly with some critical clients ...
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41822814
So there was a big Windows 10 Update out tonight Version 1607 Build 14393.222  (KB3194496)

When the machine was done updating, it threw up the screen below AND it popped up a notification to restart. 2 notifications in total. I restarted and it did the Blue Screen "Updating - do NOT turn off"

Windows-10-Update-Restart-
So it works exactly as I said it did above here. I think perhaps your customer ignored a restart ("I am too busy to restart") and then Windows 10 ran out of wait time and restarted.
0
 
LVL 15

Author Comment

by:LockDown32
ID: 41823197
Yes. I am finding that. THe Windows 10 updates are coming out fast and hard. The bug fixes are many. It is like trying to hit a moving target.
0
 
LVL 90

Expert Comment

by:John Hurst
ID: 41823432
It is like trying to hit a moving target.   <-- I keep up fairly well so not too many issues, but yes, others have more issues.
0
 
LVL 1

Expert Comment

by:PeteVfi
ID: 41823442
OK, thanks for the rating!

P.S. Just noted, that the Active Hours can be just 12hrs max., would like to set it between 8-22 -> 8-20 OK ...
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
Widnows 10 Button doesn't work or Cortana 13 57
How to Add Subtitles to Video 3 25
Network Connection 5 34
What is this Task? 4 34
If you use NetMotion Mobility on your PC and plan to upgrade to Windows 10, it may not work unless you take these steps.
OfficeMate Freezes on login or does not load after login credentials are input.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now