Citrix printing with wrong paper type - asking for manual bypass

Posted on 2016-09-27
Medium Priority
Last Modified: 2016-11-05
We are running a XenApp 6.5 farm on Server 2012 R2, our print server is running on Server 2008 R2.

We are experiencing an issue where when some of our customers are using applications published in Citrix they will be prompted to load paper to the bypass or manual trays when they print.

In some cases we have discovered that when going into the preferences, just before clicking OK to print, the paper has been set to Color, in another case the paper size was set to 8.5 x 11.09 (we know because the printer was asking for this paper size), but lately there has been nothing wrong when we check the printer preferences.  We have confirmed that the local settings on the PC itself are configured right, and we do not have the issue when printing locally from windows only through Citrix.

To add further confusion to the matter, the issue seems to be user specific - another staff member, using the same printer off the same print server and using the same application will be fine.

We have tried removing the registry key HKCU\Software\Citrix\PrinterProperties - this has worked in a very limited number of cases but in the majority it has not.  We have also tried removing the Citrix profile from the servers.

Other suggestions?
Question by:Roger Pray
LVL 81

Accepted Solution

arnold earned 672 total points
ID: 41819135
The issue might be related to a document produced elsewhere and provided to your people. The document maintains the margins document dimensions.
With that said a document created locally within your environment will not have this issue, but if I created the document and forwarded to you, my printer and settings might differ.  I believe if there is a discrepancy, when printing, there often is a warning that the formatting might differ I.e. Margins to small for the printer, etc.

Try replicating. Create a document with legal or A4 dimensions. Forward it to another user to confirm your document settings are preserved when they try to print, your document settings will be sent to the printer.
LVL 15

Assisted Solution

joharder earned 664 total points
ID: 41819779
Being that this only happens to some users, this is indicative of something stuck within the user profile.  When you say that you removed the Citrix profile from the servers, can you explain exactly what you did?  

Deleting the contents of HKCU\Software\Citrix\PrinterProperties probably wouldn't resolve your issue.  Instead, on the server where the user is running the session, find the user profile under HKUsers\[SID].  Click Volatile Environment to be sure you've got the right user.  Then go to HKUsers\[SID]\Printers.  There are three items here: Connections, DevModePerUser, and DevModes2.  Delete the contents (not the headers!) of each of those.  Then ask the user to log off gracefully and log in fresh.  If you're using roaming profiles, I'll bet this fixes your issue!

But wait ... are you using roaming profiles or a third-party profile product?  Or are you using local profiles?  If you haven't configured anything, you're defaulting to local profiles, which would cause intermittent issues.  Local profiles cause a user profile to be saved onto each server and are not a good solution because changes saved in one session (on one server) aren't saved centrally and thus don't impact the local profile saved on another server.

Assisted Solution

by:Darth Vader
Darth Vader earned 664 total points
ID: 41827667
In case of roaming profiles also please check the citrix policies for universal print driver usage. In case of specific printer drivers like "Ricoh" (known issues) add the driver to the server the session is running and add it via citrix policy as well.
LVL 39

Expert Comment

ID: 41875248
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

-- arnold (https:#a41819135)
-- joharder (https:#a41819779)
-- Darth Vader (https:#a41827667)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

Experts-Exchange Cleanup Volunteer

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

#Citrix #XenApp #Citrix Scout #Citrix Insight Services #Microsoft VMMAP #Microsoft ADEXPLORE #Microsoft RAMMAP #Microsoft TCPVIEW #Microsoft AUTORUNS #Microsoft PROCESS EXPLORER #Microsoft PROCESS MONITOR
When you try to share a printer , you may receive one of the following error messages. Error message when you use the Add Printer Wizard to share a printer: Windows could not share your printer. Operation could not be completed (Error 0x000006…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…
Suggested Courses

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question