Office 365 Rooms showing "Busy" on newly created appointments

When a user creates an appointment and chooses a room as a resource, the room calendar is only showing the appointments as "Busy". When clicking on the appointment, it says the user doesn't have permission and asks if they'd like to request permission.

How do we get the appointment information to show on the calendar and give everyone "Reviewer" rights?
HELFITAsked:
Who is Participating?
 
Todd NelsonConnect With a Mentor Systems EngineerCommented:
By default the permissions for a newly created room mailbox calendar are "Default {AvailabilityOnly}" and "Anonymous {None}".  Therefore anyone who attempts to see the contents of the meeting or calendar items will only see busy and not be able to see the details of the item.

There are a couple of ways to achieve what you want.  By setting booking delegates or setting mailbox delegates through the EAC or connecting to Exchange Online via PowerShell; or setting permissions on the calendars by connecting to Exchange Online via PowerShell.

If you need to modify the existing calendar permissions for the Default user, you will use a command similar to this...

Set-MailboxFolderPermission "Room1:\calendar" -User Default -AccessRights LimitedDetails

Open in new window


If you need to add permissions for a user that did not previously have permissions, you will use a command similar to this...

Add-MailboxFolderPermission "Room1:\calendar" -User JSmith -AccessRights Reviewer

Open in new window


Take a look at these references...

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.