Remote Assistance on Windows 10 will not prompt user for permission when assistance is offered.

I am trying to allow some of our administrative staff to view the screens of employees during training sessions. I would like to use Remote Assistance since it already comes with Win10 Pro. I have already added the Group Policies to open the necessary firewall ports and allow members of a certain group to offer assistance. I also set the Group Policy to "Allow UIAccess applications to prompt for elevation without using the secure desktop". I created a shortcut on the offerer's desktops that opens the Remote Assistance application with the /offerra parameter. I have tested the setup with from my computer, with my credentials, and everything worked fine. I have verified that the GPOs have been pushed out to both the offerer and recipient pcs. I have verified that all of the staff that should be able to offer assistance are in the group listed in the GPO.

The problem is that some of the staff will try to offer assistance, but the prompt to accept assistance never shows up on the recipient's computer. I can see that the Windows Remote Assistance process starts running if I open the task manager, but the recipient cannot accept the assistance offer because they are never prompted. Other users can offer assistance to the same recipient on the same computer, and the prompt shows up and everything works fine.
itsupportdmgAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
itsupportdmgConnect With a Mentor Author Commented:
I had some of the users that where having trouble log into different computers and they where able to use remote assistance just fine. That lead me to believe that the issue I was having was with the computer configuration. After a couple of sessions comparing computer configurations, it turns out that Windows Remote Assistance does not play well with FIPS compliant algorithms for encryption. I was then able to roll out a GPO that turned off FIPS by going to Computer Configuration -> Policies -> Windows Settings -> Local Policies/Security Options -> System Cryptography -> System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing" and disabling the setting.
0
 
McKnifeCommented:
I have no idea as to why, but I could offer a different concept for MS RA. In my setup, users click a shortcut and at the same time call helpdesk. A helpdesk supporter clicks on his link and the help request is accepted and the connection established. If you are interested, I could offer details.
0
 
McKnifeCommented:
Interesting. We use MSRA on every cient we have and never had to adjust that FIPS policy. Well, good you found it.
0
 
itsupportdmgAuthor Commented:
It worked and no other offered solutions did.
0
All Courses

From novice to tech pro — start learning today.