Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Hosts file update (Windows 10) - pinging OK but browser still loading old website

Posted on 2016-09-28
9
Medium Priority
?
104 Views
Last Modified: 2016-10-09
I have updated my hosts file to manually redirect website.com to go to a specific IP address. I flushed DNS and pinged website.com and it is resolving the correct IP. However, when I open a browser and go to the site, it is loading the old website (Wrong / Old IP Address).

I have tried clearing all the browser history, and running in private mode. Browsers I have tested with are Firefox, IE, and Chrome.

Any ideas why the browsers will not go to the IP address loaded in the HOSTS file.

Thanks,
Dan
0
Comment
Question by:filtrationproducts
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
9 Comments
 
LVL 1

Author Comment

by:filtrationproducts
ID: 41820330
I used IPvFoo to figure out that initially when I connect it is using the correct IP, however when I click any link from within the initial page it is reverting to the old IP.
0
 
LVL 1

Assisted Solution

by:stormsurge
stormsurge earned 2000 total points
ID: 41820450
0
 
LVL 1

Author Comment

by:filtrationproducts
ID: 41820465
Yes, and it pings fine. I did a little more digging and discovered that my browsers are setup to ping the real world to resolve IP addresses. So every time I clear DNS, the browser pings the real world to resolve the IP address I do not want to use. I managed to work around this by using the direct link provided by my web hosting company to access the site.

However, if there is a way to disable this feature in any known browser it would be great to know so I dont have to type in the remaining part of the address manually to test sub pages.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 1

Expert Comment

by:stormsurge
ID: 41820507
Did you try unchecking number 1

Google Chrome privacy settings
  1. Use a web service to help resolve navigation errors. ...
  2. Use a prediction service to help complete searches and URLs typed in the address bar. ...
  3. Predict network actions to improve page load performance. ...
  4. Enable phishing and malware protection. ...
  5. Use a web service to help resolve spelling errors.
0
 
LVL 1

Author Comment

by:filtrationproducts
ID: 41820639
I did, followed by clearing DNS in Windows as well as in Chrome. Still resolved the wrong IP in Chrome.
0
 
LVL 27

Expert Comment

by:DrDave242
ID: 41823727
I used IPvFoo to figure out that initially when I connect it is using the correct IP, however when I click any link from within the initial page it is reverting to the old IP.
Any chance the URL in those links could be different from what you've added to the hosts file (e.g., you created an entry for website.com, but the links refer to www.website.com or something of that sort)? I'm asking because the behavior you describe simply shouldn't happen. The hosts file adds entries to that machine's DNS resolver cache, which is checked before queries are ever sent to a DNS server.
0
 
LVL 1

Assisted Solution

by:filtrationproducts
filtrationproducts earned 0 total points
ID: 41823763
I don't believe so. However I did find a solution. The browser Opera does not have its own DNS built into it. I have been able to redirect the IP in the hosts file and use Opera without any problems.
0
 
LVL 1

Accepted Solution

by:
filtrationproducts earned 0 total points
ID: 41827782
An update on this - eventually Opera started pointing to the IP on the internet as opposed to the hosts file. I decided to change my DNS to the nameservers where the website files were being hosted. Since the host believed they were hosting the actual domain name, it then worked properly.
0
 
LVL 1

Author Closing Comment

by:filtrationproducts
ID: 41835719
Most reliable solution is to point your DNS to the hosting site. Changing hosts and using browsers were pretty unreliable.
0

Featured Post

Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In threads here at EE, each comment has a unique Identifier (ID). It is easy to get the full path for an ID via the right-click context menu. However, we often want to post a short link within a thread rather than the full link. This article shows a…
Optimized for private cloud infrastructures and datacenters, Nano Server is minimalistic, yet super-efficient, OS for services such as Hyper-V and Hyper-V cluster. Learn how you can easily deploy Nano Server and unlock its power!
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question