• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 78
  • Last Modified:

Excel file are not locked properly

Hi

We are currently experiencing an intermittent issue on our network.

We have a file server (Windows 2012 R2) at our datacenter with several shared folders. It has "Application Server" and "File and Storage service" roles installed.

A VPN is created between location A and the datacenter. Both routers are Sonicwalls (NSA240 and TZ600 respectively)

At location A, user A and B both have a network drive pointing to the same shared folder containing several Excel files.

Most of the times, user A access an Excel file, and when user B tries to open the file, he gets blocked because A is already editing the file. Which is the expected behaviour.

But sometimes, user A access the file, works in it, and meanwhile user B acces the same file, doesn't get any "already in use" warning, works in it, save the file. Then when A tries to save his changes, it says the file is locked by "another user".
User A was the first to open the file.

As a workaround for now, I've asked my users to save their file as soon as it's opened. I was never able to reproduce the problem that way.

Thanks in advance for all your help
0
deewave
Asked:
deewave
  • 4
  • 2
1 Solution
 
J SpoorTMECommented:
single file server or dfs?
0
 
deewaveAuthor Commented:
single
0
 
J SpoorTMECommented:
excel often opens file in a read only mode, only when clicking edit will it lock
0
What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

 
deewaveAuthor Commented:
When I go RDC on the server, and opens the file, it works perfectly. I can save it as expected.

If I open the file from my pc, using the Network Drive, I get an error while trying to save it (currently in use by "another user")

I went on the SonicWall at the datacenter, and disabled the Anti-Virus. Now everything works fine.

I will place a call at SonicWall
0
 
deewaveAuthor Commented:
SonicWall suggest to exclude to server's IP on GAV

From the case description, I understand you have issue with GAV.

If I am right, you can exclude the IP for the server on GAV.

Please follow the below KB article for the same.

https://support.software.dell.com/kb/sw11728

I am available from 9 AM to 6 PM EST to work on this.


It does work, but I'd want to understand and correct the problem, instead of this workaround.
0
 
deewaveAuthor Commented:
none of the proposed solutions worked
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now