Solved

Full Mailbox Access

Posted on 2016-09-29
12
48 Views
Last Modified: 2016-10-16
We have an Exchange coexistence scenario between Exchange 2010/2016.  I'm having an issue since migrating users from Exchange 2010 to Exchange 2016.  Specific users have full mailbox access to all mailboxes in the environment.  These users are also members of the organizational management group.  There are no issues when the mailboxes that is access is on 2010.  As soon as the mailbox is migrated to 2016 it can no longer be accessed by these users.  If the user is not a member of organizational management there is no issue.  I understand the best practices and the security implication of this configuration but unfortunately this is the setup that is forced upon me.  From what I can tell is fullaccess is denied at the 2016 database levels by default. The following command is run to grant full mailbox access on all 2016 databases: Get-mailboxdatases|add-adpermission -user username -accessrights genericall.  The right exists just access is still not granted.  Somewhere an inherited right is propagating from the database is my assumption.
0
Comment
Question by:georgedschneider
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
12 Comments
 
LVL 16

Expert Comment

by:Ivan
ID: 41822511
Hi,

try this command:
Get-Mailbox | Add-MailboxPermission -User <username> -AccessRights FullAccess -InheritanceType All -AutoMapping $false

That should give full access to all mailboxes, for user <username>

Regards,
Ivan.
0
 
LVL 15

Expert Comment

by:Todd Nelson
ID: 41822557
You can also look at setting up an admin role for those that need access to all mailboxes.

  • Exchange 2016 EAC > Permissions > Admin Roles
  • Create new Role Group
  • Add "ApplicationImpersonation" and "Mailbox Import Export" roles
  • Add Members that need access to each mailbox

Hope that helps.
2
 

Author Comment

by:georgedschneider
ID: 41823791
My thought was the inherited deny for receive-as at the organizational level.  There is no issue on the 2010 mailboxes just the 2016.  So what I'm trying to figuring out what is occurring in 2016 differently and what I need to do at the database or org level to resolve.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 15

Expert Comment

by:Todd Nelson
ID: 41823805
Did you attempt the suggestion that Ivan (or I) provided?
0
 

Author Comment

by:georgedschneider
ID: 41823835
Ivan's suggestion works as well as direct assignment to any mailbox works as well.  The issue is I need it to be at the database level like 2010 is so when new users are added the specified individuals have full access without having to run this command.  Its the implicit deny for organizational management causing the issue since the user are also a member of this group as well.
0
 

Author Comment

by:georgedschneider
ID: 41823842
Wouldn't creating a separate rolegroup have no effect since the users are members of organizationmanagement?
0
 
LVL 15

Expert Comment

by:Todd Nelson
ID: 41824178
Did you try the role group is suggested?

You are aware that there are roles that are not in the org mgmt role group?  Namely, the ones I stated.
0
 

Author Comment

by:georgedschneider
ID: 41824199
Same result when adding them to a new role group.
0
 

Accepted Solution

by:
georgedschneider earned 0 total points
ID: 41828441
I removed the deny for receive as  for organization management which which set at the Microsoft Exchange level using adsiedit.  This allowed us the ability to set full access at the database level using Get-mailboxdatases|add-adpermission -user username -accessrights genericall.  This prevent the inherited implict deny from being inherited.
0
 
LVL 15

Expert Comment

by:Todd Nelson
ID: 41828462
Definitely not a permission setting that should have been set outside of Exchange originally, IMO.

Personally, I do my best to discourage any full access to all mailboxes at the org or DB level because it is a bad practice as it opens admins up to possible auditing concerns and issues.

http://exchangeserverpro.com/exchange-best-practices-administrator-access-to-user-mailboxes/
0
 

Author Comment

by:georgedschneider
ID: 41838829
I agree with you that under normal operating conditions this is best practice and what I'd rather have in place.
0
 

Author Closing Comment

by:georgedschneider
ID: 41845521
This provided the resolution to my issue
0

Featured Post

Free Webinar: AWS Backup & DR

Join our upcoming webinar with experts from AWS, CloudBerry Lab, and the Town of Edgartown IT to discuss best practices for simplifying online backup management and cutting costs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article explains how to install and use the NTBackup utility that comes with Windows Server.
This article describes my battle tested process for setting up delegation. I use this process anywhere that I need to setup delegation. In the article I will show how it applies to Active Directory
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Microsoft Active Directory, the widely used IT infrastructure, is known for its high risk of credential theft. The best way to test your Active Directory’s vulnerabilities to pass-the-ticket, pass-the-hash, privilege escalation, and malware attacks …

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question