Problem with WNLB with virtualised CAS Servers

Dear Experts,

I have following environment:

2 x CAS EXchange 2010 Servers
2 x MB Exchange 2010 Servers

MB Servers are configured with DAG and working fine, now i am trying to configure  WNLB on CAS Servers, The operating System i have is Windows Server 2008 R2 SP1, All Servers are in same VLAN.

Issue:
I created NLB Cluster on CAS01 and all went ok, as soon as i added CAS02 in that cluster. CAS01 cannot ping to MB 02 and CAS02 cannot ping to MB 01 and vice versa.

whereas cas 01 can communicate with MB01 and CAS 02 can communicate with MB02.

Please advise asap. i am stuck with this strange issue.
MCIT-LibyaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MAS (MVE)EE Solution GuideCommented:
Hi,
FYI WNLB is not longer supported by MS Exchange team.
I strongly recommend to buy a cheap load balancer of your budget to make your systems supported by MS.
If you want to go ahead with WNLB you can reconfigure as in this article.
http://exchangeserverpro.com/how-to-install-an-exchange-server-2010-client-access-server-array/
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Peter HutchisonSenior Network Systems SpecialistCommented:
In the WNLB console, you need to fine tune the ports to determine which ports should be load balanced and which ports are server specific. See Port Rules.
Load balanced ports: 80, 443, 25, 110, 143 etc
Server ports: ICMP for pings, File and Print sharing (SMB) etc

https://technet.microsoft.com/en-us/library/bb633031.aspx
0
AkhaterCommented:
Yous issue is due the the Hyper-Visor, you have to enable Enable MAC Address Spoofing  on the NICs from inside hyperV for that to work as shown in this picture

https://msdnshared.blob.core.windows.net/media/TNBlogsFS/prod.evol.blogs.technet.com/telligent.evolution.components.attachments/13/7308/00/00/03/27/24/60/MAC%20address%20spoofing.png
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.