Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco Route Tagging Problem

Posted on 2016-10-02
12
Medium Priority
?
61 Views
Last Modified: 2016-10-02
Hello Experts,

We have created a network as shown in the topology.

The goal is for subnets/networks in LAN_SW to tagged and the tagged networks to be recognized by routers, CPE, PE CORE_P, REMOTE_PE, REMOTE_CPE and finally placed in the routing table of REMOTE_LAN_SW.

I have tagged the address 7.7.7.7/32 with tag 100 in LAND_SW. However, as you will see in show commands, the tag isn't being picked by eigrp.

Can you please take a look at the configuration and show commands and let me know where I might be going wrong?

I have attached the configuration and show commands

Kind regards

cpatte7372
CORE_P.pdf
CPE.pdf
LAN_SW.pdf
PE.pdf
REMOTE_CPE.pdf
REMOTE_LAN_SW.pdf
REMOTE_PE.pdf
RR.pdf
0
Comment
Question by:Member_2_7966113
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 5
12 Comments
 
LVL 1

Author Comment

by:Member_2_7966113
ID: 41825296
Hi Experts,

I forgot to add the topology...

Regards
Topology.jpg
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41825364
I have tagged the address 7.7.7.7/32 with tag 100 in LAND_SW. However, as you will see in show commands, the tag isn't being picked by eigrp.
What 7.7.7.7/32? I don't see that one configured anywhere. :)
0
 
LVL 1

Author Comment

by:Member_2_7966113
ID: 41825374
One moment please....
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
LVL 1

Author Comment

by:Member_2_7966113
ID: 41825375
Hi Predrag,

I meant prefix list

ip prefix-list TAG seq 5 permit 7.7.7.7/32

Cheers
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41825376
There is no 7.7.7.7/32, should be received from somewhere to be inserted in routing table and tagged. How can you tag something that is not there?
Maybe I just can't see it... Do you have it anywhere?
0
 
LVL 1

Author Comment

by:Member_2_7966113
ID: 41825389
In LAN_SW, there is the following prefix list

ip prefix-list TAG seq 5 permit 7.7.7.7/32
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41825396
That is command for tagging, but you do not have that network present.
So, what are you tagging??

7.7.7.7/32 is not present in the routing table of any device (not configured anywhere and not in routing table of any device).

Simplification:
You need to have paper and pen to sign a paper. Pen it your prefix list.
If you want to sign a paper you need to have paper. Route is paper.
Where is your paper???
0
 
LVL 1

Author Comment

by:Member_2_7966113
ID: 41825452
OK,

I added the following static route

ip route 7.7.7.7 255.255.255.255 ethernet 0/0

LAN_SW#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(100)/ID(9.9.9.9)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 50.50.50.50/32, 0 successors, FD is Inaccessible, tag is 10
        via 192.168.0.2 (307200/51200), Ethernet0/0
P 100.100.100.100/32, 0 successors, FD is Inaccessible, tag is 10
        via 192.168.0.2 (307200/51200), Ethernet0/0
P 192.168.0.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0
P 10.0.40.0/30, 1 successors, FD is 281600, tag is 100
        via Rconnected (2560000/0)
P 2.2.2.2/32, 1 successors, FD is 307200, tag is 10
        via 192.168.0.2 (307200/51200), Ethernet0/0
P 6.6.6.6/32, 0 successors, FD is Inaccessible, tag is 10
        via 192.168.0.2 (307200/51200), Ethernet0/0
P 1.1.1.1/32, 1 successors, FD is 128256, tag is 100
        via Rconnected (2560000/0)
P 9.9.9.9/32, 1 successors, FD is 128256, tag is 100
        via Rconnected (2560000/0)
0
 
LVL 1

Author Comment

by:Member_2_7966113
ID: 41825462
Hi Predrag

I see where I was going wrong.

As you suggested the, the first problem was not having the static route in first place.

The second problem was because I forgot the following command:

redistribute static metric 1000 0 255 1 1500 route-map TAG

Regards
0
 
LVL 31

Accepted Solution

by:
Predrag earned 2000 total points
ID: 41825467
router eigrp 100
redistribute connected metric 1000 0 255 1 1500 route-map TAG
redistributing directly connected networks (like loopback - so you can create loopback)
interface loopback1
 ip add 7.7.7.7 255.255.255.255
ip route 7.7.7.7 255.255.255.255 ethernet 0/0
redistribute static - redistribute static route into EIGRP (static routes that are placed in routing table)

So, that should be it. :)
0
 
LVL 1

Author Closing Comment

by:Member_2_7966113
ID: 41825477
Hi Predrag, got there in the end. Cheers mate.
0
 
LVL 31

Expert Comment

by:Predrag
ID: 41825541
You're welcome.
;)
0

Featured Post

Create the perfect environment for any meeting

You might have a modern environment with all sorts of high-tech equipment, but what makes it worthwhile is how you seamlessly bring together the presentation with audio, video and lighting. The ATEN Control System provides integrated control and system automation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

During and after that shift to cloud, one area that still poses a struggle for many organizations is what to do with their department file shares.
As managed cloud service providers, we often get asked to intervene when cloud deployments go awry. Attracted by apparent ease-of-use, flexibility and low computing costs, companies quickly adopt leading public cloud platforms such as Amazon Web Ser…
Monitoring a network: why having a policy is the best policy? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the enormous benefits of having a policy-based approach when monitoring medium and large networks. Software utilized in this v…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

660 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question