• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 50
  • Last Modified:

Why sharepoint kept on promtping for password while logging on?

This is using MS Sharepoint server 2013. This server has been setup and configured with some settings a couple of months. However, when the user logon, he or she has to key in passwords several times before accessing. What could be went wrong with it, and how to solve the problem?

Thanks,
0
MichaelBalack
Asked:
MichaelBalack
  • 6
  • 4
  • 3
  • +1
1 Solution
 
helpfinderIT ConsultantCommented:
I assume user is using web browser to access SharePoint content.
Are users using different browser than Internet Explorer? Could user try with IE if the behaviour is the same?
0
 
MichaelBalackAuthor Commented:
Hi Help finder,

I will try to access using is only.
0
 
Pawan KumarDatabase ExpertCommented:
Seems like your password has been changed recently and it was saved in credential manager.
Try clearing the data from credential manager.


If the above doesnt work try below.

Web.config file

Location -> C:\inetpub\wwwroot\80 or 90

Try Adding below entries there.

<add verb="OPTIONS" allowed="false" />
<add verb="PROPFIND" allowed="false" />

Open in new window


Enjoy !Pawan
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
MichaelBalackAuthor Commented:
Hi Pawan,

Sure, I will apply the suggested values when back to office tomorrow.
0
 
MichaelBalackAuthor Commented:
Hi Pawan,

The exact location for web.config file is, C:\program files\common files\microsoft shared\web server extensions\15\templates\layouts

However, after adding in the 2 lines as suggested, I can't browse the sharepoint home page.

Please see attached web.config file
web.config
0
 
Pawan KumarDatabase ExpertCommented:
Hi,

No no, Dont change that config file, that is for something else.

Let me check some other option, you are sure that you dont have config file @ C:\inetpub\wwwroot. Right ?
0
 
MichaelBalackAuthor Commented:
Yes, confirm don't have
0
 
Pawan KumarDatabase ExpertCommented:
Have you tried clearing the credential manager..
0
 
Walter CurtisSharePoint AEDCommented:
Don't touch the web config file for this. If the user can log in once, even if they have to try multiple times, that indicators that the web config file is fine. Modifying that file can lead you down a long path to destruction of your SharePoint farm.

It is likely user issues, or possibly a sporadic connection to the AD controller or possibly network issues. Troubleshoot in those directions and you will find the issue.
0
 
Walter CurtisSharePoint AEDCommented:
Any luck?
0
 
MichaelBalackAuthor Commented:
I added the sharepoint url into the IE's Intranet, and also in Internet options, tick "remember the current user and password".

Tested few days, and looks like the prompting gone.
0
 
Walter CurtisSharePoint AEDCommented:
Excellent!
0
 
Pawan KumarDatabase ExpertCommented:
Great to hear that !!
0
 
MichaelBalackAuthor Commented:
Thank for all the experts' suggestions, that led to the mentioned solution. Thanks a lot
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 6
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now