IIS suddenly not working after Windows 10 update

Abiel de Groot
Abiel de Groot used Ask the Experts™
on
Hello all,
I have been using IIS on my PC (Running Windows10) for developing my Classic ASP web sites for several months with no problems. Then last Friday there was a Windows 10 update which seemed fine until I tried to run any of my websites. I now get this error:
----------------------------------------------------------------
HTTP Error 503. The service is unavailable.
----------------------------------------------------------------
It is extremely bad timing … sometimes I could kill Microsoft!

Any advice would be very welcome.

On Thursday it all worked well.

Kind regards

Abiel de Groot Sanders
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Check the Event Log, you may have a module which need upgrading
bbaoIT Consultant

Commented:
commonly this error occurs if the application pool that is associated with your web application doesn't start, probably caused by a configuration change in a updated IIS component. you may try checking  Windows System Log to find errors from the Microsoft-Windows-WAS source. if your application pool fails to start, it should be logged there.
Senior Technical Lead
Commented:
Hi,

Looks like the latest Windows update installed or upgraded the 'IIS URL Rewrite Module2' ? You can confirm this in Add/Remove features section. If this is the case then uninstalling the existing version of 'IIS URL Rewrite Module2' then install it back from 'Web platform installer' >select Url Rewrite from Products from server section and install.

If the issue still persists, I would suggest to uninstall all the latest windows updates (just prior to the issue) from the machine and test
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Distinguished Expert 2018

Commented:
First thing to do is of course to open Services.msc and check whether the IIS Service is still running.
bbaoIT Consultant

Commented:
> check whether the IIS Service is still running.

it must be running otherwise the user could not see that error message in the browser, hehe.
Abiel de GrootDeveloper

Author

Commented:
Hi Guys. I will go over these one by one. I will get back to you.
Distinguished Expert 2018

Commented:
It could be that the ACL for the url got corrupted.
See https://blogs.msdn.microsoft.com/dparys/2009/02/05/service-unavailable-http-error-503-mit-iis-7-auf-windows-7/ (this is in german). So either use google translator on that site or follow my quick guide:
1 open an elevated cmd
2 netsh [Enter] http [Enter]
output and find the section that corresponds to the encircled section in my link, and copy and paste it to a text file in order to be able to restore it (just in case the next action does not solve it)
3 netsh http delete urlacl url=http://+:80/

Good luck.
Abiel de GrootDeveloper

Author

Commented:
Sorry for the delay but Finally got the problem solved, with professional help.

Firstly might I strongly discourage anyone from seeking help from Microsoft, in the form of their Assure Tech support at $150. (I would have paid 10 times that) They took control of my PC and left it in a state where it would not even start.

The Server cure was 'IIS URL Rewrite Module2' Thank you Radhakrishnan Rajayyan

However, further authentication issues were solved by resetting permissions on the both the root folder wwwroot and the database folder.

Many thanks

Abiel M de Groot Sanders
Abiel de GrootDeveloper

Author

Commented:
Many thanks

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial