• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 37
  • Last Modified:

MS Server ActiveSync doesn't work for Exchange 2010, what shall I do?

This is using altogether 5 Exch 2010 (w/sp1) servers. 3 CAS, 2 HT/MB. CAS is using NLB. Recently, found that my handphone stopped to receive any incoming email. How should I troubleshoot to get whole thing back in life again.

Thanks in advance.
0
MichaelBalack
Asked:
MichaelBalack
  • 4
  • 2
  • 2
1 Solution
 
MASTechnical Department HeadCommented:
Hi,
First of all you are running unsupported version of Exchange. You have to upgrade to Exchange 2010 SP3 ASAP.
Please test activesync https://testconnectivity.microsoft.com/ and check for errors in the result
2
 
Todd NelsonSystems EngineerCommented:
MAS is correct.  Update your Exchange 2010 servers with SP3 and UR21 for SP3 to be in support if you have to call Microsoft.  Also, testing from exrca.com (as MAS stated) will help to identify possible errors.

Upgrade in this order ... CAS servers first, HT servers second, and Mailbox servers last.  In your case, HT and MB are combined and will be done together.

Is the "handphone" an Apple iPhone?  What iOS version?  If it's iOS 10, I've heard of some issues with ActiveSync.
0
 
MichaelBalackAuthor Commented:
Samsung android
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Todd NelsonSystems EngineerCommented:
Did you run the ActiveSync test?  If so, what was the result?

I have heard of many issues with Android and specifically Exchange 2010 SP1.  What version of Android?  Any other types of phones work or not?
0
 
MichaelBalackAuthor Commented:
Hi Todd and MAS,

This MS Activesync problem is a perennial issue. It was because the DNS resolution issue by the primary AD DNS server. Restarting both the exch and this DC solve the problem.
1
 
MASTechnical Department HeadCommented:
Glad to know it is fixed and thanks for sharing the solution.
Please arrange a weekend and update your server to SP3.
https://www.microsoft.com/en-us/download/details.aspx?id=36768
If possible update to RU13  after update to SP3.
https://support.microsoft.com/en-us/kb/3141339
Take a full backup before update.

Cheers
MAS
0
 
MichaelBalackAuthor Commented:
Hi MAS,

Sure, we are planning to have a downtime to upgrade all the 5 exch servers.
0
 
MichaelBalackAuthor Commented:
By using the method I mentioned, I managed to get the ActiveSync works
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

  • 4
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now