IIS-W3SVC-WP Warning in Event Viewer

I've poured through a handful of troubleshooting guides to resolve this and haven't had any luck. I'm on Server 2008 R2 IIS 7.5

I'm basically in the same boat as this guy: https://www.experts-exchange.com/questions/23728157/Event-ID-2264-The-directory-for-caching-compressed-content-directory-name-is-invalid.html

Any thoughts on how to resolve this would be helpful

error-log.PNG
nflynn85Asked:
Who is Participating?
 
nflynn85Author Commented:
So the previous switching dynamic off, enabling static only and doing an iisreset did not fix the issue.

Before I go creating a new temp folder, I noticed that the IIS temp folder for compressed files did not have IIS_IUsrs in the security tab so I added that there and did an iisreset. Monitoring logs to see if the error persists.
0
 
Emmanuel AdebayoGlobal Windows Infrastructure Engineer - ConsultantCommented:
There is deadlock in the application and it's causing the app pool to crashed. You will need to install IIS Debugging Tool to capture the capture and for analysis.

You can download from IIS debugging tool from the link below

https://www.microsoft.com/en-us/download/details.aspx?id=49924

Regards
0
 
Dan McFaddenSystems EngineerCommented:
In IIS Manager, you need to verify that the configured directory for the temporary storage of compressed , exists.  The event error details tell you the actual issue:


Description:
The directory specified for caching compressed content C:\inetpub\temp\IIS Temporary Compressed Files\DefaultAppPool is invalid.  Static compression is being disabled.

Technet reference:  https://technet.microsoft.com/en-us/library/cc735199%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

In IIS Manager, do the following:
1. select the server, this lists all features configurable at the server level
2. under the IIS section, open the "Compression" feature
3. under the static compression section, check that the defined "Cache directory" exists.

If the directory does not exist, create a directory in a location that has enough free space as to not disrupt the operation of the server OS.  Then set the Cache directory to this new directory path.

Dan
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
nflynn85Author Commented:
Dan, the directory exists. What do you recommend for next steps?

Capture.PNG
0
 
Dan McFaddenSystems EngineerCommented:
I would verify the permissions on the folder above.  I would also just enable static compression.

Do an IISRESET and check for alerts.

Dan
0
 
nflynn85Author Commented:
I disabled dynamic compression and enabled static compression and performed an iisreset. I'll monitor the logs and report back
0
 
Dan McFaddenSystems EngineerCommented:
It might be worth trying to create a new temp directory for compressed files.  Just be aware of NTFS permissions...

Link:  https://forums.iis.net/t/1163821.aspx

Dan
0
 
nflynn85Author Commented:
I believe adding the IIS_USRS to the folder resolved the issue, I have not seen the warning come up again since my last post. Thanks for the assist!
0
 
nflynn85Author Commented:
Dan got me on the right track, but my own resolution resolved the issue
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.