GPO policy being denied

Posted on 2016-10-05
Last Modified: 2016-10-05
I have created a GPO computer based policy for the deployment of an .msi in a test environment  It is succeeding on one client but failing on  another.  GPresult, attached, report.htm shows that the policy is being denied.  I have gone through an extensive list of troubleshooting tips described here, but have not been able to resolve the issue.  Any thoughts?
Question by:HeilandS
  • 4
  • 3
LVL 38

Expert Comment

by:Adam Brown
ID: 41830687
The GPO status shows as "Empty" on your report, which suggests the GPO has the installation using the Computer Settings section instead of the User Settings section. Try to run your report against the Computer's context instead of your user's context.

That said, also make sure this GPO is linked to an OU with computer objects in it. If you want the installation to occur for a specific group of users rather than a group of computers, then you need to change the GPO so it uses the User Settings\Software Deployment section instead of Computer Settings\Software Deployment.

Author Comment

ID: 41830692
I do want the installation to occur for a specific group  of computers.  How do I run the report against the computer context?
LVL 38

Accepted Solution

Adam Brown earned 500 total points
ID: 41830703
gpresult /SCOPE computer /H c:\file.html

Open in new window

on one of the computers should do it for you.
NAS Cloud Backup Strategies

This article explains backup scenarios when using network storage. We review the so-called “3-2-1 strategy” and summarize the methods you can use to send NAS data to the cloud


Author Comment

ID: 41830728
I'm getting an access denied when I try to use the /SCOPE computer.  I tried logging on a a local admin as well.  Same result.
LVL 38

Expert Comment

by:Adam Brown
ID: 41830733
Right click the CMD and select Run as administrator before running the command.

Author Comment

ID: 41830753
It shows that the policy has been applied.  There is just no evidence that my .msi ran.  I'll owrk on troubleshooting that next.

Thank you for your help!
LVL 38

Expert Comment

by:Adam Brown
ID: 41830775
You usually have to reboot the computer after the policy is applied to get the installation to run when it's done through Computer Settings in a GPO.

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Child domain picking up very stale DNS records 5 93
GPO Not being Applied 3 25
Evicting A cluster Node in windows server 2012 R2 5 54
SOFS cluser offline 3 44
The article will show you how you can maintain a simple logfile of all Startup and Shutdown events on Windows servers and desktops with PowerShell. The script can be easily adapted into doing more like gracefully silencing/updating your monitoring s…
The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
In this Micro Tutorial viewers will learn how to restore single file or folder from Bare Metal backup image of their system. Tutorial shows how to restore files and folders from system backup. Often it is not needed to restore entire system when onl…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now