Solved

GPO policy being denied

Posted on 2016-10-05
7
23 Views
Last Modified: 2016-10-05
I have created a GPO computer based policy for the deployment of an .msi in a test environment  It is succeeding on one client but failing on  another.  GPresult, attached, report.htm shows that the policy is being denied.  I have gone through an extensive list of troubleshooting tips described here http://social.technet.microsoft.com/wiki/contents/articles/22457.10-common-problems-causing-group-policy-to-not-apply.aspx, but have not been able to resolve the issue.  Any thoughts?
0
Comment
Question by:HeilandS
  • 4
  • 3
7 Comments
 
LVL 39

Expert Comment

by:Adam Brown
ID: 41830687
The GPO status shows as "Empty" on your report, which suggests the GPO has the installation using the Computer Settings section instead of the User Settings section. Try to run your report against the Computer's context instead of your user's context.

That said, also make sure this GPO is linked to an OU with computer objects in it. If you want the installation to occur for a specific group of users rather than a group of computers, then you need to change the GPO so it uses the User Settings\Software Deployment section instead of Computer Settings\Software Deployment.
0
 

Author Comment

by:HeilandS
ID: 41830692
I do want the installation to occur for a specific group  of computers.  How do I run the report against the computer context?
0
 
LVL 39

Accepted Solution

by:
Adam Brown earned 500 total points
ID: 41830703
gpresult /SCOPE computer /H c:\file.html

Open in new window

on one of the computers should do it for you.
0
Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

 

Author Comment

by:HeilandS
ID: 41830728
I'm getting an access denied when I try to use the /SCOPE computer.  I tried logging on a a local admin as well.  Same result.
0
 
LVL 39

Expert Comment

by:Adam Brown
ID: 41830733
Right click the CMD and select Run as administrator before running the command.
0
 

Author Comment

by:HeilandS
ID: 41830753
It shows that the policy has been applied.  There is just no evidence that my .msi ran.  I'll owrk on troubleshooting that next.

Thank you for your help!
0
 
LVL 39

Expert Comment

by:Adam Brown
ID: 41830775
You usually have to reboot the computer after the policy is applied to get the installation to run when it's done through Computer Settings in a GPO.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Understanding the various editions available is vital when you decide to purchase Windows Server 2012. You need to have a basic understanding of the features and limitations in each edition in order to make a well-informed decision that best suits y…
Resolve DNS query failed errors for Exchange
This tutorial will walk an individual through the process of configuring basic necessities in order to use the 2010 version of Data Protection Manager. These include storage, agents, and protection jobs. Launch Data Protection Manager from the deskt…
This tutorial will walk an individual through the process of installing of Data Protection Manager on a server running Windows Server 2012 R2, including the prerequisites. Microsoft .Net 3.5 is required. To install this feature, go to Server Manager…

808 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question