Solved

Form in Lotus Notes Designer not showing any changes / modifications

Posted on 2016-10-05
11
21 Views
Last Modified: 2016-10-19
When I change anything on a form it does not display when Previewing in Notes. For example, I can type the text 'hello' and when I preview it does not display. It is definitely not hidden. However, if I make a copy of the form and then preview it 'hello' appears. But even further if I change 'hello' to 'hello world' on the copied form and then Preview it, only 'hello' is displayed. So it appears if I copy the form only the first modification shows.  I tested this by creating a brand new blank form, typed 'hello' on line 1, previewed it and it displays 'hello'. I then add more text, and when I preview it still shows only 'hello'. This is almost similar to a 'caching' issue on web pages where latest modifications are not displayed until cache refreshed. Is there something similar in Domino/Notes?
I'm using 8.5.2 FP4
What is weird is that this is occurring in more than one database.
I've already tried fixup.
Any ideas?
0
Comment
Question by:an_cwc
  • 6
  • 5
11 Comments
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41831277
I never use that button, so I don't really know what should happen when it's pushed. I assume that you have to save the form before previewing in Notes, or that you have to close the form in Notes before trying again.
0
 

Author Comment

by:an_cwc
ID: 41831418
correct. You need to save before previewing. But same thing happens, for example, from a view, i.e. if you have a button to create a new doc based on that form.
How do you preview your modifications?
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41831656
Eh, I don't... Maybe I'm using Notes for so long that I know what's the screen going to look like. I have Notes open and I just open the form in Notes, without using the button in the Designer. The button is added somewhere in the R5 or R6 version I think, and I'm mentally stuck in R3 and R4... ;-)  No, not quite, but is was never an issue for me to open elements directly in Notes.

What you should know as well is that Notes shares its memory with the Designer. So if you have an open form in the Notes client, you modify it in the Designer and you open another form, I expect the newly opened document to be displayed with the old form, it being retrieved from cache. So, sometimes you have to close elements both in the Designer and in Notes to make Notes fetch the new element from scratch.
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Author Comment

by:an_cwc
ID: 41832991
Definitely didn't have open form in Client.
I've also exited and restarted both Client & Designer.
Another strange discovery. Was working with the same form this morning on my laptop and not having the same problem - same environment. Seems to happening on my desktop, however, I'm sure it was also happening on my laptop previously.
0
 
LVL 46

Assisted Solution

by:Sjef Bosman
Sjef Bosman earned 500 total points
ID: 41833079
Only one solution: it's time to upgrade to R8.5.3 or better, to R9.0.1.
0
 

Author Comment

by:an_cwc
ID: 41837619
Thanks Sjef - not in the near future plans - would like to go to R9 but there is an issue with MYOB we have to sort out as we use Lotuscript to import from MYOB via ODBC and MYOB ODBC is 32 bit. I think my network support guys mentioned R9 only being 64 bit, but have to investigate that further when time permits. For now, I'll have to make mods to my forms and then when I'm happy I'll create a copy and then delete the original so that all my mods come through. Thanks for your input though.
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41837711
Create a VM with an R9 Designer client, and use that as development environment. Simple and effective. I have one for R8.5, for a similar reason: the client doesn't want to cross-certify my id, and switching back and forth between ids all the time is a serious pain in the neck...
0
 

Accepted Solution

by:
an_cwc earned 0 total points
ID: 41844425
A bit beyond what I want (and have the ability to do. Will just have to live with it for now.
Do I close this now or how to proceed as there is no clear solution?  Am I able to award points for providing useful information though?
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41844536
You could accept one of your own answers (for which you won't get any points yourself) and give "supporting acts" a few bob. By the way, do try to get an R8.5.3 version, it might (and most likely will) do a lot better.
0
 

Author Closing Comment

by:an_cwc
ID: 41849730
no real solution at this stage as would only know if resolved by upgrading, but wanted to close question
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41849743
Thanks. You could maybe start with an update to R8.5.3 latest FP. We experienced quite some problems with R8.5.2...
0

Featured Post

Active Directory Webinar

We all know we need to protect and secure our privileges, but where to start? Join Experts Exchange and ManageEngine on Tuesday, April 11, 2017 10:00 AM PDT to learn how to track and secure privileged users in Active Directory.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For Desktop Techs: How to retain a user's Notes configuration data when swapping out the end user's computer. (Assuming that you are not upgrading to a completely different version of Notes client) All you need to do is: 1) install Notes o…
You’ve got a lotus Domino web server, and you have been told that “leverage browser caching” is a must do. This means that we have to tell the browser everywhere in the web to use cache. In other words, we set (and send) an expiration date in the HT…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question