Solved

Form in Lotus Notes Designer not showing any changes / modifications

Posted on 2016-10-05
11
25 Views
Last Modified: 2016-10-19
When I change anything on a form it does not display when Previewing in Notes. For example, I can type the text 'hello' and when I preview it does not display. It is definitely not hidden. However, if I make a copy of the form and then preview it 'hello' appears. But even further if I change 'hello' to 'hello world' on the copied form and then Preview it, only 'hello' is displayed. So it appears if I copy the form only the first modification shows.  I tested this by creating a brand new blank form, typed 'hello' on line 1, previewed it and it displays 'hello'. I then add more text, and when I preview it still shows only 'hello'. This is almost similar to a 'caching' issue on web pages where latest modifications are not displayed until cache refreshed. Is there something similar in Domino/Notes?
I'm using 8.5.2 FP4
What is weird is that this is occurring in more than one database.
I've already tried fixup.
Any ideas?
0
Comment
Question by:an_cwc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41831277
I never use that button, so I don't really know what should happen when it's pushed. I assume that you have to save the form before previewing in Notes, or that you have to close the form in Notes before trying again.
0
 

Author Comment

by:an_cwc
ID: 41831418
correct. You need to save before previewing. But same thing happens, for example, from a view, i.e. if you have a button to create a new doc based on that form.
How do you preview your modifications?
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41831656
Eh, I don't... Maybe I'm using Notes for so long that I know what's the screen going to look like. I have Notes open and I just open the form in Notes, without using the button in the Designer. The button is added somewhere in the R5 or R6 version I think, and I'm mentally stuck in R3 and R4... ;-)  No, not quite, but is was never an issue for me to open elements directly in Notes.

What you should know as well is that Notes shares its memory with the Designer. So if you have an open form in the Notes client, you modify it in the Designer and you open another form, I expect the newly opened document to be displayed with the old form, it being retrieved from cache. So, sometimes you have to close elements both in the Designer and in Notes to make Notes fetch the new element from scratch.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:an_cwc
ID: 41832991
Definitely didn't have open form in Client.
I've also exited and restarted both Client & Designer.
Another strange discovery. Was working with the same form this morning on my laptop and not having the same problem - same environment. Seems to happening on my desktop, however, I'm sure it was also happening on my laptop previously.
0
 
LVL 46

Assisted Solution

by:Sjef Bosman
Sjef Bosman earned 500 total points
ID: 41833079
Only one solution: it's time to upgrade to R8.5.3 or better, to R9.0.1.
0
 

Author Comment

by:an_cwc
ID: 41837619
Thanks Sjef - not in the near future plans - would like to go to R9 but there is an issue with MYOB we have to sort out as we use Lotuscript to import from MYOB via ODBC and MYOB ODBC is 32 bit. I think my network support guys mentioned R9 only being 64 bit, but have to investigate that further when time permits. For now, I'll have to make mods to my forms and then when I'm happy I'll create a copy and then delete the original so that all my mods come through. Thanks for your input though.
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41837711
Create a VM with an R9 Designer client, and use that as development environment. Simple and effective. I have one for R8.5, for a similar reason: the client doesn't want to cross-certify my id, and switching back and forth between ids all the time is a serious pain in the neck...
0
 

Accepted Solution

by:
an_cwc earned 0 total points
ID: 41844425
A bit beyond what I want (and have the ability to do. Will just have to live with it for now.
Do I close this now or how to proceed as there is no clear solution?  Am I able to award points for providing useful information though?
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41844536
You could accept one of your own answers (for which you won't get any points yourself) and give "supporting acts" a few bob. By the way, do try to get an R8.5.3 version, it might (and most likely will) do a lot better.
0
 

Author Closing Comment

by:an_cwc
ID: 41849730
no real solution at this stage as would only know if resolved by upgrading, but wanted to close question
0
 
LVL 46

Expert Comment

by:Sjef Bosman
ID: 41849743
Thanks. You could maybe start with an update to R8.5.3 latest FP. We experienced quite some problems with R8.5.2...
0

Featured Post

Enroll in May's Course of the Month

May’s Course of the Month is now available! Experts Exchange’s Premium Members and Team Accounts have access to a complimentary course each month as part of their membership—an extra way to increase training and boost professional development.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I thought it will be a good idea to make a post as it will help in case someone else faces these issues. I trust this gives an idea how each entry in Notes.ini can mean a lot for the Domino Server to be functioning properly. This article discusses t…
Article by: Rob
Notes 8.5 Archiving Steps and Tips This article covers setting up a Notes archive, and helps understand some of the menu choices making setting up and maintaining a Notes archive file easier.
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question