Question about numeric and alpha caricatures when outputting?

Hi,

Is it possible to change the viewing, reporting and printing to see its Alpha setting instead? I created drop down menus from control boxes. The menus work well but when you view the data you see the numeric ID associated to it. Example, I created a drop down menu for US States. You select NJ as your choice. When you view or print, you see a 16 instead of NJ. I know the 16 is shown because it is NJ's numeric ID within the menu choices.

How do I change this to display Alpha instead of numeric?
Thanks
Earl
Earl WolfAsked:
Who is Participating?
 
Helen FeddemaConnect With a Mentor Commented:
Column widthsIf the number is in the 1st column (it usually is), just make that column width 0 to hide it.
0
 
Jim HornMicrosoft SQL Server Developer, Architect, and AuthorCommented:
Please give us a screen shot of what you're trying to pull off here, and specify if you are using Access Forms/Reports or SSRS.
0
 
PatHartmanConnect With a Mentor Commented:
When you want to include the lookup value in your output, you must include a join to the lookup table and select the alpha value from there.

Select MainTable.CustID, MainTable.CustName, StateTable.StateName From MainTable Left Join StateTable
ON MainTableStateID = StateTable.StateID;

You can include the ID field or not depending on how you are using the query.  You will need the ID field ONLY if you are using the query as the RecordSource for a form or VBA procedure where StateID may need to be updated.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
Jim HornConnect With a Mentor Microsoft SQL Server Developer, Architect, and AuthorCommented:
>How do I change this to display Alpha instead of numeric?
Make sure the zero in the Data Widths is for the numeric, and make sure the Bound Column number is for the Alpha.
And as Pat illustrated above, make sure the Record Source SQL contains both columns.
0
 
PatHartmanCommented:
Jim prompted me to reread the question.  If the problem is with the combobox itself, then Helen provided the answer.  You have to adjust the column widths.   If the problem is with a report or an export, then I provided the answer.
0
 
Earl WolfAuthor Commented:
thanks to all, I will see which issue it is. Either the comboBox or report
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.